Return to Level1Techs.com

[SOLVED] PC unstable, freezing, unknown cause

Hello guys hope you can help me here.

It’s been about 1 1/2 months now that I built my new TRX40 build with a 3960X and I’ve been fighting it now since almost the beginning to get it 100% stable.
At first it ran very well then I tried doing some memory OC (tightening timings) and got hell for it it seems, cuz I noticed very strange instability (sudden slow freezes at random intervals).
Figured out that my G.Skilll 3200 B-die kit doesn’t like the heat in my PC with 3200MHz so I dialed it down to 3066 which is now Memtest 1000% stable.
So with the weird random slow freezes now gone, the next kind of freeze has been making an appearance: freezing when left alone for the night with encoding tasks.
And here it’s getting weird, I do the SAME tasks with the SAME settings over the day and everything works without issues, then I leave the PC on over night with the next batch of encoding tasks and about 1-2hours after I leave it freezes, while I have the same programs open as I have over the day with the only difference being that I’m on the machine over the day and doing MORE stuff at the same time, like gaming for example.

How does that make sense?

So system specs (* indicates carried over from previous build):
AMD TR 3960X (slightly undervolted offset -0.03V)
Be Quiet Dark Rock Pro Cooler
*32GB G.Skill B-die RAM 3066 CL14 (Normally a 3200 kit but unstable in memtest)
ASUS Zenith II Extreme (newest BIOS 1101)
*NV 1080Ti (undervolted)
*AMD 580 (undervolted, underclocked)
*PSU: Silverstone 1200W
OS: Windows 10 LTSC 1809

Temps:
CPU: Idle ~65°C load encoding: swings between ~78°C and ~86°C at the highest
RAM: idle ~58°C load: ~72°C (this is still memtest 1000% stable)
Chipset: ~91°C (fan is mostly blocked due to GPU)
Note: Those are DAY temps; they are LOWER over night due to cold air and PC only freezes up over night.

I’m honestly at my wits end here and have never seen such a weird thing so I hope you good people can help me.
Also tagging @wendell maybe you have seen something like that.

what’s the PSU please?

also that chipset temp looks dangerous to me but I’m no expert

also OS might help

what kind of encoding tasks? might be related to it

Hmmz thats a bit toasty, although it should be capable to handle 100C.
So i don’t expect thermals to be the problem.

Do you already run the latest bios?
What Os do you use? and did you disable all power saving features inside the Os?
also in regards to your drives?

Ah yes, sry forgot those things, the PSU is a Silverstone 1200W and the OS is Windows 10 LTSC 1809. (Added to first post)
All power saving options are disabled.
Well my drives for the encoding tasks are simply a NVMe temp and an HDD output as the files rarely go over 400MB.

Yes it’s in the high area of temps, but there is nothing that I can do about it, as the case doesn’t allow more fans than are already in it, and I can’t switch around my PCIe cards in any way.
That 91°C actually lowers down to about 79°C over night, when the PC freezes funnily enough.

Damnit, sry for double posting.

Well yeah my first thoughts were since it only seems to happen,
when you are not working at your pc.
I was kinda thinking about a windows power saving setting,
that puts drives on standby when they aint used.
I was thinking maybe that could be the cull prit.

Oh I know what you mean, that is one of the first things I disable when I set up my OS, as I don’t like waiting on a drive.

1 Like

Maybe you could try to save your current bios configuration profile.
And then put everything back at stock settings and see what it does then.
Maybe dial the memory speed back a notch to like 2933mhz.

But it’s still kinda strange that it happens only over nights.
Thats why initially a power saving feature sounded the most likely to me.
But since you have disabled them, it’s likely not the cull prit either.

We need to figure out first if the issue is either hardware or software related.

I do know that random weird freezes on Threadripper can also happen,
due to a cpu that isn’t fully seated properly in the socket.
Depending on the said socket you have on the board lotus or foxconn.
But yeah when it works fine during day time, then that would not be the problem either.

Disable C-States in BIOS and see if that helps.
Also 1809 is older than your hardware, maybe that’s not optimal.

2 Likes

Good call.

I’ll dial the RAM then further back down to 2800 then leave another batch of encoding tasks running over night.

What of the many options are the C-States nowadays though?

The one thats called “C-States” and you want to set it to “disabled”. :rofl:

And what about spread spectrum?

I never messed with that, never had to. Whenever I had trouble with stability it was either running RAM that wasn’t tested or C-States. That’s why I almost exclusively suggest those two things in topics about unstable systems. :wink:

1 Like

I’d vote on that

OP, why are you on 1809?

So I checked for “C-States” and found only one option in AMD CBS “Global C-State Controll”, set it to disabled.

As for the 1809, it’s the latest Enterprise LTSC version that’s available.

Yeah i pretty much only disable it when overclocking,
because that is what mostly is being recommended.
However it technically shouldn’t really interfere much with anything.
So i also generally leave it on.

Might be a good idea just for testing.
You can save multiple profiles in the bios.

Of course you also do the run first with the C-state feature disabled like @noenken suggested.

Make sure it officially supports your hardware. TR isn’t strictly enterprise gear. Not sure how Microsoft handles this but … you know. :wink:

I’ll just let it run with 2800 and C-States disabled over night and check in the morning if it froze again, as in day usage everything is, weirdly enough, stable (<.>)".
Funnily enough I can let HCI Memtest and/or games running over night and it doesn’t freeze at all, should have mentioned that earlier…

1 Like

Keep us updated :slight_smile: