[SOLVED] PC unstable, freezing, unknown cause

I will, thank you for the suggestions until now :slight_smile:

Success for this night, 9H of encoding and not frozen.

What did I change?:
Removed undervolting offset of my CPU.
Changed RAM speed to 2866.
Disabled “Global C-State Control” under AMD CBS menu.
(Due to how these changes had to be done, also restarted the machine before leaving it alone)

I will dial the RAM speed higher again and check again.
Maybe try the undervolt again, though it seemed to not do much so I’ll leave it stock I guess.


Kind of a success for the second night.

Just upping the RAM speed to 3066 actually froze again right before I wanted to leave it alone.
I had encoded about 6H during the day when that batch finished and didn’t freeze.
The only difference being between my night run and my day run is that I left a game running in the background during the day and closed it for the night.
So after closing it and starting the next batch it forze again.

So what did I change now?:
I upped the voltage to my RAM from 1.32V to 1.34V.

Left it running again for the night and NOT frozen.

DDR4 is 1.35V in general. Even the 1.2V stuff won’t complain about a bit more juice. I always just set 1.35 manually anyway.

I lowered it mostly because I lowered the speed from 3200 to 3066 and my already high temperatures.

1.35V should be totally fine, its actually recommended to run DDR4 on that.
I would definitely suggest to try a run with that.

I’m aware it’s not an issue especially with B-die, which can run up to 1.8V for heavy OCs. I do not want to increase it anymore, if at all possible, due to the high temps, which are already about ~70°C on load only on the RAM, if you consider GPU exhaust and CPU exhaust it will get to about ~77°C or even more.
So every bit of voltage lower will decrease the “all time highs” by about 3-5°C, which in my case is a lot in terms of possible stability for B-die, since B-die is very senstive to heat and I’m already so high up with temps that I can’t even run 3200 (without erros) with my kit…

What I need at one point is a new case, but I haven’t found a good replacement yet due to my hardware (not just the E-ATX, but also my 8 drives + a RPi that is currently in a 3D-printed 5.25" bay) (⌒_⌒;)

1 Like

If stuff gets too hot while running at spec, that simply means that your cooling sucks. Also RAM is fine running a bit toasty. Just set it to 1.35v.

I’m fully aware that the cooling is inadequate (x╭╮x).
Hence my comment about the new case, but for now I have to live with it and make do.

Alright. Good luck with it.

Aside from running quite on the warmer side concearning components – did you test if your instabilities are caused by wonky idle power ? – you could try:

there typically is a setting in UEFI/BIOS called Power Supply Idle Control – try if setting it to Typical Current Idle helps.

otherwise you could try “typical” as well as “Low Current Idle” in combination with
– AMD Cool’n’Quiet (APBDIS) = Enabled
– Global C-state Control = Enabled
– PPC Adjust = PState 0

1 Like

Third night was a failure, back to the drawing board?

After about 9H and a bit it froze again, this time there was no restart before I left the PC alone.

Thank you pixelfixer for the suggestion, I haven’t tried that yet.
I’m a little confused by the “idle” and “low power” naming everywhere, because the PC is under load at the time of freezing.

Fourth night success?

What did I change?:
Increased RAM voltage to 1.35V.
Decreased FCLK from 1866 to 1800.
Left a game running in the background.
Started FFMPEG encoding task with “-threads 1”
NO restart before leaving it alone.

I hope next night will also be succesful then it may be stable…
Though if not I’ll try what pixelfixer suggested next.

Their coming to get you Barbara.

Is it possible to install the chipset driver direct from AMD? If it’s not, then C-states have to be disabled and your idle voltage should be exactly 1v or it’s not applied properly.

It sounds like your SoC voltage may be a tad bit low. I wouldn’t surpass 1.15V but around 1.14 is what I run on my 3600X for 1800 IF frequency.

If it’s high density RAM, definitely downclock the RAM and sync the IF frequency to the RAM in a 1:1 ratio.

… Anything else you fucked with for no reason? :roll_eyes:

Seriously though, just reset CMOS and if it’s still unstable then (and only then) come back for advice. It makes no sense to give advise to someone who isn’t running his system at spec in the first place.


1800 will most definitely not run stable with only 1V of SoC voltage.

I inreased the FCLK mostly to increase the core-to-core communication, if you have a 166MHz FCLK than UCLK you start to fully negate the desync negatives, at about 200MHz your latency is either the same or better than the synced, and everything above it just helps.
Since my memory doesn’t seem to do 3200 on this platform (unstable even on stock (memory errors in HCI memtest)), probably because B-die is sensitive to heat, I had/have to try to squeeze out performance whereever possible.

Buildzoid actually did a test for this you can check it out here:

SoC voltage on TR platform is default 1.1V, but I’ll see that I increase it if it freezes up again.

I have installed the chipset driver directly from the AMD package, I mostly don’t use the ones delivered by the motherboard vendor, as they are in most cases older.
It is SS RAM with 8GB per DIMM.

Yeah, sounds like a SoC voltage issue, if stock is 1.1V, you may need 1.15 or higher. My hard limit is 1.2.

Alright, I’ll try that too, thank you :slight_smile: