[SOLVED] Linux Install Issue

Confirmed this issue exists on Linux Mint 20.3 and 21. Also Zorin Pro 16.1.

CPU: AMD Threadripper PRO 5975WX 32-core
Mobo: ASUS Pro WS WRX80E-SAGE SE WIFI (Latest BIOS and firmware)
GPU: MSI SUPRIM X 3090
RAM: 128GB
3 x NVMe (2TB, 4TB, 4TB) Windows 10 is on the 2TB drive.

On boot, my USB mouse / keyboard wakes up (plugged directly into the rear of the mobo) and I press F2 for BIOS. I boot from the Live USB and select the normal install. I see this:

There is a third revalidation line, but it goes by very quickly as the logo screen appears over it. After several minutes, the logo disappears and I see hundreds of stdin errors followed by “Attempt interactive netboot from a URL?” but the keyboard and mouse are dead. I plugged in another USB KB at this point, but it was not detected and also dead. I’ve used both KB successfully with Mint previously.

So I cannot get past this point in the install. Compatibility mode install gives the same symptoms. Looks like a USB driver issue, but not sure how to get past this point.

Tried turning off XHCI Hand off on the mobo, but got the same behavior.
Changed AHCI to RAID

Tips appreciated.

Tips appreciated.

Make sure Fast Boot and CSM are disabled. ETA: Oh, and make sure Secure Boot isn’t set to Windows.

did you download the correct image?
looks like your trying to run a static install of a live image.
meaning you installed a live version to your hdd rather than the iso version for hdd/ssd/nvme
if so download and install the iso version not the live cd/usb version.

Likely that the usb has not been written properly. Use dd in linux or BalenaEtcher in Windows. Sometimes those tend to fail and Rufus works, sometimes rufus fails, but etcher works. Trial and error.

For a new workstation, I’d suggest you go with Pop!_OS if you want an ubuntu base. After you finish installing, make sure you post your neofetch on the neoflex thread.

Keep in mind Mint has older version of the linux kernel. With this kind of a setup, you should not go with anything lower than linux 5.18, preferably 5.19 if you can. You can try to install Mint via chroot from an Arch live-boot and upgrade the kernel mint uses to the latest 5.19 you can get your hands on.

Started with an Live USB with Mint 20.3 that I have used on three PC’s (written with Rufus). Then redid it with Mint 21 (Rufus), then last, Zorin Pro written with BalenaEtcher. I’ve done a dozen Mint installs from the Live CD and never had this issue.

The Mint 21 USB installed on a Linux VM on my home lab after failing on my workstation. Not an image issue I think. Looks to me like the mobo USB is failing to be registered correctly.

EDIT: All images SHA265 checksum were on the money as well.

@HEXiT - Will try that next.

1 Like

Try a dedicated live cd like systemrescuecd, it includes a memtest that you can run. If memtest passes and it boots then see if it can see the storage (lsblk at cli).

remember to install with iso mode.
not dd mode.
if you use dd mode the installer will ask you for drivers rather than installing the generic ones, which while aint always the latesst, will get you up and running.

So, update time.

They just released 16.2 Zorin and their Support advised me to try that given the improvement in drivers. Had better luck, but ultimately got stuck in the same place.

To be clear. I created the USB from the 16.2 Zorin PRO ISO. Hash values were correct for the downloaded ISO. I booted direct to the USB through BIOS. Process is to boot the LiveCD off the USB then install from there. Same with Mint and I have the same issue with that distro.

After selecting the installer I see this:

Then I get the ASUS and Zorin Logo as everything installs. This is better than before.

Eventually this screen pops up. No keyboard or mouse is active and I have no option but to reset.

Side note, I tried “pci=nommconf” in the syslinux.cfg file from another thread on here, but that changed nothing. Latest BIOS and firmware installed.

Question for anyone with a ASUS Pro WS WRX80E-SAGE SE WiFi mobo. What distros work for you and I’ll give one of them a try.

Cheers.

I can confirm the following fix worked for me. Thanks to @stevemg9 for the reference in this thread.

Set the VGA_SW to disable and was able to boot a Kubuntu ISO on USB to live CD. Followed that up with a Zorin PRO 16.2 and to make sure the latest Linux Mint. All worked as required.

Location of the switch is shown on page 1-22 of the ASUS Pro WS WRX80E-SAGE SE WIFI user manual.

2 Likes