[Solved]Computer still boots into W10 even with lubuntu as the first boot drive

so i’m not sure what the deal is, but after installing lubuntu on one of my drives in my system. i tried to boot directly from that drive (via f12 to make sure windows didn’t get a chance) but windows still boots instead. i looked at the drive and windows can’t “see” the drive anymore as far as how much space it has. (shows 0 bytes) so i know something is there. i installed lubuntu under ext 4 if that makes a difference.

my drive set up is this:
480GB SSD <-- windows 10
1TB 7200rpm <-- lubuntu
3TB 5200 RPM <-- data drive

lubuntu version is lubuntu-18.04-desktop-amd64

I have also tried to boot repair

i made a live USB with universal USB installer. i went to bios and made it first boot priority, saved and exited, pushed f12 for boot menu and picked the drive directly and the system booted directly into windows 10. did not pass go and gave me no option to collect 200 bucks… i did change the bios from a windows 8/10 boot set up to “other OS” thinking that may have been the issue. no help with that tweak though.

i specifically made sure that the dvd drive and the 1TB had first boot priority and disabled a 3rd boot option and still windows finds it’s way to the screen. i googled around for a quick minute and didn’t find anything of this particular issue, so i thought i would seek out external help. i’m looking to dive head first into linux as i’ve been in the windows world for the last 20 years. time to learn some new tricks. thanks for any help with this!

did you remove the windows drive when you installed lubuntu?

That sounds to me like what the problem is. it’s not seeing the bootsector of the linux drive. Try removing the windows drive. If the linux drive boots, then at least you know the drive is working.

I don’t know how to fix this though. But thought I’d throw in my two cents. Had this problem before, and I don’t remember how I fixed it.


i thought about that. 2 things come to mind with that though. i have 3 drives in a very small ITX form factor and i had to do some serious cable and drive manipulation to get all three in there as it really only supports 2 drives. another concern with that is that it does not fix the problem if i want to put the windows drive back into the mix. the drive it’s self is a good drive. all my drives show 100% health and i was using it as a windows drive before my SSD upgrade. then it’s been a data drive until i put lubuntu on it.

thank you for the input and trying to share ideas. i’m sure that would “fix” the issue… but not fix it, you know? lol

Remove the windows drive and see if you can boot lubuntu to at least confirm that side is working. If it does, one shot I would try is to re-install lubuntu with the Windows drive disconnected because (I’m kinda guessing here from what I’ve seen on my PC and not spent time researching for proof so take this as my 2c) with the Windows drive connected and due to it’s boot loader, lubuntu may have added itself to the Windows UEFI partition and you can’t boot lubuntu because the Windows boot loader is set to boot without showing you it’s options which may include lubuntu (although if this is the case you could add a timeout to windows boot loader but I don’t know how you do this).
Whenever I dual boot with UEFI, I always install on one drive with everything else disconnected - we’re technically still in the woods with UEFI boot-loaders co-existing so this way each OS can install it’s own boot-loader and exist separately.

i’ll see what i can do. i’ll be back shortly with a result.

Did you install linux or windows first?

1 Like

Edit: Wait till you hear from more experienced users before taking my advice!

I don’t think you should reinstall without the Windows drive installed. Otherwise how is grub supposed to see windows so you can dual boot?

When you installed lubuntu, did you leave the windows drive in?

Cause if you didn’t, that could be why Windows is taking priority over lubuntu.

Is lubuntu the only thing on that drive?

This is only my two cents mind you, but I think if lubuntu is on its own drive by itself, I think you should format that drive, completely, then try re-installing. Lubuntu when it sees the windows drive, should then ask you to install along side windows.

Instead, you should select ‘‘something else’’ or what seems close to that, partition the linux drive, then install. That way, grub should see that there is a windows drive, and give you options to switch between the two operating systems.

But that is my two cents. I just read my journal and that is what I had to do. Don’t take me as some linux guru, I’m still a noob.

I’ve dual booted multiple windows before, lots in my heydays. But i’m kinda new to dual booting with linux.

i disabled the windows drive through the sata port in bios. i reinstalled lubuntu and i’m now on lubuntu. the first reaction to the disabled drive was to proclaim that there was no boot media! but after a second install attempt, the installer found ubuntu already on the drive and i had to remove it and reinstall, so odd… but originally windows was installed first.

(off topic) this all came about because i wanted to learn python and the videos i was following was using linux for it. which as it is normally natively installed to linux, i thought that was the best choice.

but yea… now i will probably have to wipe this drive again since windows was disabled to get this install to work.

more answers to questions unread:

the windows drive stayed in during the first install.

lubuntu is in fact the only thing on the 1TB drive. i dedicated that drive to the linux environment.

i did format the drive while installing lubuntu the first time.

the first time it tried to install, it shows windows 10 on the SSD. the installer wanted to share the SSD. i have to go to “something else” and pick the 1TB myself. it was a bit of a hassle because i didn’t realize that “/” was “root”. but i got that sorted out.

anyway i did my best to make sure the SSD was windows only and the 1TB was linux only.

Have you disabled fast boot?

When it is enabled, shutting down windows is effectively putting it in a super sleep state. When disabled, dual booting should perform normally.

oh! good tip! i do have fast boot enabled! but why should that affect my direct approach of picking the boot drive myself?

That should have worked then.

Are there any other drives that are inbetween your windows drive and your linux drive?

@Smerrills could you elaborate on your question please? i have 3 drives and a DVD drive. but no other OS’s.

First test it to see if it is actually fast boot preventing you from booting into Linux.

As for the explanation… This article would do a better job at it than I can.

When you shut down a computer with Fast Startup enabled, Windows locks down the Windows hard disk. You won’t be able to access it from other operating systems if you have your computer configured to dual-boot. Even worse, if you boot into another OS and then access or change anything on the hard disk (or partition) that the hibernating Windows installation uses, it can cause corruption. If you’re dual booting, it’s best not to use Fast Startup or Hibernation at all.

1 Like

Your third drive, do you have that set up on the Sata ports on a port that is inbetween your linux and windows drive?

Like, say windows is on port 1, and lubuntu is on port 3, is your 3rd drive, or your dvd drive, sitting on port 2?

This shouldn’t matter, but i’ve always had my os drives be the first two drives on the sata ports.

Follow Novasty’s stuff first. If I think of anything else, I’ll give my two cents again.

oh a fast boot from windows directly? i don’t think i have that enabled? i have fast boot enabled through the bios. W10 has become such a pain to tweak with the settings, i tend to get lost in all the menus or unable to find settings i used to have in older OS’s. i kind of gave up on windows for that.

Check power options.

Control Panel\Hardware and Sound\Power Options\System Settings

Should tell you, sometimes you will need to click this to show it.

i’m not sure what drives are where “physically” with it being such a pain to just get them mounted and working i didn’t really care. lol the spaces in this case are so small i have to remove drives just to get my fingers in it lol. i knew i could change boot order so as long as they had a sata connection, i was fine when i built the system.

let me re-enable the windows drive and see how hard i bork this system up when windows sees it’s new neighbor. with out being in windows, i couldn’t tell you what the setting currently is.


sata drives are:
sata0 DVD drive
sata1 SSD windows
sata2 1TB lubuntu
sata3 3TB data drive (now disabled to remove risk of data loss)

i re-enabled the SSD and lubuntu now boots first. which after the restart, i’m still on…

Are both the Lubuntu and Windows installs shown in Grub?

i dont get the “grub” option. it just boots right in with no regard to the other OS.