Return to Level1Techs.com

[SOLVED] ASRock X570 Taichi/Gigabyte GC-Titan Ridge AIC: Thunderbolt 3 devices OK - But USB 3/DisplayPort device Hotplug causes BSoD :(

Hi,

I was very excited about an AMD system that officially supports TB3 and chose the ASRock X570 Taichi partly because of that.

Since ASRock does not offer a Titan Ridge Thunderbolt controller AIC, I got the Gigabyte GC-Titan Ridge dual port AIC.

  • The X570 Taichi is running UEFI version 1.70A
  • Gigabyte AIC installed in PCIe slot 5, USB 2.0 and TB Header cables are plugged in
  • Thunderbolt is enabled in motherboard’s UEFI
  • Using the latest versions of Win 10 1903 and the Thunderbolt drivers (1.41.648.4)

Additional details:

  • 3700X, no overclocking
  • 2 x 16 GiB Crucial ECC DDR4-2666
  • GPU: Radeon Pro WX8200 in PCIe 1
  • 0.5 m mDP-mDP (officially rated for DP 1.2) cables from GPU to TB AIC
  • The TB3 AIC is very firmly installed, doesn’t jiggle at all when plugging a device into or unplugging it from its Type C ports
  • The BSOD also appears when plugging an USB thumb drive into a connected USB 3 hub so there is absolutely no mechanical stress on the TB3 AIC.
  • Ethernet: Intel XL710 QDA2 in PCIe 3
  • All devices including X570 chipset with latest publicly released drivers available at this time

Issue:

  • The two Thunderbolt 3 Type C ports seem to work fine (tested various adapters: USB 3.1-SATA adapter, USB Type-C to 4 x Type A 10 Gbps USB hub, USB-C to HDMI/DisplayPort out) if the devices are already connected when the system is still powered off.

  • Update: When plugging in a non-Thunderbolt USB 3.x Type C device or unplugging one from the TB3 Type-C ports I get a BSoD (WHEA_UNCORRECTABLE_ERROR).

  • With a simple USB Type-C male to Type A female adapter in one og the TB ports I can connect and disconnect USB 2.0 devices without issue so the passthrough connection to the motherboard USB 2.0 header seems also fine.

  • Thunderbolt works seemingly fine, however it only negotiates a 20 GbE networking link between the GC-Titan Ridge AIC and a Mac mini 2018 (also with Titan Ridge TB3 controller) with a 2.0 m Belkin TB 3 cable that is rated for 40 Gb Thunderbolt/100 W Power Delivery (but without DisplayPort capability for some reason)

  • So it seems the Intel USB 3.1 controller and DisplayPort muxing (?) has issues ?!

Stuff I tried without any effect :frowning: :

  • Tested a second unit of the GC-Titan Ridge AIC

  • Changed the internal motherboard header and power cables to the GC-Titan Ridge AIC

  • Changed mDP ports on the GPU that are connected to the GC-Titan Ridge AIC

  • Newly installed Win 10 Pro 1903 on an erased SSD (and BIOS/MBR setup instead of UEFI)

  • New AMD chipset drivers that came out July 31st

  • Tried the more current AMD Radeon Consumer driver package instead of the enterprise one for the WX 8200

  • Tried a different GPU (NVIDIA Quadro P2000, also with DP 1.4), same result

  • Tried a different PCIe slot for the GC-Titan Ridge AIC

Any idea what’s causing this? I know that this is an unsupported configuration but I hope it can be fixed.
Any help is greatly appreciated!

Regards,

aBavarian Normie-Pleb

1 Like

Overlooked Thunderbolt notes on the X570 Taichi’s Overview (not Specifications) page:

I mean, DAFAQ?

Thunderbolt 3 AIC Header

Thunderbolt 3 is no longer limited to certain chipset, ASRock is the first motherboard manufacturer to skillfully implement the Thunderbolt 3 technology onto AMD X570 motherboards. All you need is a Thunderbolt 3 AIC R2.0 card!

*1: Only three TB3 devices can be detected.
*2 : Some USB 3.2 Type-C devices will cause system reboot after wake up from S3/S4.
*3 : Cannot light up the TB3 monitor after wake up from S3/S4, re-plug the cable is needed.
*4 : Does not support Thunderbolt 3 PCIe graphics card box.

Can we get a Kickstarter campaign to fix that mess?

1 Like

Thanks So much for posting this. Looking to build the exact same setup and was wondering if the Gigabyte AIC would work with the Asrock board.

I will be running a Pro Audio interface off the Thunderbolt port. (Presonus Quantum)

1 Like

Hi there and welcome to the forum!

That’s kind of funny since @wendell’s video about shoving Thunderbolt onto a Threadripper motherboard was the reason why I looked more and more at Level1 Techs content and eventually joined the forum.

As mentioned TB3 worked for me with its virtual Ethernet Bridge functionality but I don’t have other TB3 devices to test at the moment.

If you choose to proceed with your build it would be very helpful if you could post your experiences then.

ASRock seems to be the only option for possible Thunderbolt utilization on AMD left right now since Gigabyte pulled its tail between its legs and no longer solders the Thunderbolt Header onto its X570 motherboards :frowning:

Good news. I do have an asrock tb3 board on the way and will test hotplug

3 Likes

Thanks for the update!

SUCCESS!!
Got everything set up this evening. Just a test setup for now. Asrock X570 STeel Legend with an R7 3800X.
Gigabyte’s Titan Ridge add-in card. Installed the default drivers. Picked up my Presonus Quantum and the daisy-chained UAD 2 Satellite. All working in Presonus Studio One DAW.

I will get the proper setup going tomorrow and report any glitches, but could not be happier right now!!

4 Likes

Congratulations!

Nice to see that my positive TB3 tests were not a fluke.

Are you able to test hotplug on DisplayPort out and non-TB USB 3.x Type-C devices in the TB Type-C ports on the GC-Titan Ridge AIC?

(Note: Due to the risk of a sudden BSoD don’t have any unsaved important files open)

And can you give some more system details?

  • Windows 10 Version (1809, 1903?)

  • Used GPU? With DisplayPort 1.4?

Thanks!

1 Like

Does anyone know if there is a new Titan Ridge TB3 firmware version that maybe addresses such issues? There’s nothing on Gigabyte’s website but since the only version of this AIC is Rev 1.0 that has been out for almost a year I doubt that there haven’t been any new firmware releases for thst chipset knowing Intel…

So far.
Display ports don’t look to work at all. I only have a 1 display port monitor, so no much to go with, But nothing from those ports.

USB 3. The only device I have is my phone. No issues with lock ups or BSOD’s. But the phone does not connect as a data device. (fast)Charges just fine from those ports, but no data connection.

That sounds very weird.

Just to be sure:

  • The USB 2.0 Header cable is connected

  • The one DisplayPort cable from your GPU is plugged into one of the two mDP inputs of the AIC

  • The mDP inputs have numbers, the TB port you use for your devices has the same number as the mDP input port that is connected to your GPU

  • Thunderbolt is enabled in the motherboards UEFI

?

Display Port in? What is that for? And why 2? I would have thought that there would be more out, I never even thought that it would have a DP in.

Thunderbolt can carry a 2 DisplayPort signals to a dock or monitor.

I am still confused.

So you go DP out from the GPU in your PC to DP in on the TB card also in your PC to then go DP out to a dock? But why not just go right from the GPU in the PC, you are all ready there with the GPU?

Edit: thinking about it more only makes it more only makes it more confusing. If you are doing it to have a 1 wire solution then you still have looping nest of cables going out of and back into your PC, maybe a bit tiboer but this seems like a really strange thing to add to a TB AIC just for the sake of a very odd use case.

Well, you can ask Intel about that…

Thunderbolt is supposed to always carry DisplayPort signals meaning if you get TB via an AIC you’ll get ugly short cable loops at the back of your system.

I get that DP is probably unnecesary for most needs but that’s the way that standard is built.

Can you just not? I mean can it just do.regular thunderbolt, USB and so on without having to have a DP signal present? Seems like a really stupid requirement.

I don’t know yet.

I think, @Kdavies found that out by not connecting DP to the AIC which may mean yes.

That would be pretty interesting to test out, unfortunately I don’t have many TB devices (yet).

1 Like

I do have an intel PC that has thunderbolt but it is alpine ridge. It can do the DP and all that but being built in I never thought about it being required as it will be wired up anyway internally. I always just assumed it was mostly output so seeing the card with dedicated ins was very odd, I would have assumed at the very least they would have been bidirectional.

1 Like

UPDATE!

USB header was not fully plugged into MB. USB Type c connection now works with data transfer. I can hotplug with no issues. Connects and disconnects like a standard USB.

And I have no idea why, But the display port pass through now also works on both ports. It took an extra minute to boot up to the windows display , monitor flashing on and off while it did so. ( I may have been impatient first time around). I can hot plug with no lockups or reboots.

So it looks like all the functionality of the card works just fine.

One thing I am reporting to ASrock is that the secondary (maybe primary as well, but I don’t have a supported device). The M2 slots are disabled when Thunderbolt is enabled. Enabled Thunderbolt, M2 drive in secondary slot is gone, Disable it, It shows up again. There are no advanced thunderbolt options, just on and off. So nothing obvious to play with.

1 Like

Damn, you lucky b****** :wink:

It’s normal that the second (or third, depending on motherboard) M.2 slot does not work if the lowest large PCIe slot is occupied since they share the PCIe lanes - so no reason to contact ASRock (respectively give the manual a read).

Can you please give further system details?

  • Used Windows 10 version (1809, 1903)

  • Used grahics card

  • Motherboard BIOS version

Also it might be that your connected cell phone only uses USB 2.0 that is not known to have issues so far.