Return to Level1Techs.com

Smb mount issues in ubuntu

i swear to god i’m going to bash my head in with a desk. *buntu 20.04 LTS seems to REFUSE to bind/mount n SMB, especially with the /etc/fstab

Summary

unnamed

don’t

use

buntu


But to actually help, you’ve installed cifs-utils, right?

Also, in fstab, you’ve passed the _netdev flag?

And I’m going to need a bit more info about your mounts, if you want help.

2 Likes

_netdev flag? what’s that?

//192.168.1.123/Folder /mnt/Folder cifs username=<user>,password=<password>,uid=user,gid=user, 0 0

This is my working config for my *buntu 18.04 LTS boxes. it do not work in 20.04 LTS and as you cna clearly see there is no _netdev flag!

You mean at boot ? or like all the time ?

_netdev tells the system that it’s a network device and to not try mounting it until the network is up. Just throw it in the mount options.

1 Like

You have a trailing comma after the gid=user

Also, dumb question, are you trying to mount as root? If you are trying to mount as user, you need to add in the user flag.

1 Like

yeah otherwise needs to add the no_root_squash I think.

That’s burned me in the past.

all the time. ie Sudo mount -a = pemrissions denied.

nice to know but, it fails to mount even when i sudo mount -a, well after the network is up.

this made no change.
I do now know actually as this line “just worked” before. as long as the nextcloud service can read and write files to the network share, i’d be happy.

where would that argument go?


also FYI this line works if i set the share to public. i don’t think it’s an unraid things as i have this problem with xubuntu 20.04 LTS at home with a windows server.

ALSO i’m hosting from unraid but, NFS is broken on unraid:

Limetech’s solution is to just not use NFS as it’s old.

so i can’t use NFS, i can’t get SMB to work. i FINALLY got NC setup with LDAP integration.

I see TONS of threads with people having issues with SMB shares with ubuntu and it was WAS supposed to be fix but, either someone finds some small argument that gets it working or the threads just linger with no resolution.

My bad, I was thinking about NFS.

1 Like

I need the output of the following, verbatim*:

sudo mount -av

*obviously hide any passwords

Looks like error code -13 is invalid username/password.

You can validate this by checking dmesg | grep CIFS IIRC.

post your smb.conf on the server (or is it windows?)

also, this should be merged out of here. I can do it later if needed. getting sucked into a meeting rn.

@cdoublejj feel free to edit the thread title (if you can’t let me know)

2 Likes

Its not, I use it for my own nextcloud in exactly the way you’re doing. You’ll want to turn hardlinks off in the tunables section but it works fine otherwise.

In your mount -a output I see unc=\IP.ADD.R.ESS

This is not a UNC path though. A unc path would include the hotsname, not IP, of the host machine. Not sure if thats really a clue though.

1 Like

Just for reference, unraid running NFS mounts

Admittedly this is not a fix for your specific issue, but if you want to work around it I can point you in another direction. You’ll have to stop your array and change hardlinks to no.

2 Likes

i did try NFS and it technically worked with even though i had an IP instead of a host-name however the command line in ubuntu server was going bonkers with handling exceptions.
i’ll try again.

curious what arguments you put after the IP address under your NFS in unRaid?

Just make sure you turn off hardlinks like I showed and you should be good to go. I’m using the defaults otherwise.

1 Like

the reason i ask is because each guide i look at puts all kinds of different arguments after the IP address for the NFS settings (in unRaid) so i guess i’m not sure what it is or if it would be just an IP address?

I’m litterally just going to the shares and setting NFS to export: yes and security: public.

If you want user based auth you can do that too of course.

My screenshots are kind of a mess but the fstab in ubuntu is just: IP.ADD.R.ESS:/path/to/share /destination/folder nfs defaults 0 0

Verify it works with sudo mount -a of course. You will probably need to install the nfs-common package on the guest.