Service Host: DCOM Server process launcher Stuck at 30% CPU Help Please :(

My Desktop "Service Host: DCOM Server process launcher (6)" For some reason my CPU is stuck at 30% processing That Service thing making my PC not responsive i even try to restore my PC but it always fails I don't know what to Do? i'm using my Laptop now is there a fix?

This is how it looks like at less paint loads and file explorer

It looks like windows 10 is doing something weird. Multiple people are having this issue (e.g. )

And I suspect it is because some things are being sent over the network. Try disabling the p2p updates Windows 10 includes.

So What's the Solution?
the second link i think is unnecessary
and the first one is like mmmm?

I really don't want to nuke my OS and install it again all the way back to 8.1 :C
there is no freaking way thats is the last resort

I don't think you have to. Just disable the update sharing things and see if the usage goes down. You won't nuke your OS by using preprogrammed settings.

I can't tell for sure what is causing the issue, but the telemetry/updates in windows 10 need a lot of processing power, and this process is responsible for running those services.

i'm Currently running in safe mode to access the settings but it just crash when i click on "Update & security"

and if i run it normal mode it just Won't even start the Settings app

I found a thread on microsoft answers that says your system install might be corruted.
The solution they suggest is to run System File Checker Tool (sfc).

i'm giving that a try

so far 43% scanned
i know the last thing i did with my PC is Shutdown & Update then when i Turn it on that thing started
90% Done

it did not find any integrity Violations
i'm thinking on trying System Restore in Safe Mode

Have you tried to run the system settings as an administrator? That might be why it's not appearing when not in safe mode.
I think the update tab doesn't work in safe mode because safe mode doesn't have all the services, like network support, turned on.

But i can't Open The Settings in Normal mode :(
not even other Programs, i can't even play a Video because it won't launch

Nothing opens? That's strange. I don't know. I've never encountered that before.

Maybe you can at least open the settings as an administrator by going to C:\Windows\ImmersiveControlPanel and running SystemSettings via right-click > "Run as admin"

I try ed but the UAC pops i click yes but still Nothing :( i'm still thinking on trying System Restore on Safe mode to see if it fails or not

i'm Currently going to do a system Restore in safe Mode at least that opens maybe in safe mode might work

it say's it's been successfully restored let's see

nope nothing and it's the only restore i got :(

i think i have no choice but to nuke it

I'm sorry, I can't help with that. But when you'll be installing windows 10 for the second time try turning of all the telemetry / updates stuff you can while installing, it should help performance.

I have Windows 8.1 on Disc so it's it's going to take me Awhile to install Windows 10
with a 2MB Connection :(

that's a very odd Thing it's one of those problems that is a Mystery

thanks for trying to help me
I just need to back up a few things then Nuke it