Samba issue on KDE Antergos (Arch)

Hi Everyone,
I’m hoping to sort out a samba issue that has crept in after a recent update. I am missing something or not able to sort out what has changed in samba KDE. I’m using KDE network filesharing package so I can right click on a directory and select sharing in folder properties and share it. It was working fine till an update then nothing. I can select all of the options but the share is never created and the next time I check the properties it’s all greyed out again. I’d like to repair this because it’s my homeserver /nas/ plex host system.
I made a guide for myself to follow when I first set it up and things worked fine for some months. Here are the steps I outlined and completed.
Samba on KDE Arch Linux
Install software center or pacman:
kdenetwork-filesharing note the dependency for samba: folder sharing
ensure samba and kdenfs installed with no errors
in terminal type:
sudo mkdir -p /var/lib/samba/usershares
sudo groupadd -r sambashare
sudo chown root:sambashare /var/lib/samba/usershares
sudo chmod 1770 /var/lib/samba/usershares
sudo gpasswd sambashare -a terry (replace terry with username of choice)

now create an smb.conf file via a text editor in the terminal
sudo nano /etc/samba/smb.conf
paste this information below into the smb.conf file
workgroup = WORKGROUP
dns proxy = no
log file = /var/log/samba/%m.log
max log size = 1000
client max protocol = default
server role = standalone server
passdb backend = tdbsam
obey pam restrictions = yes
unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = NewUNIXpassword %n\n ReTypenewUNIXpassword* %n\n passwd:allauthenticationtokensupdatedsuccessfully*
pam password change = yes
map to guest = bad user
usershare allow guests = no
name resolve order = lmhosts bcast host wins
security = user
encrypt passwords = yes
guest account = nobody
usershare path = /var/lib/samba/usershares
usershare max shares = 100
usershare owner only = yes
group = sambashare

Now enable the samba daemons to start automatically
in terminal type:
sudo systemctl enable smb nmb
now restart the system and create a share via folder properties in dolphin
Now test your config with terminal Type: testparm and enter
if it’s working without error you’re safe to continue
sudo smbpasswd -a terry

That all worked fine for some time but now it’s failing to create the shares and I can no longer connect to the existing shares from any other system.
Here’s my testparm output currently

If anyone has been able to get this working after the latest samba changes please give me a reply.

I don’t know about the part with failing to create shares, but are you sure you cannot connect to existing shares with smbclient? It could be the network discovery issue which is common across many distros right now: Still no love with Ryzen 2400G and Linux (ubuntu 16.04)

Hi Sceps,
Thanks for reply, yes I was aware of the issue in Feb and made a change to the smb.conf file to mitigate that initial failure. Client Max Protocol = default worked for some time after that samba 4.8 change. Something in subsequent samba iterations has broken that fix apparently. I’ve tried changing to Client Max Protocol = NT1 and none of my systems can see the shares in “old” mode either. IDK where else to edit or what else may work. The old samba.config file structures don’t work anymore so I guess it’s broke officially.