Ryzen P-States info & ASRock Mainboard updates

So I've been doing some ASRock x370 Gaming K4 based overclocking on my R1700x. The BIOS btw is virtually identical to the Taichi except the background is Red. My BIOS version as of now is 1.64 Beta BIOS.

I set P-State 0 to 3.97GHz with a VID 19 (1.393750V) and FID of 9f (3.975Ghz).
The same I did for P-state 1. Then P-state 2 I set at FID 84 (2.2Ghz) and VID at 68 (0.9V). I disabled all P-States from State 3 onwards.

This is now all fine and stable, benchmarked etc and I'm OK with that basic OC.
Except for one thing. The processor will not enter Idle state and continues to run at 3.97Ghz all the time. But I want it to use P-State 2 when Idle. According to a few sources and this somewhat vague overclocking guide from AMD I understand that States 1 and 2 are the software accessible performance states and hence concluded that P-state 2 must be for low/idle performance.

But I guess that is not the case.

Alternatively I tried setting only P-State 0 to 3.97Ghz and leaving all the other states at Auto, which ended up with the Chip running at an Odd 2.9Ghz and not clocking up when under load. I also tried running with P-states 3 onwards on Auto, but that gave the same result as running with P-states 3 onwards disabled.

Has anyone got any solid source as to how the P-states behave and particularly how I can set this up to get a functional Idle-State?

Paging @wendell I remeber you talking about P-States on the Taichi at one point. Perhaps you have some useful knowledge about the P-States on Ryzen?

1 Like

P2 worked for me on idle. Try p3. ?

In Windows is it balanced or high performance? Balanced may do the trick.

P3 on auto may just be a copy of P2 not the default.


I just tested that and Balanced mode made no difference. So I forced P3 and P2 to 2.2Ghz and even set Windows Power Options to power-save and It's still sitting at 3.97GHz. It's as if it's only using P-State 0.

EDIT: So I'm going to check if P-State 1 is perhaps the magic one.

EDIT2: Tested P-State 1 and still no Idle. it really must be ignoring all states except for P-State 0. Or something else is overriding the setting somewhere.

With Only P-State 0 set to 3.97 and all else on Auto. The system ends up idle at 2.196GHz(sometimes even as low as 1996Mhz) and Boosts to 2.996GHz under load. I'm not sure where It's getting those values from. If I look into CPUID HWMonitor it shows a Max of 3.97GHz but I can't get it to ever actually run at that clock rate even under 99% load.

Try a bios rollback? Maybe a bug in that bios.

1 Like

I think I'll try and rollback to 1.60 and see what that does.

EDIT: So for some reason I have just discovered that the In-BIOS Internet based flash option already finds a 1.70 BIOS that is not listed on the website. However It doesn't inspire confidence since the Changelog simply says:


But I can almost with certainty say that the 1.64 BIOS is bugged when it comes to P-State behaviour. I manually set all the P-states in small increments, and the system isn't behaving according to any of them.


So I tried BIOS 1.60 and effectively there was no change. I'm still getting the same behavior. P-State's 1 & 2 are only effective If set to Auto for some reason. I suspect that this is some sort of BIOS issue. If I only set P-State 0 to 3.97Ghz and leave P-state 1 & 2 on auto. I can never seem to enter P-State 0 performance level.

One thing I still have to try is leave P-State 2 set to auto but 0 and 1 set to 3.97Ghz. But for the most part I can just hope that 1.70 stable fixes this.

EDIT: Tried that too and still stuck at 3.97GHz, it's safe to say i belive at this point that If using P-State overclocking the currently available BIOS versions for the ASRock x370 Gaming K4 are borked.

And then I'm not sure If HWMonitor is reading the voltages correctly either:

Ryzen Master still reports 1.393Volts With I believe the wrongly offset Temperature:

Is this a fresh windows install or is it from another machine?

1 Like

It's effectively a new Install, same machine.

What's also Odd is how when the CPU boosts from 2.2GHz Idle to 3.5GHz the temperature jumps from 48C to 58C within less than a second. Overall the temperature is jumping around like crazy (5C within a second quite often) while at Idle. I have never seen a CPU where the Temps where so lively under idle conditions. Under load at 3.5Ghz the temperature max where it reaches an equilibrium is 77C and I believe it can actually be lower If I reapply the thermal grease even thinner.

This temp jumping is the subject of a video I shot today. Hint;/: that's why they did the twenty degree offset thing. Teehee.

I will have to test more on the Taichi and see if maybe something weird is going on. I could watch Ryzen master going from 2.2 to whatever also . Any chance anything in the background is going nuts? What does CPUz report?

All other options are on auto right? Voltage , not in oc mode, level 3 load line calibrations etc?


Yip this is with everything set to auto right now. Nothing going on in the background.
Loading programs causes it to temporarily Jump to Boost frequency and then back down to 2.2Ghz along with a corresponding temperature jump. CPU-z shows the same thing albeit at a lower update rate.

Sometimes I think I was even able to make it boost by simply dragging a selection box on my desktop background, it was weird and I'm not sure if that's just some kind of coincidence.

I'm on 1.64 beta. I wonder if having Ryzen master open may affect this

I am seeing similar behavior as you but my videos have this

P-State 0
Frequency : 3800
Voltage : 1287500
FID : 98
DID : 8
VID : 2A
P-State 1
Frequency : 3000
Voltage : 1200000
FID : 78
DID : 8
VID : 38
P-State 2
Frequency : 2200
Voltage : 900000
FID : 84
VID : 68

And show it working between 2.2 and 3.8 on the 1700 with bios 1.5

However it may be Ryzen master that is downclocking in subsequent tests


This is very useful considering I have been thinking about using P states once the new bios for my C6H comes through. With P states, I'll feel more comfortable pushing for 4.2GHz on the core. But 3200-3600MHz memory still has cold boot issues so I'll let you guys know how well P states go on an ASUS board to see if that helps fill in some unknown issues.

One note just slightly off topic, I have noticed Ryzen Master messing with a lot fo other programs. Couldn't run many benchmarks and in some cases CPU-Z would crash due to Ryzen Master

I just put in the same settings as you. Load Line Calibration level 3 etc. No Ryzen Master Open and all other p-states on auto. And it seems to be scaling correctly now:

Under Load:

At Idle:

@3.8GHz, 1.287V Max Temperatures and Voltages I hit after about 10Mins of CPU stress:

in cpu-z right click anywhere on the first page when checking load freq

All Cores:

1 Like

Ok so the magic trick here is apparently when it's squirrelly to clear settings/load defaults. Because mine was acting weird.


So I stuck these settings in while also trying mine, And I'm locked to the second PSate no matter what. Weird

Agreed, I was messing with this and booted into bios with a weird VCore error and it showed 1.7v.

Quickly shut down, reset bios and seems to be fine except still no functioning pstate