Return to Level1Techs.com

Ryzen instability [solved]

amd
ryzen

#41

I'm just looking at this BIOS picture quickly

You should set
Tcl (tCAS) to 16Clk
Trcdrd and Trcdwr (tRCD) should both be set to 18Clk They should never be different.

You can set the Fail Cnt to 1
and use the tRFC1, tRFC & tRFC4 values in BIOS that your read with XMP Enhancer

tRFC1: 416T
tRFC2: 256T
tRFC4: 176T

Set ProcODT to 60Ohm (It helps a lot with system stability) (53.3Ohm is the default)

Also can you describe to me how this input lag you have is?
If you move the mouse in the bios, does it move with a very obvious delay only like a remote desktop connection over slow internet? Or Is it just sometimes slow and the fast again?

One more question, how are you making your BIOS screenshots?
Do you have a video-out capture device attached?


#42

Thanks for the quick reply, well wish i have a Capture-card, but this motheboard comes with a print function, with f12 i take prints, and it automatically in a flash-drive, i connecte my flashdrive/pendrive in usb port, and just press f12 and it will save the screen in my usb, okay lemme fast configure like you recommended, and i will be using a Iphone 4s, with both camera, rear and front camera, to grab how mouse feels in bios and report back

Because mouse feel like 10-12 fps is not going from slow to fast,, also when connecting trought teamviewer to a pc friend, mouse cursor is even better than my bios, in bios is like mouse moving at 10-12 fps i guess give me a few minutes


#43

Okay it seems that there is a problem, i can put Trfc4 to 176, and trfc2 to 256, but seems like that trfc1 in bios appear like: trfc and if i put more than 399 it pops up a problem like (Invalid input auto adjusted and changes to "3de") so what should i do? and yeah i cannot set the Trcdrd to 18, there is not number 18, lemme attached some screenshoots

TCL(TCAS) set to 16.
Oh i was like missunderstand the PROCOT i though you say put 600 OHM and below this comment i was posting a procot picture i had to delet the comment, so i ended up putting 60 OHM :3, thanks^^

EDITED: Finally i was able to put the TRcdrd to 18, its weird, when pressing the arrow down appear after 25, like 17 18 etc, and finally i configured the Trcdrd 18CLK same as Trcdwr both 18 clk, and tcl(tcas) 16
the ohm is 60 procot, but the only problem is the Trfc= which cannot go more than 399, if set to 400 it goes to "3de"


#45

Hello friend wanted to say: Thanks to you, because now the mouse feels more realistic to me, like i can feel more in-game, now in Mario Kart 8, i can drive better, but still like its kinda heavy to drive, also in counter strike 1.6 i can have a better feeling of mouse when shooting

But the visual lag persist, i would love to know more Tweaks, i want to learn from the best, i really i want, i have facing this issue since 2011 before this ryzen pc, if i was knowing about the memory tweaks maybe my mouse could be more responsiveness, but as i said

There is a problem with the TrFC1, in bios there is not Trfc1, just Trfc<-- which cannot exced from 399, if so, it will changes automatically to "3de"

If you want i can test more things, record videos, i'm here to learn, you really helped me alot, maybe you know more tech things, to monitored better this pc, because, as i said, wow... to load a game in the cemus emulator version 1.8.1 the latest one, when loading, it takes 3 minutes o.O to post to (shaders) after shaders tooks 1 minute, at the end of the day takes like 5-6 minutes to load mario kart 8 :open_mouth: and runs stable at 60 fps, but, there is visual lag, stuttering, in youtube people that have this same emulatior version and mario kart 8, you can clearly see that they load fasted the game like the loading bars take less than 5 seconds to post shaders, and game will load in less than 1 minute.

But yeah the visual lags, is very notice-able , And this happening to overall games, wish i can record with my phone, the games like cs 1.6, bios things, lemme know if you need the videos and i will record, thank you so much!!!!!!

Also the VRM 23 temperatures, thats like wow, crazy, wish we can test more that thing. did you check the Large prime 95 test csv that i uploaded here? :o, thanks again cat.


#46

Seems like it wants input in Hexadecimal. 3de would be 990 in decimal. Notice also that the Description field for Trfc in the sceenshot says: "Valid values 3DEh-3Ch" so putting those two values through a generic hex converter I get 3DEh=990 and 3Ch=60


#47

Hello thanks for answer, so i guess for the 416T, should be 1AO?


#48

looks more like "one A zero" rather than "one A O", but what do I know, I don't have the same motherboard and I can't test.


#49

Yup i set 1a0 it doesnt accept (o) just 0 hehe, lets see what catsays,

Thanks megalomaniak.


#50

Sir Cat, i don't know if you still here supporting this thread or even me, but as i say wanted to thank you, because you helped me with the mouse , is not the best , but is better than before

Anyway, I made a video of my desktop how it looks, with a third part software like ice-cream, if you are interested in keep helping me i will highly appreciate, if not is okay, i still happy n.n

Youtube video here:
ClickHereisMeYoutube^^

Editing: Now i will be recording bios, with my iphone 4s at 1080 30fps, with that camera, because as i explain the bios mouse moves like in 10-15 fps.


#51

I'm still here.

I'll take a look at your BIOS video later and hopefully better see what's going on.

As for BIOS timings, yes they are in hexadecimal. There should be two placse in BIOS where you can enter them.

  1. The Overclocking Tab -> DRAM Timings
  2. The Advanced Tab submenu (Where they are in Hex)

So 1A0 = 416 tRFC

But you can probably go lower to like 350tRFC1 or even 260tRFC since you have 2x4Gb not 2x8Gb if you want faster RAM.

Also Wow! Your English is really good in the video, at least I say so! :slight_smile:

Overall I can say this is a really strange problem if its slow in BIOS, in all my years working in IT I have not had that happen. So maybe this is something new.

With regards to CEMU emulator I'm not sure, a lot of people have been having problems with version 1.81


#52

Maybe its because you have csm disabled/uefi only? I got a similar board (x370 killer sli) and mine is just like yours, if I disable uefi its lower resolution but fast asf.


#53

Hey cat could you check my timings as well? I've been over a month with random game stuttering but can't even know the problem, looks like its RAM related because its the only thing that remove the stuttering is when I change ram settings, but next day I have the stuttering again withouth changing anything. Tried everything software related, I may make a new post for this :confused: here its the screenshot btw



#54

Wow

Your tRFC value is HUGE

Something like 416T or 350T should be a safe start.

Next start by adjusting your tRC and tFAW downwards.

You can use the 2000Mhz readout from your RAM as a baseline and decrease numbers from there:

You can use the formulas here as a good baseline.

http://www.tweakers.fr/timings.html

Also read my prior posts here on this thread.

I'm not one to tell everyone how to adjust their timings, I'd rather teach you to figure it out on your own :wink:

As a Chinese proverb once said:

You give a poor man a fish and you feed him for a day. You teach him to fish and you give him an occupation that will feed him for a lifetime.


#55

If I have stuttering, it will happen even if ur looking at a wall or at a sky with 0 load and 1000 fps, it just doesn't matter more action or less it stutters. As Info as it doesn't appears above, I set my ProcODT to 43 OHms, it must be like that or above=3200 MHz wont boot withouth 43 ohms, and then at 2933 I can boot with another resistance but it will crash in minutes, tried every procodt from 40 to 60+.

Well last time I used those (high) default timings I had stuttering it was literally unplayable, but who knows because I also had unbareable stuttering with cl16, then tried cl14 and boom no stuttering, thought it was more than 14 timings ==stuttering, but then other day had stuttering back again... so I upped them to 16 timing again yesterday and know what, stuttering dissapeared again(that was yesterday) but today I go log in and play and had a bit of stuttering again withouth changing anything, didn't even entered in the BIOS, now I changed as you saw whatever thing (this time disabled ram training and gear down) and no stuttering... for now. So it just looks like random stuttering > go bios change anything > no stuttering then start again like a wheel, being like this for over a month.

Removed myself anything software related because I tried everyything you can see on Internet, older drivers, windows reinstallation, nvidia panel setttings, throttiing, hpet, whatever windows registry you can find... etc.
Only thing that looks like it is changing RAM things. All I can think is maybe some auto setting when its X gives stuttering and then other day auto its X thing which doesn't gives stuttering, so I put almost everything on disabled instead of auto as you can see above.

P.S: Sorry for my bad English btw


#56

This is what I've managed so far, but I stil have stuttering in some games


#57

@catsay I’ve been reading over the assistance you have been providing others with getting their RAM to behave in their new Ryzen systems.

I was wondering if you would be able to assist me in getting my system to stop being fussy.

I am able to boot right now and get into some games of PUBG. But the game crashes at random points. I haven’t been able to finish an entire game since I’ve been trying to hit 3200Mhz.

Here is some info.

MOBO: MSI X370 XPower Gaming Titanium

Memory: f4-3200C14D-32GTZ

OS: Windows 10 Pro 64 - Bit

SoC is at 1.175v

DRAM 1.5v

ProcODT 60Ohm

If you need anymore information please ask. I would really love for my rig to run in tip top shape. I’m just having trouble getting it there.


#58

Here is what I have adjusted.


#59

Hello Cat, sorry for being so inactive, recently here in my country Venezuela we’ve facing many problems, with this government till the point that is getting out of control, government cutting the services, people closing the wallmarts, streets, companies. Government also cutting off the services, like (phone, water, electicity, internet services) failuring etc

But seems like today services are restored, and as i always say wanted to say thanks to you because, you have patience to help others, i finally recorded a video about how my bios looks, so if you can check here:

BiosVideoYoutube

another thing is that i set the TRFC from 416 to 260 TRFC but i dont know if that stable, another question did you check my bios? i remember like 10 days ago, you say that you were to tak a look in my bios later, hope you can do ^^

RyzenTimning:


#60

also it seems that my motherboard has a new bios update 3.0 called Agesa 1.00.6 a release on july 18
I will be upgrading to that version meanwhile, but hope you can teach me how to test by myself memory timings, amd things, because this is my first time being AMD USER, thank you cat, also i would love to have a private conversation or another THREAD, or even here, i dont want to bother the community, thanks.


#61

And with the last update, i just activate XMP PROFILE to auto, to see what happen with the new agesta 1.006 a, and this is what it trows i guess it still bad configured, when running at 3200 mhz by using XMP 2.1

This is a picture of all default, just by putting on XMP profile 2.1 and fail memory count to 1, and training memory advance off

to test is there any changes on this new agesa but it reminds equals i guess