Raid problem on Asus x570

The problem is there are 6 total drives in raid 0. Two new drives (sn850) showed up at first but Asus tech had me delete in bios to try another array. Now drives are listed under physical devices but will not show up in windows. Tech is consulting with engineers overseas. Has anyone had this problem?

I think I know what’s going on.

Important question before I give any advice: Is Windows installed on an AMD RAID volume on that system?

Everything was done using raid expert in BIOS

Objection: Non-responsive.

  1. What, if any of the listed eight SSDs are you using to boot Windows off of?

You can see 4 NVMe and 4 SATA SSDs.

  1. Do you want to use them with an AMD RAID configuration or just independently like normal drives?

  2. Does any of the SSDs have important data on it so that the whole drive should not be deleted?

1 Like

2 x 970 plus 4tb nvme raid 0 / 0S on motherboard slots

2 x 860 2tb sata raid

2 x 250gb sata raid

Strange thing is Im not sure what kind of raid the SATA drives are. When I tried to get the bios to do raid it would fail for sata drives, then I noticed in windows those 4 drives became two.

When I inserted the new drives sn850s into the Asus hyper pcie. They initially showed up as two separate cards, which is what I expected. It’s when with an Asus tech on the phone with me went into bios to create another RAID 0, the option was greyed out. So we did a number of things including removing the drives and then reinitializing. Problem is they don’t seem to be reinitializing. I enable both and but yes to reinitialize and it instantly finishes. If I go back in the same menu, it will have the same message to Initialize disk. In referring to raid expert in BIOS.

I’ve tried switching the 970 plus drives to pcie Asus hyper card and sn850s to mobo. Samsung’s show as normal but 850’s don’t.

To be clear the 850’s show up in BIOS as “ready” but not online as the rest. Asus tech recommended installation in a separate PC which I will try later.

The goal is to get the sn850s online and in raid 0

“Important question before I give any advice: Is Windows installed on an AMD RAID volume on that system?”

My answer to that is I used raid expert in BIOS on an AMD motherboard so I would assume yes? All data is backed up and can be wiped clean as needed. Currently I have swapped the 850’s back to Asus card and will test in a different PC. Not sure what that’s supposed to solve but will try it.

** Different PC made no difference

I got it

Happy to hear that you could solve it yourself!

I have some experience with AMD’s motherboard RAID software and encountered a few bugs, one sounded like the situation you had been in:

  • To use drives with AMD’s RAID software you have to initialize them, this means the software is writing a bit of meta data to the drives “Yay, I am drive 1 of 2 of a RAID0 volume, my serial number is abcd1234, drive 2 of 2 has serial number efg5678” and similar meta data is written to drive 2;

  • In current Windows versions normal NVMe SSDs are mostly handled by a generic Microsoft “Standard NVM Express Controller” storage controller in Windows Device Manager;

  • When using NVMe SSDs with AMD’s RAID software, two AMD devices “steal” the NVMe SSD away from the “Standard NVM Express Controller”, these are called “AMD-RAID Bottom Device” and “AMD-RAID Controller [storport]”, you get one of each for each physical NVMe SSD that is handled by AMD RAID;

Bugs:

  • Sometimes, if you delete an AMD RAID volume the SSD isn’t “returned” to Microsoft’s “Standard NVM Express Controller” which leads to it not showing up in Windows at all, but just fine in the UEFI and other operating systems like Linux;

  • To solve this you have to uninstall the devices “AMD-RAID Bottom Device” and “AMD-RAID Controller [storport]” in Windows Device Manager with its drivers and sometimes reboot the system;

  • This would be catastrophic IF Windows itself is installed on and booting from an AMD RAID volume since then Windows would no longer be able to boot since it doesn’t have the required drivers to do so.

In this case I had to delete one of my volumes so that I could create a new one. I think there’s a specific number that can be created on x570