QEMU/KVM - Not Capable of Installing WINDOWS 10/11

I keep getting this over and over again.

I give it topology; 2*2; 100GB space & 16 GB ram.
I have tried ‘Legacy Bios’, ‘UEFI x64’, ‘UEFI SECUREBOOT x64’. The windows manual stated it’s a fix within the system… Within Windows, that you do a secure boot for in order to find what’s wrong.

I have now tried it with bootleged windows ISO’s, and the original from Microsofts own page, both Win10 & Win11. Same results. So I was thinking, maybe it’s QEMU that’s at fault here.

I installed ArcoLinuxXL without a problem, and a bunch of other Linux distro’s. It’s a Windows only problem.

Here’s my system info;
image

I still get this problem. "/


This is not really helping either. I have no idea what’s going on, what have I done wrong? OR what have I not yet done?

Can you please post the output of cat /proc/cpuinfo?

And the qemu config you are running ?

Found a video that I’m going to see now.

EDIT;
That did not work for me. I’m met with the message that there’s only two options “host-passthrough” or “maximum”… Setting it to Maximum still gave me the same error code.








I’m also adding this Info, since I’m going to do a GPU-Passthrough as soon as I get the install running.

Saw that I also missed to add the actual CPU setting.

Can you paste the actual XML?

1 Like

image

The really irritating thing is that I have now had the same problem in Manjaro and ArcoLinux.

While Linux installs are done without any hassle; creating Windows VM’s is.

How do I fix this? Just chown and chmod the whole folder structure?

This is gonna be weird, but I smell zen 1 RAM shenanigans. It’s gonna sound weird, but remove half your RAM and try again.

Is it 2x16GB sticks or 4x8GB sticks? Zen 1 sucks at dual rank and quad sticks…

1 Like

Disable memory ballooning to start with ?

  <memory unit="KiB">16777216</memory>
  <currentMemory unit="KiB">1048576</currentMemory>

It looks like you are trying to install windows with 1GB of ram … it’s not gonna like it …

1 Like

I did a “sudo chmod 1775 /var/lib/libvirt/images/win10.qcow2” and now it has access to the file… Strange that it wouldn’t have access to it’s own file…

… Woah, I have had 32 GB of ram in the computer for ages, and there hasn’t been any problems at all, this began with a newer kernel or later versions of Linux, I actually use at least 16 GB per session, I rather not go down that road.

I changed it to 16 GB.

Will do that.

Still the same result. It’s a CPU thing, and it started with newer versions of the Kernel. I get it my 1700X is getting old, but did it really have to get into this situation? It started noticing it this year. I haven’t had any problems with it before. Last year I had multiple Windows VM’s.

When does it fail? Does the installer even get to the initial welcome/partition choose?

Nobody said you had to leave it out, you’re just doing experiments. It has been fine forever with the address ranges that QEMU doesn’t use lol

I had the world of trouble with my 1600X with bluescreens everywhere when it had two sticks of RAM, had to half them to get them to work.

1 Like

I have an idea what it could be. You run a first generation Ryzen processor and the early models of the first generation were affected by what was known as the segfault bug. This bug was not due to some faulty software, but to an actual undisclosed problem with the silicon. Peoples attention was drawn to it because some tasks like compiling certain application would fail an crash the kernel. I have first hand experience, by owning an affected processor for a short time, that this bug also affects virtualization. There are some tools that try to trigger an error by this hardware bug, but to be sure if you are affected you can remove the cooler, thermal paste and look at the print on the processors heatspreader, the production year and week are mentioned in the small print on there. If you want to be sure that you are unaffected you processor needs to be produced in week 26 of 2017 or later!