Pop_OS on Ryzen 4500U laptop

So I recently got a Lenovo L14 G1 with a Ryzen 4500U with Radeon graphics.
I want to run Pop_OS but I cannot get the graphics drivers to work.
I am currently running kernel version 5.8.14.
lspci -e outputs the following information:

06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c3) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Renoir
	Flags: bus master, fast devsel, latency 0, IRQ 255
	Memory at 460000000 (64-bit, prefetchable) [size=256M]
	Memory at 470000000 (64-bit, prefetchable) [size=2M]
	I/O ports at 1000 [disabled] [size=256]
	Memory at fd300000 (32-bit, non-prefetchable) [size=512K]
    	Capabilities: <access denied>
    	Kernel modules: amdgpu

When I boot it gets stuck on fb0: switching to amdgpudrmfb from EFI VGA and nothing happens.
I have gotten it to boot on kernel version 5.4.0. But the GPU still doesn’t work and the experience is awful with extremely high CPU usage.

I have tried to use third party drivers, like oibaf/graphics-drivers and tried to boot using kernel flags to use amdgpu.

Is there something I am completely missing here? Or do I have just wait until the next Pop_OS upgrade like other posts suggest?

Pop_OS is generally not something I would recommend for such new hardware.

You could try fedora to see if that works out of the box while you wait for an update for pop.

I have tried multiple different distros, including Fedora, with newer kernels and would still get the same error.

I don’t think oibaf has been updated in over a year now? Not sure this is related to your issue but if you want to try the latest Mesa drivers, the Kisak ppa is the way. https://launchpad.net/~kisak/+archive/ubuntu/kisak-mesa

Install mainline kernel. It is updated for the 4000 series 5.4 isn’t (or atleast wasnt)

I have a asus pn50 with a 4300u and it works great with pop os 20.04 and kernel 5.8.x

Edit: sorry, didn’t see you were already running 5.8. Not sure what it could be.

I checked my Renoir system closer. It was running 5.8.13. I updated to 5.8.14, still worked.

My lsicpi -nnvvk entry for the graphics:

04:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Renoir [1002:1636] (rev c4) (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Renoir [1043:87e7]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort+ <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 32
	Region 0: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 2: Memory at e0000000 (64-bit, prefetchable) [size=2M]
	Region 4: I/O ports at e000 [size=256]
	Region 5: Memory at fe600000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu

I checked dmesg for the fb0: switching to amdgpudrmfb from EFI VGA line.

[    1.381339] [drm] amdgpu kernel modesetting enabled.
[    1.381533] Virtual CRAT table created for CPU
[    1.381551] amdgpu: Topology: Add CPU node
[    1.381653] checking generic (d0000000 7e9000) vs hw (d0000000 10000000)
[    1.381654] fb0: switching to amdgpudrmfb from EFI VGA
[    1.385135] amdgpu 0000:04:00.0: vgaarb: deactivate vga console
[    1.385172] amdgpu 0000:04:00.0: enabling device (0006 -> 0007)
[    1.385269] [drm] initializing kernel modesetting (RENOIR 0x1002:0x1636 0x1043:0x87E7 0xC4).
[    1.385272] amdgpu 0000:04:00.0: amdgpu: Trusted Memory Zone (TMZ) feature disabled as experimental (default)

That seems to be the point the EFI is handing off to the amdgpu driver. Looks like whatever difference there is between an Asus 4300U and a Lenovo 4500U is causing the problem when amdgpu takes over.

I’m happy to try or check something else for you.

Thanks for the information!
I managed to solve it by turning of “OS Optimized Defaults” in my BIOS.
So for anyone having the same problem, switch that option off and upgrade your kernel!
But HDMI output still isn’t working.

1 Like

From what I found oibaf still gets updates. The ppa shows an update as late as yesterday. Should I stick with them or switch to kisak?

Ah, then I guess it is not dead afterall, if it has the latest Mesa then it should be fine :thinking:

For the HDMI stuff, are you running the latest mesa, llvm, and linux-firmware packages?

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.