NextCloud + Tailscale

Question for y’all. So, I am in the process of following Wendell’s recent homelab guide. I unfortunately don’t have the hardware storage requirements for TruNAS, so I just have a debian machine running Portainer, so everything on Portainer that you did I followed along with (NextCloud and TailScale). I set up the advertise-routes and in tailscale I have it set to route subnet. When I try to connect to NextCloud using the 100.#.#.#:8080 IP or the local 192.#.#.#:8080 IP I still get the “untrusted domain” message. I did a sanity check restart on the machine running Portainer but did affect the issue.

NOTE: I’m pretty new to this and since I am not using TruNas, I should have probably changed the volumes for the stack compose files but didn’t. I don’t know if that is a factor because the machine is on TailScale and I can access NextCloud locally.

Any ideas?

Hmmm, can you try accessing nextcloud by hostname?

Tailscale has some funky DNS and https helpers that may be of use?

Basically, see MagicDNS · Tailscale

NextCloud says “Could not find host” when I use the host name. Compared to the IP address where it’s says about the “untrusted domain”

I saw the MagicDNS in the TailScale settings. I’ll look into that

That’s what you’re looking for :wink:

1 Like

I was getting ready to try that when I tried it one more time but tried the tailscale MagicDNS and that worked! Thank you @risk and @modzilla!

1 Like