Return to Level1Techs.com

Need Help with NVME Raid on x470 Crosshair VII

@wendell I have two 960 evos and want to put them in raid 0, my bios doesnt have anything in the way of raidxpert2 that I can find. I’m wondering if they removed the option of nvme raid from the bios for the asus crosshair vii x470 non ac?

I have looked under advanced menu of the bios and it doesn’t appear as it did in your video.

nvme mode has to be raid, then you have to save, reboot and go back into uefi. I think you may also have to disable CSM as it is a uefi only setup?

1 Like

I’m having the EXACT same issue. And have been struggling the last couple of days with it.
The Lvl1Tech video of this inspired the purchase of this mobo and I can’t wait to get it to work.
I’ll try Wendell’s suggestion and report back.

Thank you. What you suggested works. Have a clean install with my two Evo’s.

Hey just checking back in, I DID get this to work.
I need to change this specifically in the uefi bios:

Boot -> CSM(Compatibility Support Module) -> Launch CSM [disabled]

Advance -> Sata Configuration -> NVMe RAID mode [enabled]

This made the RaidXpert config appear and i was able to create an array with 2 NVMe drives.
Also I noticed when i re-enabled CSM after the RAID was created, I could still access the RaidXpert 2 config.

Thanks

1 Like

Hey, @SirGuybrush, and @wendell.
…apologies for the length, but wanted to be thorough… I need help too…

For the most part, I followed instructions in the video tutorial and hints found in forum posts, like this. Got Windows 10 Pro installed using NVMe RAID drivers provided by AMD. When I run CrystalDiskMark it comes up with these results:

Did two runs and was met with pretty much repeating results. Not what I was expecting from two Samsung 970 Pro NVMe’s in RAID 0… but then again, I changed to different driver source than what Wendell describes using in the April YouTube video.

What I noticed was that there are two sets of drivers out there on the interwebs. One is the Threadripper set Wendell pointed to, and another is the set available for the x470 chip set. They both say in the zip packages:
rcbottom
rcraid
rccfg
One zip folder extracts with the labeling WTx64 and the other extracts to RS2x64, just like how Wendell describes. Which one am I supposed to use?

Here’s the link to the AMD X470 provided “AMD RAID Driver (SATA and NVMe RAID)” page
https://support.amd.com/en-us/download/chipset?os=Windows%2010%20-%2064

And here’s the direct link to the zip file from that page I used
https://www2.ati.com/drivers/nvme_raid_windows_driver_9_2_0_70.zip

I’m currently using the 9.2.0.70 drivers from the X470 chipset source. Here is a screen shot:

I’m running a 2700x, dual 1TB 970 Pro NVMe M.2 drives, ASUS Crosshair Hero VII Bios Version 0804. I can provide more screen shots or system info, if needed. Since I’m a noob I can only upload two pics per reply. Trying real hard to rise above the normies, man… anywho…

I made the stupid mistake of installing a bunch of apps/games before ever running the benchmark to prove I was fully utilizing the array correctly. If a solution exists which would prevent me from deleting the array, I’d greatly appreciate that! :sweat_smile: :sunglasses: :slight_smile:

…and yes, ninite and external storage all can help me rebuild quickly if array deletion is required.

I noticed that the level1techs article is missing, so couldn’t refer back to that to see if I missed an additional step or detail. Is this just simply a matter of using the Threadripper divers instead? What are your suggestions for how to go about optimizing these drives given the current state this gear is in?

as a side note, I deeply appreciate all the level1techs content and am inspired to learn how to include more Linux in my life

Thanks for the help!

Try 2gb write. I was getting half the speed with 1gb, I upped it to 2 and it was hitting 6GB reads and 4GB writes.

Any overclock? I’ve noticed marginal overclock mess with I/o bandwidth

@Ancient_Evil_God do you mean change the “test size” from 1 GiB to 2 GiB?

@wendell, Yes, I have a mild 10% overclock… up to 4.1 Ghz.

Is this where I am supposed to use the “eCLK Mode” in the Bios if I plan to keep this over clock? … something about Asynchronous mode?

Set everything to pure stock and restest then tweak from there? Except memory. Start with memory then modify from there. Try to attan 2933 to 3200 stable but you need to test at each memory speed and timing set because you can regress. Push the oc too much and I/o suffers.

Understood. I’ll try what you’ve suggested. This gives me a direction to take things. Thank you. @wendell

The best thing you can do for processor oc is just to enable pbo, ditch the power and thermal limits and just let the cpu do it’s thing. It’s 4ghz for me all core on a 2700x and 4.350 on 1-2 cores. On this motherboard. With a fsb of 100.5mhz. and that config has offered the best overall performance vs any manual or at all. 3200 with 14-14-14 timings is solid but 2933 is really close too so if you test you may find 2933 is faster than 3200 depending on timings and other factors.

2 Likes

wendell is probably correct about I/O throughput being handicapped by manual oc settings. You are correct about what I meant with the 1gb vs 2gb test size. Worked for me.

1 Like

Sorry to sound dumb, but PBO isn’t a feature available yet in Ryzen Master. Is there a feature in BIOS that is PBO but just labeled differently?

yep, its a setting and the help text is like “load board defaults for X, Y and Z” (enabled) and auto is “amd defaults”
set that and everything else on not-really-overclocked settings.
memory at 2666/2933 should be fine too, to start as a baseline. Then bump memory speed to 3200 and play with timings. Then after that’s dialed in and you’ve tested raid speed in those scenarios can you tweak further

1 Like

Well, still no luck… I’ve tried everything… including: disabling all other storage ports, disabling most USB ports/headers, messed with as many BIOS settings as I could find… read forum threads, watched your video many times, watched many threadripper videos to gain insight, tried many more things. Tried the RAIDable way… tried installing standalone drivers without the rccfg driver files during front-end install… tried ASUS raid driver sources, tried AMD RAID driver sources, tried all the Threadripper drivers I could find on the net! I even went as far back as two previous bios revisions (601,702)… went back to current bios version 804 and slowly over clocked seperately the memory, then put that back at stock and slowly over clocked the CPU… then did both memory and CPU over clocking… Still no change!

I even tried installing Windows 10, non-RAID on just one Samsung 970 Pro NVMe 1TB drive, in the M.2_1 space and ran CrystalDiskMark there to only see a very under performing sequential read/write again! That got me thinking…

I went in and installed Samsung Magician and found out that the drive was not recognizable by the software. Also, Samsung Magician reported that it was NVMe PCIe3x2… the other drive was still installed in M.2_2 and was showing up as NVMe PCIe3x4 as I would expect. They are both 970 Pros… So that’s when I disabled as many ports, headers, and features that could think of… still no change after trying RAID0 again… The best I can do is 3600 seq. read and 3300 seq. write. No where near your results, Wendell.

I will try to swap out the drives into the opposite M.2 positions and see if I can isolate the drive or the PCIe lanes

I was curious though, where did you find BIOS version 508 as seen in your tutorial video? I can only find 509 on the ASUS website…

Newest bios works fine. Other users were tripped up by the csm settings and got it working pretty easily. It’s not that crazy, tbh.

If it’s 3.0 x2 pcie make sure you don’t have any SATA devices plugged in? There are some ports that share bandwidth ? It works for you but is just slow right?

Yeah, I agree with you for the most part. The bios works 99.99% of the time for nearly everything. With the exception of one thing, good Sir.

Noticed that most everyone else having success are using 960 pros. Even your example shows how it can be done well with 960 Pros. Which, I have to take a moment to express deep appreciations for your work and the tutorials you provide. You are a true gem in the tech world.

I’ve already ironed out the CSM conflict potential way early on in the process before all my parts arrived… hahaha.

I unplugged all SATA devcies before and turned off all the SATA ports. I believe SATA ports 1 and 2 share one of the m.2 lanes. But as we know other PCIe3 lanes are shared with the m.2_2 port. And there in lies the problem, as I believe it to be at this stage.

Woke up this morning, put on my ‘chaos ensues’ shirt and said, “What is the core issue? Is this a matter of firmware recognition and configuration by the BIOS? Will we ever get off this burning planet?!?!?”

What I’m starting to think is the case is that the AMI (American Megatrends Inc.) Native NVMe Driver Support is not meshing well with the 970 Pro. This suspicion is confirmed by the latest QVL.

Usually I ignore the QVLs and just use none QVL stuff on my own, find work-arounds and get it going. THIS has been the most challenging one yet. It’s such a new product that a new bios covering native drive implementation hasn’t come out yet. Which would also explain why I have yet to see the “Advanced>NVMe Configuration” menu item in the BIOS show up. Additionally, this incompatibility is confirmed by when I install windows on one 970 Pro, NO RAID, then later add in the other 970 pro and then install the Samsung drivers, go back to Samsung Magician and voila! The drive is so new that not even Samsung Magician recognizes the drive. Apparently there is a version 5.3.0 of Samsung Magician out there in the wild that hasn’t been officially released to the public which correctly identifies the drives as 970 Pros. Anyways…

The drive that was showing PCIe3x2 is now showing PCIe3x4!!! Eureka!

Right?

not so fast…
What happens is that NVMe drive gets firmware instructions via operating system drivers. When those get installed in the OS environment, the drive stores that in the firmware and it knows how to behave towards the BIOS. So the issue is getting the drives into a X4 state, then coming back into the BIOS for RAID0 based Windows 10 install and not losing that X4 configuration. I believe I have to install the graphics card in either the PCIe3_2 or the PCIe3_4 slot in order to trick the drives into keeping there X4 designation within the BIOS native driver. That’s very hard to do because when I setup the RAID0, the BIOS warns that creating the array will erase all data on the drive. I’m assuming this includes the firmware instructions of how to be configured as a PCIe NVMe SSD.

Only chronicling all this for the thread so others trying to RAID0 Windows 10 on the 970s Pros attempting to get the bleeding edge of speed aren’t caught off guard and think that their board or the drives are defective, thereby compelling them to RMA unnecessarily.

I’ll try different graphics cards slot configurations and get back to you. fingers crossed.

Huzzah!!!

…it worked :smiley::smiley::smiley:

I had to first install windows on a single 970 Pro drive. Then boot down, insert the other NVMe drive into the remaining M.2 slot. Then boot into windows and install the Samsung 970 Pro NVMe drivers to both drives. This loads the firmware that the NVMe’s need to talk properly with the UEFI BIOS.

Then I powered down, moved the graphics card to the PCIEX4_3 (bottom slot), booted back into windows just to confirm nothing had changed on the side of the NVMe drives and then powered down. Booted into UEFI in advanced mode, setup the UEFI for RAID based install, and built the raid array using RAIDXpert, as demonstrated in your tutorial.

Windows install went as one would expect, loaded the latest NVMe RAID (9.2.0.70) drivers during windows install. Several reboots later back into windows, loaded CrystalDiskMark and BOOM!

NVMe%20RAID0%20with%20only%20chipset%20drivers%20installed

This is before installing all the drivers for the rest of the platform. The only drivers I installed were the ASUS support website x470 chipset drivers (things like power management and such).

Thanks for the help man! Hope this tutorial helps other 970 Pro users on this platform.

as an aside, here’s my build specs

ASUS ROG Crosshair VII Hero Wi-Fi
BIOS revision 804
AMD Ryzen 7 2700X
G. Skill FlareX DDR4 3200 CL 14-14-14-34 (F4-3200C14Q-32GFX)
AMD Radeon RX580
2 Samsung 970 PRO NVMe M.2 in RAID0
Corsair HX850i
Lian Li test bench
Windows 10 Pro 64 (build 1803 or also called 17134.112)
No overclock… Yet