Return to Level1Techs.com

Need Help - First-Timer With Raspberry Pi

Wow, hey, I haven’t used these forums in a long time, I kinda forgot this place existed, though I’ve been keeping up with the youtube show for the most part, ANYWAYS…

I’m trying to setup a Raspberry Pi for the first time with Linux. This is my first time trying to do anything with a Raspberry Pi and only my second time trying to put Linux on anything. I’ve been following this guide:


I been following this guide for everything except for the overclocking part, I’m interesting in doing the “Lubuntu” as he suggested. But when I plug in the Raspberry Pi and it fires up… I get nothing, just a black screen. The Raspberry Pi must be sending something through that HDMI cord because the “No Signal” message on the screen goes away, but I’m not getting anything other than a blank, black screen. Going through some trouble shooting guides on the official Raspberry Pi website, I think there may be something wrong with my SD card. I’ve tried re- flashing several times, with Etcher, I tried re- flashing with the official Raspberry Pi Imager, I tried reformatting it multiple times(every time I tried firing up the Raspberry Pi it was with FAT32 formatting on the card), I even tried a different SD card, but I still got the same results, just a black screen.

…and now I’m just kinda flummoxed. I have no idea how to proceed in trouble shooting the card itself. Is the card bad? Is my Raspberry Pi bad? I don’t know what to do next. I’m all for problem solving myself and digging deep into trouble shooting guides, but I just don’t know where to look next.

I was wanting to set up this Raspberry Pi as a desktop to keep it connected to a Wacom Tablet at all times and use it as like an “art station” of sorts in a different place in the house as my daily machine so I can really focus on enhancing my drawing skills on the Wacom. I’d really appreciate any help that can be offered, thought I probably can’t work on this again until this weekend. Thank you!

Etcher should verify what it wrote, as long as that worked I doubt it’s the card’s fault.

Could be the monitor you’re connecting to is confusing it in some way.

Have you tried different monitors/TVs?

I had some issues when I used a shitty USB charger to run a pi3b.

1 Like

This. Check your power supply is strong enough.

Also which model pi do you have? If it is the pi4 there are 2 hdmi ports and you have to use the one closest to the power supply for the primary screen otherwise you get no signal.

Even if the SD card is bad you should get something on screen.

1 Like

I would suggest you use raspbian. It’s tailored to the hardware much better.

That’s a great idea, I didn’t even think that the monitor might be the problem, I’ll try it with the 42" in the living room then. Thanks!

The power supply should be fine, I’m using one of those starter kits I got off of Amazon that comes with a case and everything. The plug in even has the Raspberry Pi logo on it. Let me know if you want more details.

Okay the different screen worked. But when I tried typing the command to install it shot back at me with “could not find package.” Does that maybe mean that my ethernet is not connected right?

Glad you have the pi displaying now. I assume the above means you have keyboard and mouse and have gone through initial setup.

Ok we need a little more detail. Are you still using Ubuntu?. If so then it may need you to do further configuration before you can access software sources. If you are using raspbian it should have taken you through a dialogue box to configure the network on first boot.

A couple of things to test.

  1. can you access a website using the browser?

  2. try the WiFi connection and make sure that can connect.

I’m still trying to install ubuntu, yes. I get to the part where I type in “sudo apt install lubuntu” and it gives me the cannot find package message(I tried with the regular “ubuntu” also and got the same result). I assume I’m missing a step with setting up the ethernet connection.

Let’s take this back to basics to help us understand your problem.

  1. You have a raspberry pi4 fully connected to monitor mouse keyboard and wired ethernet.

  2. you have an SD card.

  3. that SD card has an operating system on it?

  4. when you turn on the pi Ito boots into a desktop environment (I assume raspbian) and from there you are opening a terminal to type apt-get Ubuntu?

  5. if you have raspbian installed you can’t overwrite it with Ubuntu with apt-get. Raspbian is based on Debian and is cut down to run on the arm processor and an SD card, so would be missing the Ubuntu base packages.

  6. if you want to run Ubuntu on the pi Go to the Ubuntu website and download the iso.

You would need to flash that to an SD card (blank one ideally) and plug that into your pi. Boot it and it will work.

There is a tutorial linked at the URL above.

If this is not your problem please could you explain what you are trying to do?

1 Like

Yes.

Yes.

Yes.

No.

Also no. I’m not doing anything with Raspbian, I just want to put lubuntu on it. (Should I be doing something with Raspbian? I was under the impression that I could just put straight ubuntu on it without Raspbian.) Watch the video I linked in my initial post, I’ve been following every step in that video EXCEPT for the part that allows me to overclock it. But when I get to the part to type in “sudo apt install lubuntu” I get the cannot find package message.

Again, I think I’m missing a step to establish a connection to the internet through that ethernet cord.

Ok I think I see the issue. eta-primes video does not follow the guide on the Ubuntu website. I’d suggest reading that rather than relying on just some random youtuber.

I was confused as I thought you were trying to install the entire Ubuntu package through apt-get which wouldnt work. I can see why the video is leaving you flummoxed.

All you are trying to do is install the desktop environment. This is already on the SD card by the stage you are at so the issue had nothing to do with your ethernet.

The issue is the command you are typing. Try this one:

sudo apt install lubuntu-desktop

There as further instructions on the Ubuntu tutorial if you get stuck

2 Likes

Sweet, I have my first Pi on order, and that guide looks the mutts nuts. Cheers man

Okay, so that command started doing its thing but then gave me a huge list of “failed to fetch” messages ending with suggesting me to run “apt-get update” but then that gave me a short list of “Permission denied” messages. Gonna try googling how to fix this, let me know if you want more details.

try this sequence

sudo apt-get update
sudo apt-get upgrade
sudo apt install lubuntu-desktop

Same result, a long list of “failed to fetch” messages.
edit: just to show you guys what’s going on here.


and then I retyped in these commands just so you can see what’s happening here.

Another edit: okay going back through those tutorials again, I’m clearly missunderstanding some things and missing some steps. Give me a while I’ll figure this out.

No worries

I’d suggest refladhing the SD card just to make sure it is not a corrupt install.

This page may be useful when you do that to add your WiFi credentials into the build. That will let you eliminate the ethernet port as an issue.

You can ping the internet?
Might just be the sources are unreachable/need updating, but I don’t think that is normal.

Like, does it work when you

ping google.com

In case the network is not resolving, even if ping 8.8.8.8 was working?

Okay, I reflashed and figured out somethings I was doing wrong, I did have a simple problem with my connection. But I got a successful install and I got to the desktop of lubuntu! There’s some other problems to be solved but for now I’m just pleased to have a successful installation.

I’m getting alot of really weird graphical glitches. Janky artifacts and such. And when there was a second window on top of another, the screen would flicker to black and go out for seconds at a time(it did this once before, today, before I had successfully installed, maybe the pi just doesn’t like this monitor). And when I opened up Firefox it slowed down so badly that I couldn’t do anything at all and had to unplug it without a proper shutdown. I’m done for today. But at least I did get it connected to my wifi (though I didn’t get the chance to test the connection) and set up some other user accounts, so that’s a start. Thanks everybody.

2 Likes