[N100] - Firebat T8 - Inner stuff and some tests

A few days ago I’ve posted in the “What new thing you acquired” about a Firebat T8 Plus mini-pc, bought to substitute a Pi4 that I use in a remote location.

Well, the thingy arrived… Even though it’s not an expensive mini-pc, there are some people that will be worried about buying it or would like more information, so I’ll share whatever you guys need here in the next couple of weeks, until I deploy it “in production”.

Unboxing (with sound, you’ll get to hear my beautiful voice):

(sorry about the quality, I’m not a streamer/youtuber, and not a native English speaker)

It comes with Windows 11 pre-installed:

BIOS is text-only (there are lots of options, if you want to know anything specific let me know and I’ll record a video to post here).

The memory is DDR5, even though it’s running at 3200Mhz. I didn’t try to change anything out of the box.

And I remember someone telling me that it would be nice to record the thermals, as it can be toasty. I’ve ran a stress-test for 1 minute locally using s-tui and stress , and the results are below (no sound):

Locally it’s 28ºC, and the unit kept at 59º~60ºC stable at the end of the test, consuming ~12W (per system report). I’ve ordered a watt-o-meter to check that directly on the wall as well, but I don’t have it yet.

Since we’re talking about hardware, I took the liberty of opening it (well, it’s mine anyway). You have to remove 2 covers before getting to the mainboard:

After that the mainboard is visible, and it’s small and not tall as well:

Fully opened. We just have to be aware of the wifi wires:

This current ubuntu instalation is a throw-away as I’ll be using HassOS before final deployment, so if you want me to test anything here, feel free to request and I’ll do my best to post.

I won’t be driving the machine as a desktop, though.

PS: Moderators, I didn’t find a mini-pc section, so I’ve added the topic under “Other Hardware”. Please feel free to move it to the correct place.

1 Like

How are you satisfied? Everything ok? Temperatures still good? Thank you

// update: one more Q.: Does it have in BIOS possibility to automatic turn on when power is applied (after power failure for example)?

It’s already installed and running 24x7 in a remote location.

Temperatures were fine-ish for me, given that we’re almost in the summer and it’s located in a hot place. So CPU was varying between 60ºC~65ºC.

Unfortunately I lost telemetry a few days ago due to a local disaster, where the fiber was severed and wasn’t fixed yet (weird stuff, it’s almost in the middle of a jungle here in Brazil, and yet there’s a fiber reaching the place).

I’ll try to grab some pictures of the BIOS when I’m back there to post here, but I remember I’ve configured it to automatically turn on on power loss (and I’ve tested this at home by pulling the plug a couple of times).

I’m happy so far. Way better to my use case than the Pi4 that was there before.

1 Like

hi @Machado , can that device be installed with OpenWRT as a portable travel router, similar to what NetworkChuck did with a RPI? I am currently in dilemma of choosing between this Firebat T8 and GMKTec NucBox 5. Thanks

@infernuz11 , sorry sir, but I have no idea, to be honest.

The basic OS should be simple to install. But I don’t know if the wifi card would perform well in AP mode. I’ll try to grab the specifics about the wifi card and post here later.

@xnd , it’s possible to configure it to wake up after a power loss.

This “State After G3” option can be set to S0 State or S5 State. I’m not an expert, but S5 looks like sleep mode and S0 State is fully awake.

I’ve simulated a few “power losses” events, by pulling the plug from the socket, and every time I’ve plugged it back in, it turned on normally (booting into Proxmox), without any issues.

I did some tests on S5 State (the one on the picture), and in this case nothing happens. It doesn’t turn back on after a power loss.


LSPCI about the Wireless card:

The wireless card is a Realtek RTL8821CE 802.11ac model.

1 Like

Hello. Do you know how to disable secure boot? This option is locked and I can’t find an answer on how to unlock it. Thank you

Hi, Do you know if it’s possible to upgrade from the wifi 5 card to a wifi 6 card and can i use a M.2 “nmve” storage card instead of the “ngff” ? Thank You.

Hey! I bought the same machine. I have experienced that the fan is running on maximum after I installed ubuntu. Sensors-detect can only detect cpu core temperatures, so I am unable to set a new fancurve. Have you experienced similar things. I have heard that this machine should be whisper quiet, and I am not happy that it’s little fan is making a constant humming noise in my living room.

What ethernet network card is it using?


I am trying to disassemble mine but after unscrewing the four little black screws one side of the mini pc is still not opening/sliding down (this is to remove the first cover.

I see a hole above the audio jack with a little padlock but not sure how to do it.


I got it disassembled.
The first layer needs a bit of encouragement, the audio port protrudes and it’s preventing the “IO shield” part to slide out. You can bend the layer a bit (since it’s plastic) so audio port doesn’t prevent it from sliding.

Also I have been playing around with this mini pc as well, but recently the SSD (512GB) failed on me within the first month. It looks like a low quality SSD, so just wanted to share it as a cautionary tale.

I don’t see why not, it’s a PCI-E card which you should be able to replace.

The WiFi card that came with mine is CDW.C9821CE-00 by Cdtech.

Can someone please tell me where I can download Windows 10 drivers?

I installed Windows Server 2022 on mine but it hasn’t installed the ethernet or wifi drivers. The drivers were installed in the pre-installed Windows 11 installation.

Mine came today

What key do you press to get into the bios
I have tried del. F1 F2 etc…
im having to it with shutdown /r /fw /t 00 /f

Here’s some info that may help some people

Tested working Wifi Cards By Me
Intel® Wireless-AC 9260 (PCIe)
Intel® Wi-Fi 6 AX200 (PCIe)
Intel® Wi-Fi 6 AX201 (CNVio2)
Intel® Wi-Fi 7 BE200 (PCIe) (Tested before fitting it in another pc)

Should Work Wifi Cards
Intel® Wi-Fi 6E AX210 (PCIe)

May Work Wifi Cards
Intel® Wi-Fi 6E AX211 (CNVio2)
Intel® Wi-Fi 6E AX411 (CNVio2)

The M.2 Slot is PCIE 3.0 x 2

Bios Version: T8PLUS 0.02 x64 26/09/2023

Setting Ram to Auto results in 4800

The memory controller is locked at Gear 4

The Ram is running at CR1
CR1 is better but its very odd DDR5 is running at that

Any time you make a change in the bios you have to press the power button even though the light is already on for some reason

The USB is USB 3.2 Gen 2 x 1 (10 Gb/s)
and was confirmed as that with an ASM 2364 USB 3.2 Gen 2 x 2 Nvme Controller

Intel® Wi-Fi 6 AX200
Sabrent Rocket 2230 NVMe 4.0 1TB

Benchmarks Windows 10 22H2
It benchmarks and runs much better on Windows 10 22H2 btw…
compare below with yours on Windows 11


Thanks a lot for these information! Two questions though:

  1. How did you mount the SSD? You’ve mounted 2230 drive but T8 has mounting only for 2242.
  2. Is it possible to swap the WIFI card for a second SSD?

PS: I’m using Del to enter the bios, works like a charm, you can also use F7 for a boot menu.

I have problems though with detecting boot USB, it’s rarely seen on my T8, though is detected every time when rebooted from Windows.

Google it: “[INDEX] All My Drivers/Firmware/Software Threads”
You need drivers for RealTek RTL8821CE and RealTek RTL8168/8111

I cut up a piece of credit card
made a hole in it then lined it up and trimmed to size

You should be able to put another drive in the wifi slot
but it will only run at PCIe x 1

Edit i forgot to say you would need an M.2 A+E Key to M key adaptor
They come with different cable length’s maybe a 10cm cable would be ok
but im not sure if the board would fit in the case


Then it’s probably not worth it :sunglasses: Thanks!

One more question - what WiFi slot type can I use? Can I buy Intel BE200 with an E key? Will it fit?

Okay I’ve disassembled mine, here are some photos,

part 2:

Chips seems to be Micron on my Firebat T8

1 Like