My .trash-1000 folder is still there. It's not in linux, but in Windows. And I can't delete it. (Dual Boot system)

I got it. I ran into a silly problem. Now the USB stick should be fine and installed.



Edit: I will now boot with the usb stick, and see what I can do.

Sorry, but I didn't quite get that with the ssh issue. Something else I could do? Did you solve it?


are you using a linux formatted drive? if it is on a fat32 or vfat drive, yeah do NOT run that command. it is for linux formatted drives only. i have never ran linux on anything but linux formatted drives especially debian. run fsck in an interactive mode and it should not delete files. 

i did see the .trash-1000 directory, it is on a fat32 thumb drive i have. my real trash files are in ~/.local/share/Trash

i missed this. you can try the systemrescue cd, but mounting a windows drive depends on what format it is. 

# mount -t vfat /dev/sdb1 /mnt <- where sdb1 is the fat32 drive


ntfs-3g /dev/sdb1 /mnt <- where sdb1 is an ntfs drive

do not run fsck! you were right. i missed you were using a non-linux drive and that changes things. so if you haven't fixed it lets start over. 

and just post a brand new reply to line up the comments.

is the drive fat32 or ntfs? 

OK. What we have is the Harddrive: It's an NTFS filesystem. I am using it together with Debian 7, and Windows 7. Some files (even unreadable for Windows, but readable for Linux) area created in Debian 7, some files are created in Windows 7. I deleted over 200 GB of data. But it didn't work well (some files couldn't be deleted). So I went on, and deleted them in Debian. Then it was gone. But it's still there in Windows, in that folder .trash-1000, and I can't delete it in Windows. I went into hirens boot's parted magic, and looked into the drive, /media etc., and it didn't find anything when I wrote -ls, when I wrote -ls a it just gave me the   . and .. (Booting in miniwindowsxp and trying to delete it that way wasn't working either)

Now in systemrescue I am a little bit overchallenged. It doesn't show anything under: /media How do I make it show it? Or isn't it important anymore, since it wasn't possible for me, with me with parted magic? And yeah, if I run chdsk, I will make a backup. Didn't do it yet, I fell asleep, and forgot to hook it up to another Laptop with a harddrive for copying files. I will do that soon.


Edit: I've edited out the post a bit^^

[snip] you'll mount that with system rescue cd. and since it is an ntfs part then it would be similar to this

$ lsblk -f <- this command lists the partitions, their file system, uuid and mount point

$ ntfs-3g /dev/sdx# /mnt/windows <- mounts an ntfs partition into the /mnt/windows partition

i think it's /mnt/windows in sysrescuecd anyway. but in the example x is the letter where the linux part is and # is the number eg /dev/sda1 (would be the 1st partition on the first hard drive) like this

# ntfs-3g /dev/sda1 /mnt/windows

after mounting the drive you can navigate to the .Trash-1000 folder and delete the dir with this command

# rm -rf ./Trash-1000

make that 

# rm -rf .Trash-1000 <- changed sorry 1st cup coffee

i deleted the "if it has its own partition" it appears you have all this in one partition. never seen debian installed along with windows.

just a comment not related so much to your problem -> there is a "distribution" called cygwin that is an excellent way to run linux within windows. otherwise use the systemrescuecd to make two partitions and one will house windows and one will house linux. windows will be an ntfs partition and linux an ext4 partition. install grub in the mbr and install windows first.

i have to go install an ssd into a mac laptop. so don't feel bad about not seeing things. i asked the guy about the bios and he said what bios? lawl!. then i am thinking the thing has a rom not a bios. wtf? anyhoo... they have internet access and i'll connect via my tablet. thanks for putting up with me. i can get distracted pretty easily.

Lol. I remember doing that for somebody to. The difference was he had watched tons of videos, and wanted to do it himself. The only problem was, he constantly was thinking: Oh, I have to rewatch this, and that, and I am like WTF. I tell him something like: You have watched tons of videos how to do that, on that exact same laptop. Dude, how do you think they are doing this? Just see how it goes, and drag it out, and fit it in. No need for videos anymore! So he did everything, without watching a thing anymore. Some Apple kids are really funny XD. That with the bios is gorgeous^^. And don't worry, you are a great help. It's fun doing this with you :D.

OK. I did that with lsblk -f, and ntfs-3g/dev  ....

But when I try to mount it (I think I got it right) it doesn't show mountpoints (lsblk -f gives everything, but not the mountpoints). I write:

ntfs-3g/dev/sdb1 /mnt/windows

(sdb1 is the harddrive) but it doesn't work. It says: zsh: no such file or directory: ntfs-3g/dev/sdb1


ntfs-3g is the command. /dev/sdx# is the first arg. so there is a space between them.


# bash

at the prompt then retype the command.

we got the ssd in. took us a bit and had to go get a T6 torx driver. got one with a flashlight on it... 

screw driver with flash light... win! I hope his system runs juicy now ;).


ok, the mounting on the drive worked. I went to lsblk -f again and it showed me the mountpoint. I went in there, and typed ls -a still not a folder named .trash-1000.

maybe it has to do with how I accessed it? Under lsblk -f it showed: /mnt/window

But that gave the directory error message, so I navigated to: /mnt/windows  and it navigated to the harddrive. Strange. I thought I should mention it.


Edit: I mean navigated to the HDD.

can you see any files under /mnt/windows like bin, home, usr, var etc... after mounting it? if it is one partition you would be in the / directory. 

I can see every file (looks like it) that I was able to view in Windows and Debian. Just not the .trash-1000 folder, that I can only see in Windows. It's the same partition. (Some of the harddrive is used as swap, otherwise the drive is not partitioned)

that is odd. try ls -alF and if it is not there i am stumped. i can't see why a file is visible in one os and not in the other. go into windows maybe and take ownership of it, then try deleting it then try renaming it. see if you can open it and delete its contents. you probably did this, but the thread is long.. i knew for sure we'd see it..

I did ls -alF to now. This is crazy. Doesn't make a difference. I went into ownership etc. And it's free for users, admins etc. SYSTEM has not taken over it, or some other thing.