My .trash-1000 folder is still there. It's not in linux, but in Windows. And I can't delete it. (Dual Boot system)

i'm reading my last post and i see that i say delete then rename it.... that's backwards i think i was saying try deleting it and that does not work then try renaming it. 

so you're saying that you can get to the permissions page of the file in windows and you see the list of users in the security tab?

I renamed the folder to: i hate this folder

shit+delete still doesn't work on Windows. I go into properties, and security, and "Everyone" can access this folder.

add your username (even if it is administrator) to the list.

give it allow full control.

take ownership under advanced

try and delete it.

I think I am one step closer now. I renamed the folder to: i hate this folder

So, when booting into systemrescuecd, I am going into the harddrive again, and there it is! I got it. It displays the folder, and the name is ofcourse: i hate this folder.

OK, now the deleteing. How should the syntax be when deleteing? Iam afraid of deleting my harddrive. So should I write: rm -rf i hate this folder?


Edit: That was a stupid mistake in my last sentence. I edited it out.

yes, type 

# rm -rf i and hit the tab key. it might autocomplete to 

#rm -rf i\ hate\ this\ folder

spaces need a metacharcter to deal with the space or it will parsed incorrectly form the original command 

Damn it. I see, that I have 2 more of these folders. So I renamed them to. (but with: _ than spaces....). Ok, now I am going to fry some.....

oh man i thought for sure it would work.. well its just a machine.. he hehe... the spaces don't really matter just use the escape character "\" after each word. if you are in the zsh like i saw earlier type

> bash 

then you should get a bash prompt and it is "easier" to work in

OK, we nearly got it. I deleted 2 of the folders. (for anybody who will watch this thread. Everytime I mounted a partition, and was finished, and proceeded to the next harddrive, because I needed to get to the next file that I want to delete [.trash-1000 devil thingy] I had to unmount the harddrive I was currently in. So do: umount /mnt/windows to unmount your harddrive. And then navigate out of the directory of the drive you have unmounted to!)


Sorry, I just wanted to write this for anybody, who will have a similar problem. I had found topics about deleting .trash-100, but not something like this where only one operating system was seeing it. So I gave a little information for anyone there.


Nevermind. So I deleted already 2 of the 3 folders. One still remains vigilant XD. The original .trash-1000, the super-GOD. I will stop joking now. 2 of them I had renamed to: i_hate_this_folder, and ofcourse I forgot to (I guess I did) rename one of the folders, and it stayed: i hate this folder. I did it with \ as replacement of the spaces, and without them. Just simply the name. Both didn't work. Maybe add an " and another " at both ends of the file name, when doing rm -rf?

I think I have an idea, gonna be back soon....

I'm sure you emptied the waste basket in Linux and that's good. But do it for each account! I say "account" since stuff like XBMC usually has it's own user credentials and is famous for creating separate trash folders on different file systems (when it has to hop between NTFS and ETX4, for example). So you may want to shut those processes and all their child processes down before emptying. Kill these things or else that folder might reappear with more contents (cache stuff, most likely) causing the same headache all over again.

Once anything that may be trying to look at your NTFS partitions is shut down, then you might try unmounting your NTFS partitions before shutting Linux down. However, that mysterious .trash-1000 folder might still be there. But if it's empty Windows should at least be able to delete it.

Right now, I'm almost positive that Windows can't delete it because of the permissions and/or user privileges of the contents and possibly even the folder itself. So empty it in Linux and things should be easier -- I say, should! (Yes, even Windows pays attention to this stuff.)

But if worse comes to worse, you might try rebooting from a live CD (or another system and SSH into the system or actually physically attaching the HDD and going that way), get to a CLI with root privileges and try chown and chmod the folder and it's contents so that anyone can delete it -- and then delete it!

I can't say for sure that's going to work since you may still have to log on with identical user credentials in order to futz with things. So if it's really bugging you there's alternatively a Windows tool called File Assassin from Malwarebytes. (Search for it on CNet's Download area if that link didn't work.) I can't say if that's going to work either but it does seem quite able to disinfect other forms of digital herpes. ;-)

Good Luck.


anonymous 666 I've done about 90% of this in a linux live cd. >> The systemrescuedisk we've been talking about. (page one of the forumpost). And I did the chmod. I've been writing chmod +x to give it special permissions, and then tried to delete it again. Didn't work either. I am going to try File Assassin now....


OK. Here is a BIG breakdown: How it all started was with deleteing steam. Then I went into control panel, seeing that all my games names are appearing. So I deleted them one by one. After every deletion, it said something about not being able to find something. I guess it was talking about the roots of where the game actually is. Later on I saw that there are a bunch of files still left from steam. I try to delete them, and ofcourse it doesn't work. So, I delete them in Debian 7, with the wastebasket way. So I get my .trash-1000 folder. Now, while I was doing all the troubleshooting, I installed by the way (very bad mistake) steam, and two of my games again. (my fallbackmode, if I overheat *this is a joke). We will come back to those games. So after this time, and so forth, nearly everything got deleted. Nearly.... Now, why is this .trash-1000 folder (which I renamed) not deleteing like it's friends? The rm -rf command that gives me the error told me: (the name of the folder is: i hate this folder)

sysresccd windows # rm -rf "i hate this folder"
rm: cannot remove ‘i hate this folder/expunged/3857127132/SteamApps/common/Counter-Strike Global Offensive/csgo/resource/flash/econ/stickers/cologne2014’: Directory not empty
rm: cannot remove ‘i hate this folder/expunged/3857127132/SteamApps/common/Counter-Strike Global Offensive/csgo/resource/flash/econ/tournaments/teams’: Directory not empty
rm: cannot remove ‘i hate this folder/expunged/3857127132/SteamApps/common/Counter-Strike Global Offensive/csgo/resource/flash/econ/weapon_cases/crate_sticker_pack_cologne2014_01_slim_store.png’: Is a directory
rm: cannot remove ‘i hate this folder/expunged/3857127132/SteamApps/common/Half-Life/valve/save/c2a2d.HL1’: Input/output error
rm: cannot remove ‘i hate this folder/expunged/3857127132/SteamApps/common/Half-Life/valve/save/c2a2d.HL2’: Is a directory



This was, after the games where installed. So, after that, I deleted the local game content of that particular game, and then steam again, and so the game was deleted to. But the folder still remains. I can't delete it in linux like the others. Now, after all that, the new thing I am getting is this: (I renamed the folder to: iamgoingtodie)

rm -rf iamgoingtodie
rm: cannot remove ‘iamgoingtodie/expunged/702659509/expunged/3857127132/SteamApps/common/Counter-Strike Global Offensive/csgo/resource/flash/econ/stickers/cologne2014’: Directory not empty
rm: cannot remove ‘iamgoingtodie/expunged/702659509/expunged/3857127132/SteamApps/common/Counter-Strike Global Offensive/csgo/resource/flash/econ/tournaments/teams’: Directory not empty
rm: cannot remove ‘iamgoingtodie/expunged/702659509/expunged/3857127132/SteamApps/common/Counter-Strike Global Offensive/csgo/resource/flash/econ/weapon_cases/crate_sticker_pack_cologne2014_01_slim_store.png’: Is a directory
rm: cannot remove ‘iamgoingtodie/expunged/702659509/expunged/3857127132/SteamApps/common/Half-Life/valve/save/c2a2d.HL1’: Input/output error
rm: cannot remove ‘iamgoingtodie/expunged/702659509/expunged/3857127132/SteamApps/common/Half-Life/valve/save/c2a2d.HL2’: Is a directory

P.S. Anonymous666: I just tried the File Assassin, it didn't work.

So, the folder shrinked to a 120kb'ish folder by the way. If anyone was able keep a up with this.

Thanks for all the help. And espeacially thanks to you gnumber9 :). For now, I will not do a backup, and run chdsk. Let's see if there are going to be more ideas.... in the next 2 days or so. 

giant, what was the output of lsblk and lsblk -f? 

The format of the text in bash was not really applicable in the comment section here, so I made a photo:

(this is after everything done to the files&drives)

Edit: sdb1 is the harddrive where the folder is, and my datagrave. sdb2 is just the swap.

ever thought about a file server? i built one with an ivy bridge pentium (should have got a haswell) and an asus csm board, just sata 2, but it's a file server (use ext tools to maintain files)  and gigabit isn't going to go saturate sata2 nor mechanical drives. it's linux and has no gui.  it uses 70MB of ram out of the old 2Gb stick i had laying around. i have 2 1 TB drives i keep in sync with rsync a tool that is like robocopy but much more elegant. i could raid, but na, that means i would have to have backups and a spare drive. i do keep a drive of all my data i back up once a month and leave it off line. i also have a printer on the server and share it via cups and ipp. the files i share are nfs and samba shares. an older pc could work as well one like they sell on newegg for 150 bucks. the wendell asrock server video inspired me to at least want to do an ecc file server. thinking supermicro though. -- i'm rambling coffee...

so linux is in /dev/sda3? and you are sharing data between linux and windows in /dev/sdb1. and ... you have deleted files on sdb1 and apparently one that has an overload of gamma radiation and you created super trash can, the arch nemesis of the lowly system's administrator. LOL!! too much coffee sorry.

That sums it up. Sometimes I go into my windows desktop in Debian (so into /dev/sda2) and grab some files I need.

This could be done in a job interview with the folder: Copy this file into a harddrive, and tell the guys who applied for this job to delete this folder. The first one who makes it, gets the job. Lol.

Would be funny to watch to. My arch nemesis XD... Yeah. I think I will keep it in some usb stick, and try to deleted it 10 years later.


I will try to get some apprenticeship, then move out, read a bunch of Linux books (commandline will be the first ofcourse), and then that file server will become an option. And for now shift+delete will do the job in Debian, to not let the super trash can get more alliances. XD

i hear ya. red hat cert no doubt.

did you ever run an interactive file check of the ntfs drive while running windows?