My .trash-1000 folder is still there. It's not in linux, but in Windows. And I can't delete it. (Dual Boot system)

So I have deleted gigabytes, upon gigabytes of files at once in my linux distro (Debian 7, with gnome 3 [I run temporarily gnome 2 right now, if that could be any important, but that's very probably not the problem]). It first went into the wastebasket, (which uses a folder called .trash-1000 to store the "deleted" files] and then deleted the files from the wastebasket. It was about 300 gigabytes.

 

Now, if I boot into Windows 7, there is still that folder: .trash-1000

So, I say great! Let's delete.... Nah, Windows doesn't let me. It gives me this message:

An unexpected error is keeping you from deleting the folder. If you continue to receive this error, you can use the error code to search for help with this problem. Error 0x80070570: The file or directory is corrupted and unreadable.


So, I boot into my Linux distro, and write the command: ls -a. As super user. It's the command for finding hidden folders, the folder which start with a . so I can find the hidden folder .trash-1000

So I see where that folder is, so I can delete it. But it's not there! It doesn't find it:

 

[email protected]:/home/arthur# ls -a
. Documents .gtk-bookmarks .profile
.. Downloads .gvfs Public
.bash_history .fontconfig .ICEauthority .pulse
.bash_logout .gconf .local .pulse-cookie
.bashrc .gksu.lock .mission-control Templates
.cache .gnome .mozilla .thumbnails
.config .gnome2 Music Videos
.dbus .gnome2_private Pictures .xsession-errors
Desktop .gstreamer-0.10 .pki .xsession-errors.old


Because of course I deleted it with deleting the wastebaskets content, but Windows still sees it. And it sees it as a 230'ish GB sized folder. I've googled around, and now I can scan it with chdsk to clear this up. Problem is, even if chdsk should't delete files, I've found forum topics which show people that have delted files from chdsk. Lot's of files. Before I deleted this, I had a chdsk scan, that always wanted to run, everytime I wanted to boot up into windows 7. I've disabled it in regedit. I went in regedit into: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager, and went into BootExecute, erased the text in it, and pressed ok.

 

So, here I am. Will chdsk perhaps delete files, while performing, without any other special command? I am making a backup now, (exept of the .trash-1000 folder, or this will happen probably in another windows system with >that backup harddrive) and try to scan with it. Maybe you guys can help me do it right the first time.  Will chdsk harm my files?

 

try shift-delete in both linux and/or windows.

thanks a bunch. 10 GB are left, that give the error message. I want to get rid of this to.

i see your online so i won't edit my first comment. i admit i did not finish reading your thread that was rude sorry. this sounds like an extended attribute issue. i've delt with them in the past, but it's been a while. there is way to delete it and you sound like you got the skill, so simple things you've probably tried. i know this sounds simple as well, but have you tried mounting this in another live environment and deleting the file from there? ie sysrescuecd. 

Do you mean booting into another linux distro (not from a harddrive, but a bootable device), and try to delete it in this environment? If yes, I could just hook up my hirens boot right now, and do it. (but after I made a backup)

yeah, I just googled: sysrescuecd.

I will do that, just need to transfer my files via Ethernet cable, it will take a bit, I will report later then. Thanks.

cool... yes, i would use sysrescuecd. one tip on that. if you make a bootable usb with it, don't mount the iso in the /mnt dir. the script uses that dir to make the usb stick. i just mkdir a directory something similar to /home/me/pendrive and mount the iso there and run usb_install.sh  from there as su

yeah. It would make things easier. I've just tried it with hirens boot's linux enviroment, and it didn't see any files in the hard drive, which was strange. When I writed in the harddrive: ls -a, it gave me the . and the ... Lol, directory, and parentdirectory. Maybe I went into the harddrive wrong, the harddrive was labeled as sdba1, so I went into it in the commandline. I will try to do the mounting of the .iso in the commandline, let's see if it works with my low skills :).

Edit: I mean I ran ls, and it didn't show any files, then I ran ls -a, and it gave me the directory signs. Yeah...

i would boot the pc with the disk or usb. then mount the drive with the .trash-1000 file into /mnt. eg: 

$lsblk <- to find the partition and if it's on sdb then,

$ mount -t ext4 /dev/sdb1 /mnt 

$ ls -alF / or whatever dir <- make sure the file is there or can be displayed

# rm -rf  .trash-1000 (careful with rm -rf)

probably in your home so

$ls -alF /home/username

/home/usename # rm -rf .trash-1000/

i might be just blowing hot air. i cannot make a .trash-1000 file on my linux part... is the drive a fat32 drive?

ok, at the installation instruction for sysrescuecd it gives me:

 

Mount the CD-ROM ISO image
You first have to mount the ISO image (or a media where you have burned it). You just need an empty directory on your system on which the ISO image can be mounted. We will use /tmp/cdrom in this example but you can use any directory such as /mnt/cdrom:

mkdir -p /tmp/cdrom
mount -o loop,exec /path/to/systemrescuecd-x86-x.y.z.iso /tmp/cdrom

 

So I navigated to the place where the pen drive is:

how would the mount -o command look like? Like: mount -o loop,exec /home/me/pendrive /tmp/cdrom

?

i'll get that for you let me do it as well and i can copy it to here

the filesystemtype is msdos. When I installed hirens boot, I used rufus on (meh) Windows, and said it should do simply an .iso image.

first i make a directory and name it anything. i will name mine usbdrive

$ sudo mkdir usbdrive

$ sudo mount -o loop systemrescuecd-x86-4.3.0.iso usbdrive/

$ cd usbdrive

usbdrive $ sudo ./usb_inst.sh

i made a .Trash-1000 file. the 1000 is a user id. 1000 is the default first user in debian (as well as (k)(x)(l)ubuntu). i did not get the same error deleting the file... well sounds like a corruption or disk pointer issue. i think you said you ran fsck. which would have been my next move. then mount it in sysrescd.. i like debian stable. i run it on my laptop which i take with me. it has a serial port i can connect to a switch. course i haven't had to... just at school. it's about 12 years old.. i think. i used to run openbox now i run xfce on it.

also since the user is 1000 any user with that id i would think could delete it. also 0 (root) should be able to do it. i have files on a file server that clonezilla make and i am unable to delete these while i am sshed into the server and am root. i have to delete them at the machine. i figured it is a ssh issue and i have not looked it up, so i walk 10 feet and do it.

ok, it seems like it's installing it... I get back to you if it's finished.

By the way: You did this explanation very well. Every time I go to forums, I have to thoroughly think how the communication with the system in that particular command works, or have to google many pieces, or both. But this was easy to understand.

1. No. I didn't run an fsck/chdsk! That's my last move. Because if I do it, I will make a backup (didn't do it yet, it would take the whole night). Because I've read on forums, and espeacially on forums with people with a dual boot system, that some people lost files. And not some files, but many files. I even have files that windows can't read on the drive, which it could easily delete, but I use them on Debian. And the .Trash-1000 folder is only visible in Windows. (or I was doing ls -a wrong)