Memory Unleashed on Threadripper: 128gb & 2933 & ECC tested | Level One Techs

I sent it to the fan that bought it, so I dont have it anymore

I added one more (slightly crazy) result to the list.
In tests were the crucial ram does well, it’s untouchable, even against the craziest of clocks ( 2-14-14-14-14-34 @ 3133 MHz ).

If I wanted to duplicate your tests the command would be:

phoronix-test-suite benchmark 1811116-FO-1810311FO90 ?

I got a basic phoronix test running real quick on Arch 4.19.2 kernel with my 2950X w/ 128GB ECC and I’m getting some #1 results with the command you posted earlier in the thread

phoronix-test-suite benchmark 1810154-FO-MEMORY29909

Update: Here are the results:

1 Like

I missed your original post, though as you found, you had the magical incantation correct.

The 1810154-FO-MEMORY29909 results were from before a BIOS update that appeared to resolve the strange behavior that was being seen.

See Wendell’s updated entries added to the test here:

I added a timing matched comparison (and removed a bunch of older results) here:

I merged your score into the 1810262-SK-1810269FO64 results along with bringing back the previously removed 2950X scores for comparison.


I tried running a test paralleling your last set, but i’ve run into issues with some tests failing. Going to have to do some digging in the logs to figure out what needs to be fixed.

I’ve encountered and worked around a few phoronix test suite issues so yell out if you get stuck (list the failing tests), it may be ground I’ve already covered.

added additional 128gb testing on Asus X399 A and GSkill TridentZ 128gb kit 950X + GSkill TridentZ 128gb 2933 Asus X399A NUMA/UMA

1 Like

I have 8 Samsung 16GB DDR4-2400 ECC Server Memory M391A2K43BB1-CRC00, unregistered on my X399-DESIGNARE
Your mileage may very but I’ve had it at 2933GHz CL16 now for almost a year.
I’ve not run a huge amount of benchmarks but the game benches I’ve run on my Windows VM saw a performance improvement each time I uped the frequency.

Your Mileage may vary, I did not expect to get the sort of frequency’s I got.

I shall try and learn how to run the bench mark this week end and post results.


It’s super easy if your distro lets you install the Phoronix test suite.

On fedora it was all gui …Software app and Phoro…it poped up.

Yep It is, WGet the deb from the site, dpkg -i, find and resolve dependency install tests.
It looked a little intimidating from the manual at first but I’ve managed to install some tests and run the first one all from the console.
They seem OK for 2933?
I’ve 15 VMs running so… I could find some more performance…

I’ve worked out how to get all the tests on one link

Is it possible to remove a result? I didn’t intend to upload “Jef_UKs_1950x-2933_ECC-CL16” and cancled it part way through to re run with a name that matched the rest better and it looks a mess sorry :confused:

Certainly not for any anonymous test results, that would be a bad idea.
I’m not sure what might be offered with an account though, that info seems to be a bit sparse.

You can clone any of the tests that are online, rename, sort, and remove any entries, and re upload it, though it will get a new name and link.

@wendell I was a little late getting to your last video update on Threadripper memory, thanks for the shout out :slight_smile:

@CrayZeApe have you ever seen this issue with pts/opencv-bench-1.0.0/opencv-benchmarks-0.1?

/home/…/.phoronix-test-suite/installed-tests/pts/opencv-bench-1.0.0/opencv-benchmarks-0.1/src/discrete_fourier_transform.cpp: In function ‘int main(int, char**)’:
/home/…/.phoronix-test-suite/installed-tests/pts/opencv-bench-1.0.0/opencv-benchmarks-0.1/src/discrete_fourier_transform.cpp:39:30: error: ‘CV_LOAD_IMAGE_GRAYSCALE’ was not declared in this scope
Mat I = imread(filename, CV_LOAD_IMAGE_GRAYSCALE);
/home/…/.phoronix-test-suite/installed-tests/pts/opencv-bench-1.0.0/opencv-benchmarks-0.1/src/discrete_fourier_transform.cpp:84:33: error: ‘CV_MINMAX’ was not declared in this scope
normalize(magI, magI, 0, 1, CV_MINMAX); // Transform the matrix with float values into a
/home/…/.phoronix-test-suite/installed-tests/pts/opencv-bench-1.0.0/opencv-benchmarks-0.1/src/discrete_fourier_transform.cpp:84:33: note: suggested alternative: ‘CV_MMX’
normalize(magI, magI, 0, 1, CV_MINMAX); // Transform the matrix with float values into a

Phoronix then complains:

        Test Installation 1 of 1
        1 File Needed [0.04 MB / 1 Minute]
        File Found: opencv-benchmarks-1.0.tar.gz                    [0.04MB]
        Installing Test @ 17:48:28
            The installer exited with a non-zero exit status.
            ERROR: collect2: error: ld returned 1 exit status
            LOG: ~/.phoronix-test-suite/installed-tests/pts/opencv-bench-1.0.0/install-failed.log

    [PROBLEM] pts/opencv-bench-1.0.0 is not installed. 

Looks like it’s not seeing the OpenCL libs.

I’m not sure what options Arch gives you for OpenCL, but many tests require OpenCL 2.0.
Mesa can be build with OpenCL 1.1 support in the form of Clover, but for 2.0 support, you might be limited to what comes with the proprietry graphics drivers for now, in which case it becomes more of a GPU compute test than anything else.

You can install opencl-amd and see how you go.

Relative Info:

Greetings! I recently tried to join the 128gb ram on Threadripper club, but I failed. My build log is Here

I got it booted up earlier today and only 4 of the 8 ram sticks are showing up in UEFI. I’ve read up a ton in preparation for this build and I suspect the CPU needs to be re-seated, but I would really appreciate your feedback.

Thanks in advance for your help!

Use your cell phone to take really close up pics. Loose dimm? Seated level both edges? Take pics to show ram seated right on both sides? Used the toruqe wrench well?

Good evening good sir!

This is my first Threadripper build, but I’ve installed at least 1000 if not 2000 ddr4 modules and I have not had this issue before.

I followed these two videos as my method of installation for the CPU:

An interesting aspect is that it is all of the sticks on the right side, i.e.


Any chance the memory is in backwards on that one side? The memory orientation rotates between the two sides? Remove all the memory from that side ?

Edit: yep in your pic the memory is in backwards on one side which means it’s not snapped in all the way on the one side.

Because TR, the memory sticks rotate around the socket. Memory on one side is rotated 180 degrees relative to the other side on TR. (Not so on Intel, sometimes)

Lol Wendell! You know that feeling you get when you’ve left the house and someone says “You locked the front door right? , You turned off the stove right? , You closed the garage door right?,” You know you did it, but that seed of doubt has been planted and it just grows and grows until you go back and check it.

I read your message but then wasn’t able to get back to the machine for hours. Needless to say, the doubt-tree grew to full size. You got me good on that one lol! :joy:

The memory is correctly installed on both sides, in 180 degree rotation like you mentioned! When I went to populate the left side, I did do a double take about the rotation before I installed the memory. I made a note of that Gotcha in my personal build notes to share with future builders as well.

I’m at the workbench for a bit now and hopefully I can get this resolved. It will be a shame if I have to take the cooler off as I was hoping to get some thermal performance benchmarks with the pre-applied TIM included with the Wraith Ripper to share with future builders.

Also, a forum member mentioned that they do not see images in my build log, only links. On my end I see images and captions. What do you see on your end?

Seriously, I appreciate you taking the time to share your feedback with me. I’m new to this community, but I’m extremely pleased with what I have seen so far.