Return to Level1Techs.com

Memory Unleashed on Threadripper: 128gb & 2933 & ECC tested | Level One Techs


#61

Good work. It’s nice to confirm that for the same speed/timing, dual rank really is the way to go in threadripper (if you can afford it) given the seeming hard 2933mhz wall when using 8 sticks. What’s a bit surprising is how much 4 single ranked but higher clocked sticks lag behind in most cases.

For those that aren’t aware, single rank sticks can sometimes edge out dual rank sticks because you can overclock them harder. With threadripper that’s not really going to happen.

Still don’t regret my single rank sticks given the going prices and what was available when I got them, especially since I’d still have hard time beating that.


#62

Very interesting results. Some of results are completely opposite. Like 2x 3200 sticks vs 8 x 2666. In Kernel comp, 3200 is 2x faster , but then in rendering or compression is the complete opposite,2x slower. Just madness :smiley:


#63

The posted benchmark results indicate that the 8x16GB Crucial test was run at 1280x720 resolution. If so then the two game benchmarks could do with a refresh.
That being said, the Crucial ram appears to be performing exceptionally well at stock 2666MHz.


#64

Just madness?

Only when you forget to take note of the “more is better” and “less is better” text above the test. :smiley:


#65

While it’s true that overclocking 8 sticks on Threadripper isn’t really going to happen (though I can push it to 3000mhz), setting tighter ram timings can go a long way toward matching the dual rank performance.


#66

Yes the game res is wrong, I noticed that later too, but I did pts benchmark (the other benchmark name for comparison) so not sure how to coax it into running right. Maybe a different GPU driver than expected or need an older kernel.

Idk what the 7980xe settings were either but that’s a super fascinating result. All the non game results are super interesting


#67

Is there a reason since the review of it, the Zenith Extreme board hasn’t been featured in any more level1techs videos?


#68

I sent it to the fan that bought it, so I dont have it anymore


#69

I added one more (slightly crazy) result to the list.
In tests were the crucial ram does well, it’s untouchable, even against the craziest of clocks ( 2-14-14-14-14-34 @ 3133 MHz ).

https://openbenchmarking.org/result/1811116-FO-1810311FO90


#70

If I wanted to duplicate your tests the command would be:

phoronix-test-suite benchmark 1811116-FO-1810311FO90 ?

I got a basic phoronix test running real quick on Arch 4.19.2 kernel with my 2950X w/ 128GB ECC and I’m getting some #1 results with the command you posted earlier in the thread

phoronix-test-suite benchmark 1810154-FO-MEMORY29909

Update: Here are the results:

https://openbenchmarking.org/result/1811167-RA-1810154FO35


#71

I missed your original post, though as you found, you had the magical incantation correct.

The 1810154-FO-MEMORY29909 results were from before a BIOS update that appeared to resolve the strange behavior that was being seen.

See Wendell’s updated entries added to the test here:
https://openbenchmarking.org/result/1810255-FO-MEMORY29944

I added a timing matched comparison (and removed a bunch of older results) here:
https://openbenchmarking.org/result/1810262-SK-1810269FO64


#72

I merged your score into the 1810262-SK-1810269FO64 results along with bringing back the previously removed 2950X scores for comparison.

https://openbenchmarking.org/result/1811187-SK-MERGE836516


#73

Thanks!

I tried running a test paralleling your last set, but i’ve run into issues with some tests failing. Going to have to do some digging in the logs to figure out what needs to be fixed.


How Well Does 128 GB of DDR4 Work On Threadripper? | Level One Techs
#75

I’ve encountered and worked around a few phoronix test suite issues so yell out if you get stuck (list the failing tests), it may be ground I’ve already covered.


#76

added additional 128gb testing on Asus X399 A and GSkill TridentZ 128gb kit 950X + GSkill TridentZ 128gb 2933 Asus X399A NUMA/UMA
https://openbenchmarking.org/result/1811207-FO-1811187SK17


#77

I have 8 Samsung 16GB DDR4-2400 ECC Server Memory M391A2K43BB1-CRC00, unregistered on my X399-DESIGNARE
Your mileage may very but I’ve had it at 2933GHz CL16 now for almost a year.
I’ve not run a huge amount of benchmarks but the game benches I’ve run on my Windows VM saw a performance improvement each time I uped the frequency.

Your Mileage may vary, I did not expect to get the sort of frequency’s I got.

I shall try and learn how to run the bench mark this week end and post results.


#78

It’s super easy if your distro lets you install the Phoronix test suite.

On fedora it was all gui …Software app and Phoro…it poped up.


#79

Yep It is, WGet the deb from the site, dpkg -i, find and resolve dependency install tests.
It looked a little intimidating from the manual at first but I’ve managed to install some tests and run the first one all from the console.
https://openbenchmarking.org/result/1811235-RA-RUN1STREA45
They seem OK for 2933?
I’ve 15 VMs running so… I could find some more performance…

I’ve worked out how to get all the tests on one link
https://openbenchmarking.org/result/1811232-RA-4939X399D75

Is it possible to remove a result? I didn’t intend to upload “Jef_UKs_1950x-2933_ECC-CL16” and cancled it part way through to re run with a name that matched the rest better and it looks a mess sorry :confused:
https://openbenchmarking.org/result/1811235-RA-1810154FO56&obr_hgv=Jef_UKs_1950x-2933_ECC-CL16&obr_sor=y&obr_hgv=Jef_UKs_1950x-2933_ECC-CL16


#80

Certainly not for any anonymous test results, that would be a bad idea.
I’m not sure what might be offered with an account though, that info seems to be a bit sparse.

You can clone any of the tests that are online, rename, sort, and remove any entries, and re upload it, though it will get a new name and link.


#81

@wendell I was a little late getting to your last video update on Threadripper memory, thanks for the shout out :slight_smile: