Lubuntu - HP Pavilion x2 Detachable PC 10 (tablet) sound issue

Edit Update: April 20th 2019 23:54pm

  • installing to the latest linux kernel does indeed help get the bluetooth working! in addition to the steps below!
    • kernel version
[email protected]:~$ uname -r
5.0.9-050009-generic

Edit Update: April 20th 2019 15:21pm

  • Well i got serious, I hooked up a monitor, keyboard&mouse and got to cracking down on this HP tablet sound/wifi/bluetooth issue and I got some results…
  • Ubuntu 19.04 Disco Dingo consumed too much memory and sucked down my tablets battery life, at first it seemed all is well but opening up more than web browser and a terminal seemed to really bog it way down, cause hangs/crashes.
  • I have installed Lubuntu 18.10 once more, seeing that bluetooth was working on Disco Dingo that inspired me to get the bluetooth working on Lubuntu 18.10. Safe to say I accomplished that goal. Never give up, never surrender, never go backwards, never go forwards, just do it.

I will now attempt to describe what I did to get bluetooth working on Lubuntu 18.10 on this HP tablet (Disclaimer: i am by no means a linux expert but i do have a background in computer programming so take everything i mention i with a grain of salt.)

  1. I installed the UCM files for the bytcr_5640 from this repo and why the hell not i installed these sof bytcr-rt5640 here as well. Follow the readmes within the UCM files for each one.

  2. I installed this firmware for my RTL8723bs from here

  3. at this point no bluetooth, no audio, and no wifi

  4. feeling lost, I took to researching and just reading similar problems other linux users were having

    • here the user tauro_kpo provided some instructions on how to set a permanent sound device and black list the hdmi audio. I followed these instructions on how to blacklist sound modules In the end I undid this since it provided no fixes
    • I read something about perhaps blacklisting the ATOMISP kernel module perhaps conflicting with intel SOC, basically my tablet has a crappy front facing camera so I thought perhaps this was related
    • I installed the UKUU tool, I remember Wendell mentioning this and upgraded to the lastest linux kernal sudo ukuu --install-latest still no bluetooth/audio/wifi :frowning:
  • I came across this terminal command sudo dmesg and some errors that the files rtl8723bs_config-OBDA8723.bin, and rtl8723bs_fw.bin could not be found! Bingo, lets get these files and put them where the os thinks they should be, turns out these files are part of the linux-firmware package, odd i already have linux-firmware installed. I grabbed the needed files here and copied them to /lib/firmware/rtl_bt/
  • at this point i rebooted and bluetooth manager started to breathe signs of life, it looked like it was actively searching for devices in the area, I place my bluetooth right on top of the tablet and BINGO, I pair and connect it. However if i moved the bluetooth headset more than < 1 inch the connection would be lost
  • righto, so the bluetooth radio signal is super low… I search on how to fiddle with the bluetooth radio signal i found this and this Both of which have now been UNDONE
  • At this point I wanted to just make sure the bluetooth wasnt busted so I booted into Windows 8.1 and tested the bluetooth, everything checked out good. I walked to my front door to test the signal door and signal remained strong
  • At one point i deleted the pulseaudio *.tdb files and such, i lost the link that described this, basically pulseaudio would rebuild these files
  • Well i i think I know what was killing my bluetooth and that was having the my built in internal Wifi enabled, turning it on kills the bluetooth signal. I will keep testing…
  • confirmed, turning on the internal WiFi or using a USB WiFi adapter causes the bluetooth signal to immedietly cut out.
  • for now i can use a 4 port usb with a hard line ethernet port to browse web, listen to music basically any of my media needs.

Edit Update: April 18th 2019 22:40PM

  • I installed Ubuntu 19.04 Disco Dingo

Good news

  • blutooth works out of the box so I can listen to music and Level1Tech News on my blutooth headphones while I am at work now!!!
  • pretty snappy, clicking around and opening programs is quick and responsive
  • tablet’s volume rocker button functions
  • touch screen behaves as expected, dragging your finger down on a webpage moves the page down and does not highlight text

Bad news:

  • it sees the speakers but still refuses to output any audio to the internal speaker or headphone jack
  • internal wifi also still does NOT work
  • being that both those are Realtek Semiconducter wifi and audio I am not surprised
  • oh and also my tablet was oriented the wrong way, it was oriented vertically by default and not horizontal with no options to flip it back run the terminal command to get it back to horizontal
    xrandr -o normal
  • battery disappears quick
  • the auto orientation works but seems very confused, i will probably turn this off
  • camera not detected

In the meantime

  • Having a way to listen to audio is all I wanted!!
  • I will keep searching for solutions to get the internal wifi and sound working
  • Thanks to everyone who posted to make suggestions, I find that simply discussing a matter usually leads to a solution
    • As a note to people looking as this post in the future if you wish to install a 64bit linux distro using the HP Pavilion x2 Detachable PC, you must first build the bootable usb like normal but then place a 32bit UEFI in the bootable usb;s folder /efi/boot/bootia32.efi Find a efi file here https://github.com/hirotakaster/baytail-bootia32.efi/blob/master/bootia32.efi
    • once that is done press F9 to get into HP’s boot option menu, usually it will detect the bootable usb but you may have to navigate to the file by selecting “boot from EFI file”
    • though this is only for tablets with a 32 bit UEFI like this HP

Edit update: April 18th 2019 1:04pm

  • During my lunchbreak I decided to reinstall Lubuntu 18.10
  • installed the UCM files listed in the github repo and cold reboot my tablet and I am now seeing a audio output titled “Built-in Audio MonoSpeaker playback + Speaker playback + Headphones playback”
  • I believe I installed the wrong UCM file then realize my mistake then installed the correct one last time. easy to confuse the repo files bytcr-rt5640
    and byt-rt5640 in my case bytcr-rt5640 being the correct one.
  • Even though I have pulseaudio no longer showing the Dummy Output I still cannot hear anything out from the speakers or headphones plugged in. Any ideas?

pavucontrol-qt


Edit update: April 17th 2019 5:26pm

  • when running the terminal command hwinfo I see this output
----- kernel log -----
  <3>[  102.409219]  Baytrail Audio Port: ASoC: no backend DAIs enabled for Baytrail Audio Port
  • Does that mean anything?

Hello Level1Techs and everyone, this is my first post here! I have been lurking in the shadows reading all sorts of interesting topics however my favorite thread has been “Post your battle stations” Post your battle stations! what a awesome thread, I will probably post there today when I get chance.

I have been experimenting with installing Linux on my HP Pavilion x2 Detachable PC 10 (tablet)

  • Attempt #1: Having fallen in love with Linux on my home personal machine, I thought Ubuntu 18.04.02 LTS would work and it ran and everything but I got frustrated due to not having WiFi or sound working so i retreated back into Windows 8.1

  • Attempt #2: I did some reading about what distributions would work for certain devices and then attempted to install Debian stretch and it worked but still no WiFi or sound and i didnt really dig the UI and interface as well so I retreated back into Windows 8.1.

  • Attempt #3 (present): I really did like the consistency and wealth of information there is for Ubuntu so I installed Lubuntu 18.10 which I read was a good candidate for the lightweight hardware that is the HP Pavilion x2 Detachable PC 10 AKA HP tablet for short.

Currently the tablet has dual boot Windows 8.1 and Lubuntu installed, the goal being I delete the partition for Windows and go full 100% Linux. I would really like to get at a minimum the sound working for the HP tablet since I can get WiFi through a USB WiFi adapter. So I have done a pretty good amount of web searching and trying various things to get the sound working but to no avail.

I should be a little bit more specific when I say sound not working, when I open Configure “Volume Control” on Lubuntu all i see is the Dummy Output for Pulseaudio but for Alsa I see a bunch of different options from hw:1 - Speaker, hw:1 -Mono DAC, and many more… And even more specifically is that the headphone jack and internal speakers output no sound what so ever. BUT I can plug in a mini HDMI to a monitor or TV and audio does go out to the monitor’s or TV’s speakers and when I do this Pulseaudio no longer displays the Dummy Output of course. To summarize I have no sound on the headphone jack or internal speakers but plugging a mini HDM to a tv or monitor I have audio out.

What have I done so far in attempting to fix this?

        snd_soc_sst_bytcr_rt5640    32768  1
        snd_intel_sst_acpi     16384  1
        snd_intel_sst_core     53248  1 snd_intel_sst_acpi
        snd_soc_sst_atom_hifi2_platform   102400  2 snd_intel_sst_core
        snd_soc_rt5640        126976  2 snd_soc_sst_bytcr_rt5640
        snd_soc_acpi           16384  2 snd_soc_sst_bytcr_rt5640,snd_intel_sst_acpi
        snd_soc_acpi_intel_match    20480  1 snd_intel_sst_acpi
        snd_soc_core          229376  5 snd_soc_sst_bytcr_rt5640,snd_soc_rt5670,snd_soc_rt5640,snd_soc_sst_atom_hifi2_platform,snd_soc_rt5645
        snd_pcm                98304  8 snd_soc_sst_bytcr_rt5640,snd_soc_rt5670,snd_soc_rt5640,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_soc_rt5645,snd_pcm_dmaengine
        snd                    81920  16 snd_seq,snd_soc_sst_bytcr_rt5640,snd_seq_device,snd_timer,snd_compress,snd_hdmi_lpe_audio,snd_soc_sst_atom_hifi2_platform,snd_soc_core,snd_pcm,snd_rawmidi

Last night I attempted to fix the audio and it led me into this website https://thesofproject.github.io/latest/introduction/index.html which seemed to be overkill and may not even fix my problem. I tried to install the sof repo using docker but docker confused the hell out of me because I do not have much experience with docker.

Any assistance in this sound issue would really be awesome and if you want to see any output of specific terminal command lines let me know and I will get back to you! Thanks again!

4 Likes

Heya and welcome, it’s gonna be all downhill from here.

So you replaced the UCM files as described in https://github.com/plbossart/UCM/tree/master/bytcr-rt5640, did you have pulse audio volume control (pavucontrol) installed to check if your card was recognized?
It’s a broader tool for configuring audio devices than DE defaults.

Hey thanks for responding!
Yes thats correct, when I installed those UCM files (bytcr-rt5640) they warned me i was overrriding some other files from the package linux-firmware which I ended up having to force the overwrite, so they are certainly installed. pavucontrol is installed and up and running, under “Output Devices” I see the Dummy Output while Show is set “All Output Devices”.

Interesting I played around with the pavucontrol and under Configuration I see
Digital Stereo (HDMI) Output (unplugged)
Digital Stereo (HDMI 2) Output (unplugged)
Digital Surround 7.1 (HDMI) Output (unplugged)
…etc… but just HDMI Outputs

I selected DIgital Stereo (HDMI) Output (unplugged) and now that appears in place of the Dummy Output. Neat stuff. Did you want me to screen grab or look at anything specifically?

So there’s no ‘analog stereo duplex’ or the like under the configuration tab?
In that case yeah your confs are still borked.

Damn can’t help atm I’ma have to go to bed and I don’t even have a machine to replicate the issue…

No worries, I will keep investigating!

The Linux sound system isn’t really my bag o’ donuts. But, I’m guessing that your tablet has a Broadcom WiFi chipset, which is the bane of many Mac and Dell folks trying to get WiFi running on their laptops. There are obviously exceptions, but many ISOs don’t seem to include the necessary Broadcom binary. And, if your tablet/laptop does not have an Ethernet port, it can be inconvenient to connect with your distribution’s repository, in order to secure the needed driver. If you are determined to use Debian, It may be possible to use another machine to snag the correct driver. It may also be possible to replace the inconvenient Broadcom WiFi hardware, if your BIOS doesn’t include a WiFi white list. Or you may choose to browse through some different distros to see if one includes a better selection of WiFi drivers in their ISO file.

Best of luck!

Yeah I think the internal WiFi is a Realtek something or another
Here is a partial snippet output from running
hwinfo
P: /devices/platform/INT33BB:00/mmc_host/mmc1/mmc1:0001/mmc1:0001:1/net/wlan0
E: DEVPATH=/devices/platform/INT33BB:00/mmc_host/mmc1/mmc1:0001/mmc1:0001:1/net/wlan0
E: DEVTYPE=wlan
E: ID_MM_CANDIDATE=1
E: ID_NET_DRIVER=rtl8723bs
E: ID_NET_LINK_FILE=/lib/systemd/network/99-default.link
E: ID_NET_NAME_MAC=wlx00e04c870000
E: ID_OUI_FROM_DATABASE=REALTEK SEMICONDUCTOR CORP.
E: ID_PATH=platform-INT33BB:00
E: ID_PATH_TAG=platform-INT33BB_00
E: IFINDEX=2
E: INTERFACE=wlan0
E: SUBSYSTEM=net
E: SYSTEMD_ALIAS=/sys/subsystem/net/devices/wlan0
E: TAGS=:systemd:
E: USEC_INITIALIZED=10452441

Does this mean I can get the internal WiFi working as well? I am seeing some possible solutions when searching for rtl8723bs + Ubuntu

Wish I could help more, my trouble shooting skillls are “try next distro”

Only lite version I have experience with is LXLE because it worked on my old e machines 1300,

I was amazed how the light linux’s can really make old hardware useful and fun again, cool thread btw

2 Likes

Many of the Bay Trail/Cherry Trail era devices had myriad issues from the 32 bit boot loader to sound and networking issues when trying to get Linux going. I was fortunate that the desktop boards didn’t have such issues, so I don’t have first hand experience, but many people having issues ended up using Linuxium. Here is a page that should have a few options for you:

Hopefully something on that page can lead you to getting things working. I don’t really know anything about their ISO’s or the isorespin thing, other than remembering many people saying it was the only way to get everything working on similar devices. You could always ask for help in the comments. If you are still having trouble then you may want to either look for other sites where people have specifically gotten your tablet fully functioning, or sites supporting similar hardware like other Bay Trail tablets and TV sticks.

If that doesn’t work, I know guys over at liliputing.com and cnx-software.com have talked with the Linuxium guy in the past and they would be more knowledgeable about this than most people. I know at least on cnx that you can post on really old pages and still likely get a response. The comments section over there has a lot of smart and helpful people.

1 Like

Realtek tends to be somewhat schizophrenic. Sometimes they support Linux with drivers and sometimes they don’t. It looks like some other folks have had some luck building a driver from source. This isn’t the friendliest introduction to Linux, but doable for someone who is patient and willing to learn.

http://forums.debian.net/viewtopic.php?t=134853

1 Like

I have gotten the Dummy Output to go away and it now detects the internal speaker/ headphone plug but it still does not output sound either playing a song on soundcloud.com or running the command speaker-test Please take a look at the updated information in my original post.

I added the “helpdesk” tag so it is easier to find by people actively helping on this forum.

@khaudio can you help in this situation ?

maybe @PhaseLockedLoop also take a look ?

2 Likes

Give me 10

2 Likes

While @PhaseLockedLoop is writing, go ahead and re-check the different options in the advanced tab now that your outputs are recognized.

1 Like

I can defintely hear a slight static pop when switching from speaker playback to headphone playback. I think I am close :slight_smile:

There’s different audio modes under the advanced tab, if you have a faulty setting you won’t get audio, but if it’s still silent after testing every option then wait for a more advanced reply

First off welcome to the community! thanks for stopping in

as for your issue. I realize your running with Ubuntu. Im going to post my response to this on the exact same issue on red hat based distros then we can adapt it below this post

For audio to work on Bay Trail or Cherry Trail bases devices you need to have an UCM profile for your device.

You need to basically build a backported alsa lib. Its not too hard but lets roll with it

https://fedorapeople.org/~jwrdegoede/alsa-lib-ucm/

Download the alsa-lib-1.1.6... and alsa-ucm-1.1.6... files and in a directory with both these files run:

sudo rpm -Uvh alsa-*.rpm

To install the new version, then do:

killall pulseaudio

After this you should have working sound. Chances are that your device has only a single speaker and needs a kernel quirk to mark it as such, to test this go to the sound settings in gnome-control-center and hit the "test speakers" button, you will likely only hear sound for the left speaker.

To test if the mono speaker quirk helps, add the following to the kernel commandline: snd_soc_sst_bytcr_rt5640.quirk=0x563432

Your device may also need a quirk for the internal microphone and for detecting if headphones/a-headset are plugged in.

To test the internal microphone do:

sudo dnf install gnome-sound-recorder

And then run gnome-sound-recorder (without any headphones / headset plugged in) and make a test recording. If this does not work, try using the following quirk
setting instead:

snd_soc_sst_bytcr_rt5640.quirk=0x563433

Notice the last 2 has changed to a 3 and no other changes.

Once you've the microphone working, please test that headphones get seen when plugged in (they should show up in the sound settings in gnome-control-center)
if you had to change the quirk for the microphone you likely also need to change it for jack-detect into:

snd_soc_sst_bytcr_rt5640.quirk=0x563423

Note this time the second to last number has changed from 3 to 2. So if you did not need to change the microphone settings, but the jack detect is not working with the defaults, then this becomes:

snd_soc_sst_bytcr_rt5640.quirk=0x563422

Please let me know if the updated alsa-lib fixes things and what the rights quirks are for your device. When you know the right quirks please also run the following command as a user, not as root :

grep . /sys/class/dmi/id/* 2>/dev/null

And copy and paste the output here, this will allow me to add the correct quirks to the quirk table in the kernel so that future kernel versions will do the right thing automatically.

Now we need to migrate this from fedora to ubuntu lets do it. The directions will likely be quite different so I may have missed it butWhich version of ubuntu are you running. That is where we will start

better yet run sudo apt install neofetch … install it… run it… paste it here… Should be similar to :

HEIMDALL&                               (       
      (((               (               (((     
     ((               ((((#               ((      [email protected] 
   (((     (((       (((((((       (((     (((    ----------------------------- 
  (((    (((            (            ((     (((   OS: Ubuntu 18.04.2 LTS x86_64 
  ((    (((     ((      (      ((     ((&    ((   Host: GL502VT 1.0 
 ((     ((     ((   ((( ((((((  ((     ((     (   Kernel: 4.18.0-17-generic 
 ((    ((     ((   (  ((      (( ((    (((    (   Uptime: 1 min 
 ((    ((    (((   (( ((      (( (((    ((    (   Packages: 2565 
(((    ((    (((     ( ((     (  (((    ((    (   Shell: bash 4.4.19 
 ((    ((     ((     (((((((((   ((     ((    (   Resolution: 1920x1080 
 ((    #((    (((    (     (    (((    ((     (   DE: GNOME 3.28.3 
 (((    (((    (((  (((( ((((  ((     (((    ((   WM: GNOME Shell 
  (((    (((        (  ((( #(        (((    (((   WM Theme: Adwaita 
   (((    (((       (((   (((      (((     (((    Theme: Telinkrin-Gradient-rig 
    (((     (      (((     (((      (     (((     Icons: Suru++ [GTK2/3] 
      (((          (  (( ((  (          (((       Terminal: guake 
       ((         ((  (((((  (          ((        CPU: Intel i7-6700HQ (8) @ 3. 
                  ((((     ((((                   GPU: Intel Integrated Graphic 
                  ((         ((                   GPU: NVIDIA GeForce GTX 970M 
                 (( ((&   ((( ((                  Memory: 1254MiB / 15904MiB 
                 ((    (((    ((                
                 (   ((( ((    (                                          
                (( ((       (( ((               
                (((           (((

Im working on finding the ubuntu UCM port for alsa lib right now. Essentially we just need to do that. I am assuming no linux experience or some?

EDIT: Seems I miscalculated your linux experience. Okay Lubuntu 18.10 Ill have to look if the version of alsa in there is working out of box and is just a matter of conf or not

1 Like

Sorry for the delay had to switch computers to make it easier to dump text

[email protected]:~$ neofetch
            .-/+oossssoo+/-.               [email protected] 
        `:+ssssssssssssssssss+:`           ----------                        
      -+ssssssssssssssssssyyssss+-         OS: Ubuntu 18.10 x86_64           
    .ossssssssssssssssssdMMMNysssso.       Host: HP Pavilion x2 Detachable P 
   /ssssssssssshdmmNNmmyNMMMMhssssss/      Kernel: 4.18.0-10-generic         
  +ssssssssshmydMMMMMMMNddddyssssssss+     Uptime: 56 mins                   
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/    Packages: 1906 (dpkg)             
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Shell: bash 4.4.19                
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Resolution: 1280x800              
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   DE: LXQt                          
ossyNMMMNyMMhsssssssssssssshmmmhssssssso   WM: Openbox                       
+sssshhhyNMMNyssssssssssssyNMMMysssssss+   Theme: Arc-Darker [GTK3]          
.ssssssssdMMMNhsssssssssshNMMMdssssssss.   Icons: Adwaita [GTK3]             
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/    Terminal: qterminal               
  +sssssssssdmydMMMMMMMMddddyssssssss+     Terminal Font: Ubuntu Mono 14     
   /ssssssssssshdmNNNNmyNMMMMhssssss/      CPU: Intel Atom Z3736F (4) @ 2.16 
    .ossssssssssssssssssdMMMNysssso.       GPU: Intel Atom Processor Z36xxx/ 
      -+sssssssssssssssssyyyssss+-         Memory: 874MiB / 1922MiB          
        `:+ssssssssssssssssss+:`                                             
            .-/+oossssoo+/-.                                            
               
a

Neat stuff!

LOL cool okay… now you mentioned having the correct ucm installed

so maybe we are past the fedora specific directions. read through those and see if you can make the same modifications on ubuntu… I think this issue is fixed in 19.04 I could be wrong

Wil do, thanks I will read through it and update everyone on what happens.