Return to Level1Techs.com

Looking Glass - Triage

helpdesk
lookingglass

#1

Looking Glass med bay.


:arrow_right: Origional Thread :arrow_left:

:arrow_right:Changelog Thread :arrow_left:


Looking Glass - Changelog
Looking Glass - Guides, Help and Support
Looking glass quickstart guide instructions do not work
Looking Glass Setup Guide
#3

still giving me

cannot open shm file ivshmem: Permission denied
cannot bind

is the /tmp/ directory fine if I leave the code as it is presented in the guide? Or should I point it to somewhere in my home directory?


Looking Glass - Guides, Help and Support
#4

What’s giving you the error? You’re going to need to be a bit more specific.


#5

unless your user has access to /tmp point it to a folder in your home directory. Worked for me.


#6

That’s one option. Another option is changing groups around. You could also run ivhsmem-server as qemu and add yourself to the qemu group. (if not already in there)


#7

Hows this for a bug? or am i just doing something wrong?


#8

Distro?

Haven’t experienced that before.


#9

Looks like the stride is out… what is the guest GPU?


#10

Guest GPU is a EVGA GTX1080 FTW. Host is Fedora Rawhide kernel, 4.14.3


#11

Can you try to change the guest’s resolution?

Also don’t run Looking Glass as root, add yourself to the qemu group so it can access the ivshmem server without the extra access.


#12

Will take another crack at it tomorrow. Don’t think I got the permissions quite right on the ivshmem socket so it’s not able to connect without sudo for the moment.


#13

No worries. The problem with the output is clearly a bug though, it’s not due to your setup.


#14

Running this right now, works amazingly well! I get sub-60 frames with the client full-screened while playing games , but I suspect it’s due to using igpu on the host…

Can I suggest adding a flag to ignore all input on the client? There’s some funky behavior when trying to switch between windowed and fullscreen in i3 (it doesn’t work half the time). I got around this by commenting out all the keyboard/mouse events. It’d also be useful for those that have their special keyboard/mouse setups between guest and host.

Host: Arch Linux w/ intel gpu (intel HD 530)
Guest: Windows 10 w/ 980ti


#15

How sub? and is it constant or dips?
Also try turning off mipmapping with the -m switch.

Just turn off the spice client in Looking Glass looking-glass-client -s


#16

I’m having the same issue currently.


#17

Can you please try with another resolution, seems to be related, the last report was running the same.
Edit: I think I know what it is, just want to confirm before I hack on it.


#18

EDIT: Yes at 1920x1080 it works as expected. Not at 3440x1440. Also resizing the window doesn’t work.


#19

Sorry I should have provided more info.

The fps on the client appears to be constantly lower - here’s a SS from just sitting idle in Overwatch: https://i.imgur.com/Kp6CRAq.png
A little hard to tell but the client is constantly at ~40-50fps while the game itself is much higher. Perhaps my processor is getting taxed from the CPU usage of these games; I don’t see the fps dips when running GPU benchmarks eg Heaven.

Also for the -s switch, it appears to turn off all events including window events, so things like resizing doesn’t actually re-adjust the render resolution?

Edit: mipmapping does not seem to make a difference either. Might be time to finally get a dgpu for the host…


#20

Excellent, thanks for confirming that. Resizing seems is a problem with having spice disabled, I will fix that soon.

This is to be expected, the FPS is not the screen FPS, but the rate at which we are getting frames from the guest. If nothing has changed/updated then frames are ignored and not sent to the host.

Yup, confirmed, I will fix this.

Don’t do that… your IGP is plenty fast enough, just a few rough edges in Looking Glass.


#21

This is to be expected, the FPS is not the screen FPS, but the rate at which we are getting frames from the guest. If nothing has changed/updated then frames are ignored and not sent to the host.

Pardon my lack of knowledge on the tech, but would it be possible to force all frames to be sent regardless of changes? I wonder if that could ‘smooth’ things out.