Location icon in Android is always on

Hello everyone! This is kinda awkward but I need some help: a week ago the location icon on my in the status bar on my Android phone lit up and there’s no way to make it disappear, unless you straight up disable all the location services on the phone. There’s no report of rogue apps using location data and I’ve been monitoring though PiHole (too lazy to setup Wireshark really) all the traffic going through my phone but there’s nothing weird there.
Digging in the web I’ve seen this reported even on the official Google’s Android forum. Some absolute knob who’s in charge of it decided to tell users to disable location services.

What I know is that the most affected people are people using chinese manufactured phones (Motorola especially, Honor, OnePlus/Oppo) running Android 12 and located in the EU. I might be wrong but this is all I got in the past days.

So I’d like your help for a couple things:

  1. if you’re affected or know people affected please let me know, I’m really curious to know how deep this rabbit hole goes. Also would be useful data for the second point.
  2. if @wendell could hook me up with someone at Google that will look into this I’d be extremely happy because looks like no forum or any kind of help to troubleshoot this problem has been given so far. I’d be the guinea pig if they need logs or details.

Thank you for your help!

Are you using a recent phone with active service updates? Cheaper phones only usually have 1-2 years of software support if you are lucky. Samsung has 3 usually. Newer Pixels have 5 years.

IIRC most phones are made in China, with likely only Samsung and Sony having their own fab capacity done within their own mainland, It is not where it is sourced, its more of the unpatched zero days and n-days in its firmware and software. Keep them updated!

The fine folks at the Google Threat Analysis Group and Citizen Lab could be interested in your phone:

  • [email protected]
  • I cant find Google TAG’s contact details. Maybe just through their regular support?
1 Like

Yes, I’m using a Motorola Edge+ 2022 on Android 12 with Sept. security patches.
Weirdly enough older phones are not affected (running < Android 12).

Yes, I’ve been inaccurate. What I meant to say is phones running some Android version that came from china.

I’m as updated ad Motorola allows me to be.

I will, thank you so much for the contact. What I think is the culprit is Google itself, but I can’t be sure.

There’s no support for the Android OS. Just the forum, which is handled by underpaid and not knowledgeable people, as far as I can see.

1 Like

Have you tried to find out which application is using your location? For example, on Samsung you’ll find that under Settings > Location and it will display a list of apps that recently accessed the service and when.

Have you installed any new or updated any apps recently that require location access?

2 Likes

Yes, totally! That’s the first thing I did but there’s nothing either under the privacy settings and under location settings.

About the updates I can’t really track down if it happened after a specific app update. I tried uninstalling some apps and removing access to location from every app on my phone. Nothing changed.
This is why I’m inclined to think it’s an issue with Google.

One thing comes to mind is trying to reset both “Google Play services” and “Carrier Services” apps – they might be hidden by default. Clear the data/cache and force stop for both. This should effectively reset any issues with Google. Don’t worry, the most this will do is reset the Play store and RCS which will re-register anyway if you use it.

Good suggestion. I tried but it didn’t work beside having the effect you mentioned (reset some Google settings and RCS).
Looks like it’s a deeper issue and I’d need the tools of a security firm or to root the device and dig pretty deep into it.

Worst case scenario, you can fake gps locations if they are actually spying. You can also try using the adb shell to check if gps is on.

Of course the firewall is on and you control network traffic per app… :wink: Alternatively, you can run a malwarebytes scan to make sure nothing got inside.

Did a scan with Malwarebytes and Bitdefender but nothing showed up. It’s not sneaky if it shows up, I’m pretty sure nobody is spying on me.
I don’t have firewalls on my phone.

Hmm, just a bug then? :wink:

If you are pretty sure that nothing in the background is using GPS then ok. It would be good to do a factory reset and watch when the situation occurs again. :wink:
The issue even to report the bug will be whether the gps is actually turned on or just the icon is selected.

As for the firewall, it’s imho bad that it’s not used on such devices. This allows you to really control traffic per application and capture strange phenomena. :wink:

By the way, I also doubt that @wendell gave anyone any of his private concats in google, if he has any. :wink:

I don’t know, I can’t tell if it’s just a graphical bug or not. It just appeared out of nowhere one day and it’s not going away.

Yes, as sure as I can be with the tools I have.

I would really REALLY like not to reset it because it’s an hassle to get everything back together.
I tried booting it into safe mode, but didn’t change a thing. So I guess it’s something deeper that a reset won’t fix anyway.

Yup, I really need one. Any suggestions?

Well that’s fair, I didn’t think about it. What I would’ve liked really is to escalate this thing because I’m seeing more and more reports of people having this issue in different degrees of worse (I got away the better, some people can’t get it to turn off even for an hour, some are reporting battery drain) and there seems to be nobody that really wants to help.
First world problems, I know. But I’m also determined enough to get to the bottom of it and solve this thing once and for all.

Other people also have a similar problem and suggest that it started some time ago with an update.

Hmm, a factory reset would explain a lot, but I understand the inconvenience of this. :wink:
Do you have another device with the same android version?

The only thing left for you at the moment is to play with adb shell and the method enable disable functions and maybe something will happen.
But if it’s actually a bug that was introduced by an update, then there’s probably nothing you can do yourself to fix it, wait for future patches that may or may not fix it.

I do not know exactly what “it something deeper” would mean… If the partition with the image is not violated, the reset will always restore the factory state, regardless of what mess has become on the device, especially when it comes to no root. :wink:

I used to use…
https://play.google.com/store/apps/details?id=app.greyshirts.firewall

But now I move all devices to…
https://f-droid.org/en/packages/eu.faircode.netguard/
https://github.com/M66B/NetGuard/

On 4.4 I still use NRF but it’s hardware only for LAN work. I have other newer versions on NG.

The only drawback with NG is a paid option if we want to be able to create rules. The free version only allows you to completely allow or block the application. But the 5 euro for the pro versions for all devices I have, I think is ok. :wink:

NG also has udp controls, which not every fw on android has. The f-droid version also has the option of blocking dns addresses from the HOST file, which is handy when we do not have a pihole or similar.

Of course typical bs for android if you use vpn then you can forget about firewall. Because each fw uses the vpn function in android to intercept traffic.

Android bugs… not the first and won’t be the last, arm yourself with patience and the ability to ignore some things. :slight_smile:

Indeed. Had to take a break from digging into this issue because I needed to relax and this is just excessive noise.

I’d have a little window in which to make sure the factory reset had effect, if it has anything to do with Google apps.

Unfortunately not. I go through one phone at the time every four years or so nothing in my inventory is running Android 12.

Yeah, that seems like the logical and scientific approach to take.

It’s surely a Google app problem, since it’s hitting lots of users. Seen some evidence in the Asus forums aswell. Their support is pointing the finger at the Google Play Services.

I meant what I said just before this. I just can’t english sometimes (yes, said it that way on purpose lol).

Intriguing and love that it has a Github page to take a look at.

I think it’s fair to pay people for their work. Also I’ve spent money less wisely for sure in my life, another 5 won’t do me any harm.

Oh yeah, I used to use something like that and it’s either or since firewalls rely on the VPN function. Not bad though, I don’t use a VPN and won’t use one at all times since it would kill my battery.

There was a time with Android 4.4 in which Android was so nice, very few bugs, ran fast on low resources. After that seems like it’s getting worse and worse when it comes to buggyness. I’m ignoring it right now and that’s maybe what I should’ve done from the start.

You can try killing processes from google and it might change something.

Personally, I have turned off everything from google. I only run two processes once in a while to check for updates in the playstore. Every other process that can be turned off without root I have turned off, although there are some that can not be turned off so easily. :wink:

Oh yeah, that was the first thing I did. I have developer options off so I can see all the processes running. No shot, didn’t make a difference whatsoever.
It’s a pretty big fuck up if you ask me. I hope Google is gonna fix it soon!

Well, there were and will be bugs, and it’s good enough that it’s just an annoying bug, not something that makes it impossible to use the device. :wink:

I am more annoyed by the short time of support for Android. I have a lot of devices with 7, 8, 11… for 4 I can understand that it is dead but 7 and 8, you can still buy new devices that have 7-8 and from day one they are full of holes and no hope of updating.

At least with an old pc/laptop I can decide what I want on board. A smartphone / tablet in many cases is a closed box without the possibility of using anything else / newer, even if you are willing to sacrifice some % of performance. :wink:

Found the bug! Something is messing with the auto night light setting in Android 12. Disabling auto night light the icon went away immediately without coming back.
It’s not a user breaking experience, but still super annoying and worrying when you can’t find what’s using your location!

They left everything into the SoC and manufacturers hands. And they want to make money so they’re gonna screw the end users.

Totally agree! That’s why I got my CC card ready to swipe as soon as a more powerful and usable Linux phone comes around.

2 Likes

If you want, I can give you one activation code for NG.

This is not a problem and I already have to pay for my devices so it does not make a difference to me one more.

All you have to do is install NG from git and then after starting, go to options (three dots on the right side up) click on “Pro features” and then “challenge” and then give me the code that is there.

I need this code to generate an activation code that I will give you on priv.
This code can be used once with this particular device.

PS
It’s not piracy, it’s just my codes that I paid for.

2 Likes

Thank you so much for this solution. I’m using a Moto G(100) with Android 12. That icon was driving me nuts! I was following the same thread on the Google forums but they recently closed it. It seems you can still have the Night Light feature turn on at a custom time, but when you choose “Turns on from sunset to sunrise” under the “Schedule” option it causes the issue. I’m curious how you figured it out. Thanks again.

2 Likes

No worries, I appreciate the kind gesture.

Never thought you were pirating for one second! But I guess it was necessary to make it clear anyway.

1 Like