Return to Level1Techs.com

Linux Novice Struggling with Ubuntu Install (NVMe drive/partition not detected)

The past day or so I’ve decided to be an adult and finally move more of my workflow onto linux (for real this time). I’m trying to set up a Win10/Ubuntu dual boot. However, unlike previous attempts I’m blocked right out the gates. Here’s my process so far (I’ll likely be including a lot of irrelevant information since I truly have no idea what’s the problem):

I’ve created a new partition on Windows 10, splitting my SSD into two equally sized partitions (drive letterings are C (Win 10 boot), D (HDD), E (SSD partition 2 to be used by Ubuntu). It’s formatted as an NTFS file system and recognized/usable in Windows. Create a bootable USB drive using UNetbootin with the 18.04 iso. Boot up into the UEFI, switch to boot up from USB, restart the machine. This is the point where I face some difficulties and seek help.

After selecting ‘Install Ubuntu’ I get stuck on this screen for a little while: https://imgur.com/rYkLaJN

Followed by: https://imgur.com/HLpb2e0

The installation then starts as if nothing happened, but neither partition of the NVMe drive is detected: https://imgur.com/ja9YVD6

Next, I tried using another USB creation tool (Universal USB Installer). Different GRUB: https://imgur.com/R89C5Kw. Similar problems: https://imgur.com/dken3rB, https://imgur.com/bErr3ez. Although with this tool it doesn’t even pretend to go into the installation process.

Other things I’ve tried so far:

  • Check to see whether AHCI mode is enabled (it was).
  • Enable/disable secure boot.
  • Unplug my HDD so that the NVMe drive and the USB are the only drives available to the machine.
  • Disabling fast startup in Windows
  • Disabling/Enabling virtualization in the BIOS.

My system specs:

AMD R5 2600

ASRock B450 mini-ITX mobo

ADATA SX6000 512GB NVMe drive

WD 4TB HDD

Thank you kindly, and I truly appreciate any help on this one! (I’d say I’m definitely below average knowledge when it comes to linux, so please bear with my ignorance)

From what I’m seeing on your screen, you only have 1 partition (other than the 16 MB boot partition).

SDB is your device (full drive)
SDB1 is your boot partition
SDB2 is your full NTFS partition

You should have another unused portion of the disk if you indeed had another partition (it would show as SDB3 or if no formatting as freespace).

You do have the ability to resize your NTFS partition using gparted in ubuntu, but there is always a small risk of data loss. If you have a spare SSD, I’d suggest installing to a fresh drive rather than doing this, but if not, you can google how to do this step.

2 Likes

You can and probably should use another drive for Linux.

Did you disable fast boot in Windows?

1 Like

He does mention following the normal steps such as disabling fast boot.

I agree with you on just using a fresh drive, it would be much safer in this case.

2 Likes

My bad I skimmed because mobile.

Thanks for the response!

I attempted to install 19.04 onto my USB-C connected external SSD. I went into the BIOS and selected to boot from USB to install Ubuntu (as opposed to boot from UEFI to install). This time the installer was able to successfully detect my NVMe drive and partitions. Instead of trying to install to the external device I installed to the desired NVMe partition. Installation process was fine, but upon rebooting and switching to boot from the NVMe drive I was stuck on an eternal purple screen after the grub menu. Forcing a restart and trying again gave these messages: https://imgur.com/vkxyIGt. Rebooting a third time reaches the log-in screen, but every time I enter my password I reach the desktop and then immediately am shot back to the log-in screen.

After repeating this for a while the pattern seems to be:

  • If the installation USB stick is left plugged in alternate between being frozen on a purple screen and the log-in screen (shooting back to the log-in screen after reaching the desktop).
  • If the USB stick is not plugged in, display https://imgur.com/vkxyIGt (without the two ‘sda 9:0:0:0: [sda] …’ lines).
  • If the USB stick is plugged in after having not been, display https://imgur.com/vkxyIGt, then alternate according to the first bullet point above.
  • If the USB stick is plugged into a different USB port, display https://imgur.com/vkxyIGt.

Other notes:

In both cases the NVMe drive is no longer detected.

There are some weird things here you are describing.
First, I’d make sure the BIOS is absolutely up to date on the board.
Second, if you’re using an nvidia card, make sure you’re using the nomodeset option.

Here is one site that goes over that:

basically you just add to the line that says “quiet splash” and just replace it with “quiet splash nomodeset”

This should at least fix the purple screen thing and the loop problem.
As far as your drives that may be a motherboard thing which is why you might want to udpate the bios, if that’s not it, there’s probably a boot setting getting screwy.

I have indeed updated the bios to the latest settings, and I am using an nvidia card (2080). Looking at the linked post, how can I access & modify /etc/default/grub without being able to log in?

Thanks again!

You can edit your grub lines at boot up.
there are a few different ways depending on the version you’re running, here is a good link that goes over some of the ways:

do an online search for editing grub at bootup using ubuntu to get details

Regarding the bios updating, I’m running the latest version as found on the asrock support page https://www.asrock.com/MB/AMD/Fatal1ty%20B450%20Gaming-ITXac/index.asp#BIOS.

Adding the boot parameter nomodset (following https://askubuntu.com/questions/38780/how-do-i-set-nomodeset-after-ive-already-installed-ubuntu) doesn’t appear to help. I still reach https://imgur.com/vkxyIGt on the existing install and https://imgur.com/GhA5Zak (without the modsign message) if I try to reinstall ubuntu.

okay the UUID error indicates the drives name is getting changed during install somehow. That is very odd. I have been able to work around this before by forcing the drive name, but I don’t want you getting that into the weeds (shouldn’t be necessary normally).

I’ve seen this sort of behavior on an old laptop that had a really old UEFI mode. I’d have to turn off UEFI to get it to install and it would break the UUID when it tried to boot back up. I eventually figured out to change the download media to nonUEFI and disable UEFI in the BIOS and then I was able to get this to work.

I’m wondering if perhaps your ubunut version has UEFI installer by default and your PC UEFI is crapping out. You could disable UEFI but not sure if that’s going to mess up your windows install.

It is probably best at this point to try a different drive as it’s possible to break your windows install as you mess with this more.

Should I be booting from the USB installer or the UEFI installer? I think I’ve tried both, but it would be good to know if there’s a more correct way.

On one of my many reboots and reinstall attempts I managed to get to the installer without any error messages or warnings. The NVMe drive was correctly detected but the installation process eventually stopped with the following messages https://imgur.com/dgDeQeb. Note that Win10 is on partition 1, nothing else appears with labels partition 2-4, partition 5 was the EFI and partition 6 was the target destination for the Ubuntu install. This partition structure remains even if I erase/format everything [except Win10], after partition 1 the next available is labelled as 5.

As an aside, if I can get Ubuntu to work I don’t mind so much doing a complete wipe of the Windows partition. In fact, it might be best if linux is the only OS that touches the metal with all other OS’s operating through VMs

EDIT: It looks like I’ve already messed with enough stuff to break my Win10 install. I’m not so attached to it since I only built the machine recently, but this might be a good opportunity.

Thanks so much again!

If you’re going to wipe the drive, then just do that and delete all the partitions so ubuntu can set it up properly with the defaults. There shouldn’t be 6 different partitions so I think something is getting really whacky here.

If you still need data off the drive that can probably be recovered if you install on a different disk and then plug this one in once the install is completed. You can probably read the messed up partitions and possibly even rebuild the boot sector on that drive to get back into windows.

The thing I think that is screwing things up is having NTFS partitions but I can’t say for sure since I’m not there to inspect them all.

Installation was fine and the drive was detected. Reformatted the drive and merged all partitions into a single one. Upon reboot I was first stuck on a purple screen. Rebooting and setting nomodset I am now getting similar nvme IO_PAGE_FAULT errors as earlier https://imgur.com/0yY03Qt.

are you using all the defaults? is it EXT4 partition? Do you have any oddball settings on the NVME?

edit:

https://ubuntuforums.org/showthread.php?t=2380700

this thread outlines your problem, it appears to be an issue with UEFI. This person solved it with the following steps in the bios:

Security -> Secure Boot -> Secure Boot Mode -> [Standard]

He also mentions he had secure boot disabled in the bios in another spot as well

I just reset the uefi to defaults, made sure secure boot was disabled and secure boot mode was standard.

I think at this point I’ll just go out to my local computer shop, and buy a 256gb sata ssd and see if even that works.

I truly appreciate your help.

sounds good, please post here so we can know if it works!

Reporting back:

I got a 250gb Samsung 860 EVO. I unplugged/disconnected every other drive (NVMe/HDD) and installation seems to work great. However, now at the log in screen (which I can consistently reach now, so that’s something!) I’m being immediately shot back to the log in screen after reaching the desktop for a few seconds.

It’s also worth noting that the log-in screen is extremely sluggish, so my guess would be for me to install nvidia drivers. That said, I’m not sure how to do so if I can’t reach the desktop.

Additionally, I go straight to the log-in screen without seeing a grub so I’m not sure where I could add the ‘nomodset’ parameter.

EDIT: Figured out how to get a command line (ctrl alt f3) and installed the nvidia drivers according to http://ubuntuhandbook.org/index.php/2019/03/install-nvidia-418-43-g-sync-support-ubuntu-18-04/. Installing the latest drivers appears to have worked!

One thing to note is that during installation I was ‘spammed’ with what felt like hundreds of ‘PKCS#7 signature not signed with a trusted key’ messages at the end of the driver installation process. I forced a reboot, but everything seems to be working smoothly! (finally!)

Now to see if this can remain stable when I put back the nvme drive…

1 Like

First boot: Stuck on purple screen for around 90s, then reach the log-in (everything working fine).

Second boot: Sent to grub (this hadn’t happened when the 860 evo was the only drive), then an nvme error message https://imgur.com/SGRfSnR then after about 90s sent to the log-in screen (everything works normally when logged in).

Third boot: See first boot.

Fourth boot: See second boot.

I assume the pattern continues in this way. I then formatted/reinstalled Windows on the NVMe just in case some old structure was getting in the way. After installing Windows successfully and rebooting into the Ubuntu drive (860 evo) I still see the above problem.

This is quite frustrating but at least its usable in a sense.

Nope scrape my comment you said everything works great in the previous post.

Is your NVME still with both Windows and Ubuntu ? maybe it boots in the old boot partition you made.

At boot up spam F8 ( usually this will open a menu to select a Storage device to boot from ) or Del or F2 ( the binds in most cases for your UEFI menu ) where you can choose to boot from the second ssd.