Lenovo Yoga Book 9i Linux experience

Hey, y’all!

I’m determined to buy the new Lenovo Yoga Book 9i dual touch-screen laptop. But I have some concerns with Linux compatibility.

My motivation:
I need Linux for work and the WSL is not the experience I’m looking for. I use Arch at my workstation and Fedora on my Laptop. I like the Book 9i because of its screens and am planning to heavily use the pen input for work.

My Question:
So, how about that thing called Linux on double touch-screen “laptops” with pen support?
Does anyone have experiences to share?
Or problems I will most likely encounter?

I greatly appreciate any input and discourse!
(I don’t have the device yet, it will be on sale in my region shortly.)


The rarer the laptop, the worse it is for software support especially for Linux, unless you can gift one each to your favorite Kernel dev, Mesa/Noveau dev, DE dev, and so on.

There is a reason single display laptops like Thinkpads are so good on Linux: everyone has them. The farther you deviate from this, the worse it gets.


Let me share my thoughts.

I tried to do my homework and check what exact chips and hardware are inside the Book 9i. If the individual parts have support, their combination will have to, right?

I found these pages from Lenovo with lots of details:


The Book 9i is on intel 13th Gen mobile (with Iris Xe). I don’t expect problems with the core hardware. (Should I?)

The Wifi and Bluetooth chip is the Intel AX211 (source: Double trouble: Lenovo Yoga Book 9i 2-in-1 Dual Screen OLED convertible review - NotebookCheck.net Reviews). This chip has Linux driver support with iwlwifi on recent kernels.

The screens are Samsung-ATNA33AA02 (source Double trouble: Lenovo Yoga Book 9i 2-in-1 Dual Screen OLED convertible review - NotebookCheck.net Reviews).
These seem to also be used for the ThinkPad Z13 G1 and ThinkPad X1 Carbon G10 which both have entries in arch wiki and seem functional (the Z13 even with working touchscreen).

Very important for me is Linux support for the included Lenovo pen. It is the new version of the Lenovo Digital Pen 3.
I’m thankful for input here. Any experience with the predecessor Lenovo Digital Pen 2? Browsing the Lenovo listings in the archlinux wiki shows pen support for laptops with the Pen 2.

One problem probably will be the special included Bluetooth keyboard.
But I can use a different one with good Linux support (any recommendations?) or move to a wired KB if in dire need.

Then there are USB-C docks. I want to choose this one:

I found this guy’s video: Lenovo USB-C Mini Dock unboxing and Linux experience - YouTube
seems to work on Linux Mint for him.


Its a really cool and fancy laptop. I mean you can try and it is Lenovo so there is some sort of support.

The issue that I am afraid for you is power/sleep states breaking the multimonitor when it idles out/sleeps. You may resume with bad DPI scaling or one screen not working or both. You may need to turn off screen dimming and standby which will hurt your battery in the long run.

Next issue is the bluetooth keyboard, that may be another potential problem/annoyance. If you can live with a USB keyboard attached, it should fix the issue in another way.

Worst case is you run linux in WSL or in a VM in windows. Depending on your actual work I do not know if that is acceptable to you.

If you end up getting one of these, I’m very interested in how well it works.

Back in 2019 I looked at both the Yoga 920 and the XPS 13(?) 2-in-1s, and discovered that neither had good pen stability on linux.
So I ended up waiting until Black Friday and purchasing a Surface Pro 6 instead.

As far as dual screen laptops go, I have no idea. However, I’ve had mixed results with my surface.

The good thing is that power consumption and performance seems to be equal to windows - especially with the surface-linux kernel & packages.
Also, the pen seems to work as well as, if not better than on windows.
And the display doesn’t dim when rendering a dark background (yes, this is a real “feature” on Intel iGPUs).

The bad is that it took about 3 years for the Intel precision touch driver to not randomly crash, or detect phantom touches on the screen.
In addition to that, I still have issues with WiFi taking up to a minute to connect after resume, and the device failing to hibernate, followed by trying to cook itself.

I imagine that the Yoga Book 9i should mostly “work”, but may have certain quirks depending on how Lenevo has configured their firmware.

I agree with @regulareel that you’ll probably have to just try it out and see if it’s good enough for your usecase. :roll_eyes:

1 Like

Is this common for laptops? I never had issues on my 3 monitor workstation with suspend-resume and the screens. Also my old Laptop on Fedora never had issues with sleep.
Or is this a new problem that comes with the new power states of recent platforms?

Hmm. So I shouldn’t get my hopes up that other (than the included) Bluetooth KB work on Linux?

I’m not sure what is worse, dealing with crappy Windows 11 or with unstable Linux… :sweat_smile:

Power management is a whole other can of worms.

But it’s good to know, that the surface line has decent Linux support. How about the Surface Folio (Keyboard thing)?

If you mean the Surface Typecover, mine is fully functional since it’s just a simple USB device, but some people had problems on the newer version with its integrated fingerprint reader.

The typecover is a pretty good keyboard for typing, but poorly layed out for coding. The trackpad is smaller than on other laptops, but still feels nice and is easy to use.

If you’re curious about compatibility for the Surface line of products, the surface-linux github wiki has a nice chart:

P.S. The easel mechanism is absolutely fantastic on the surface pro for writing and illustration, but the lack of a deadicated GPU significantly hinders graphical performance.

Today I had the opportunity to get hands-on with the device in a local store. It was locked down in software and had no keyboard or pen demo available, but still, I have some thoughts to add.

Let’s assume that the basic Linux driver support is there, the screens are detected and fully functional (incl. touch). There is still a lot of custom usability software necessary. Let me explain:

The different screen configurations only require standard settings such as rotating the displays, disabling either one and moving and resizing windows. All of which are common tasks of GNOME (I use GNOME, so I’ll refer only to one DE). However, lots of things have to be done at once. For example, changing from landscape to portrait mode, two displays have to be rotated, correctly aligned for the window manager and the application windows adjusted.
This should be working with GNOME, as it is a common situation for single-screen tablets, right?
If not, I imagine GNOME extensions taking over that switch to saved configurations once the accelerometer is triggered by screen rotation.

More difficult is window resizing across both screens. Say in portrait mode I have a PDF reader open and want to stretch it across both screens so that I can have one page on each screen. Instead of dragging the window to fit each time, it would be nice to have some auto-snapping or keyboard shortcuts (provided by an extension).

These and similar software solutions are supposed to be provided by Lenovo for Windows OS. But from my hands-on experience and from what I’ve read online, these need more time to mature.

As I have zero experience with touchscreen devices/tablets under Linux I have to ask:
Do you guys think that there will be major problems?
What software (extensions) come in handy for these situations?
How is GNOME on tablets (keeping the Yoga Book’s 2 screens in mind)?

I’m willing to invest time into solving these coding challenges, like coming up with some GNOME extensions and systemd / udev configurations. But I won’t be able to make it on my own, as my experience with this type of programming is limited. Here I count on getting support from the community.

I have one. I was planning to play around with Linux once I figured out how to non-destructively open it.

I’ll try a live USB later, but I also have the ThinkBook Gen 3 Plus, and that thing was pure pain with both screens thanks to their implementation of DSI. It works now display and touch wise, but still disabled one of the screen when you shut the lid. If that happens with the Yoga Book, it would drive me mad.

Awesome! I’m very much looking forward to your report!

Check out the links I posted previously, there is a full disassembly guide.

I don’t think you can open it non-destructively. Some adhesive needs to be replaced.

Well that looks less than fun lol. Guess I’ll start out w/ a 64GB partition and if I get it working well, just shrink the 11 partition later.

How is it going?

I was also wondering, how one boots from USB A - drives. Is it just plug and play from a Thunderbolt dock, or does one need a USB C (Thunderbolt) to USB A adapter?

No luck yet. Haven’t been able to boot off of anything (stalled blinking cursor). I tried the same flags that got me booting with my ThinkBook Plus Gen 3.

I have a Type-C flash drive, but I have used a C to A dongle with success on it as well.

That’s a shame. Maybe some UEFI settings are in the way. Unfortunately, the documentation for the UEFI is useless:

I too bit the bullet and am now an owner of a YogaBook9i. I just couldn’t resist any longer.

So let’s get this thread moving again.

I can reproduce:
After switching off secure boot and booting from a USB drive on a C to A adapter I’m met with a stalled cursor as well.
So far I tried Fedora 38 and Pop!_OS 22.04 without any flags.

Have you tried any USB docks and wired mice yet? I’m planning to buy one of these, and want top figure out if the compromises will be worth the features when using Linux…

I’ve used this one for a few years with all of my 2-in-1s. Works great with the 9i for power and data.

I bought the Lenovo USB C mini Dock
lenovo store page

It works great on windows, with the bonus of an additional charger in the box. It was discounted a lot as a bundle with the YogaBook 9i. It should also work in Linux, see reply in this thread of a random youtube video testing the dock on Mint.

Today I updated the UEFI to the latest Version KXCN32WW (Download).

Then I tried some Linux distros again.

First Archlinux with the latest 202308 Archiso. And lo and behold … I booted straight up into the arch zsh. I checked the journal and during boot there were a lot of ACPI Errors and some wifi and bluetooth errors. But it worked. Only when powering off, it got stuck at a semi-dead state.
(Also the top screen is actually flipped 180 degrees… )

Then I tried Fedora again. It did not work. Same stuck cursor.
So I tried setting the systemd target to multi-user, because the archiso is command line only and I thought that could be worth a try. And also removed the quiet command line option.
This time I got output on the screen and landed on a login promt.

@Den-Fi when you were trying Linux USBs, were you booting ISOs directly or did you format a usb drive with the contents of the ISO?
I booted arch from a formatted USB drive and then I have a Ventoy usb drive with a bunch of ISOs to play around with.