I no longer agree with microsofts EULA and want to use linux mint

I have been using linux off and on over the years and seen the new EULA microsoft makes us agree to while using the windows OS. I don’t like the language or some of the terms in the agreement. I just started on my laptop to switch to linux. My desktop will follow suit as soon as I make things work on linux. I mainly watch youtube videos and play games like Diablo 3.
The issue that I have is while watching youtube videos there is this tearing or artifacting going on. I don’t know the first thing on how to smooth that out.
Another issue I have is while adding repositories I get this error. This PPA does not support bionic’ '.
I know there are workarounds out there to sorta “fix” these problems. I think maybe here I could maybe buddy-up with somebody or bodies… hope maybe my transition would be complete. Thank you in advance for understanding my problems/issues.


You actually read the damn thing? Congrats, that’s probably more effort than I would have put into it.

To answer your questions:
“The issue that I have is while watching youtube videos there is this tearing or artifacting going on. I don’t know the first thing on how to smooth that out.”

To fix this you need to make sure that the accelerated desktop is enabled (either compiz or compton) and ensure you have the most up to date drivers for your GPU installed.

Edit: How we solve this issue will depend on what type of GPU your computer has, so please let me know.

As far as your second question goes, what PPA are you trying to add? Mind linking me to it?

Welcome to The Borg, I mean Linux.


Tearing is a rough problem to solve but to get started, which version of mint, what DE are you running, and whats your graphics hardware?

If you are going to add repositories make sure they support ubuntu 18.04 as thats what mint 19 is based on. bionic refers to bionic beaver which is ubuntu 18.04.


I’ve experienced tearing on both Debain 9 and Ubuntu 16.04. I have Nvidia cards installed, on debian I had to blacklist the software driver nouveau and install proprietary driver, on ubuntu I had to install proprietary drivers and it worked. Never tried Mint, but on my current installation, Xubuntu 18.04, its under Settings > Software & Updates > Additional Drivers.

I know when you have a laptop with both integrated and dedicated graphics it can make things a little harder, but I have never had a laptop like that so my experience with it is pretty low.

Once you have the nvidia drivers installed and working, this is an easy way to get rid of the tearing.

With the proprietary driver open nvidia-settings, go do the X Server Display Configuration page, click “Advanced…”, and check Force Composition Pipeline and hit Apply. Your screen may flash.

This prevents any tearing at all for me, in all applications. There is a performance impact but in my experience it isn’t a massive one.

When running a game I just turn Vsync off in game, and it’s handled by the nvidia driver. No tearing and everything works great.


I have a laptop with the core i7 6500u and GTX 940m.

1 Like

Ok so did you get the Nvidia proprietary drivers installed?

post removed.

1 Like

I switched to that in Driver manager right? that’s the one I did.

1 Like

Please use any os but mint.

You may want to elaborate on that.


So mint, currently and in the past, has been scattered. Some things are up to date and other things are just 2009 for no reason. I just fixed alsa and pulse problems out the wazoo for some of the fam running mint 18.2. Thats not old.

Instead, try ubuntu mate. You’ll have an A+ experience as its designed around user choices. You can do whatever you need without ewer touching the terminal. ElementaryOS is also A+.

1 Like

I accidentally broke ubuntu though. trying to unload x server and install the nvidia graphics driver. maybe i’ll try elementaryOS. maybe even fedora.

Ok lemme share a rule.

We ignore the nvidia website. Ubuntu has a driver installer just like mint to set up drivers. Again, no reason to open a terminal :stuck_out_tongue_winking_eye:

1 Like

I understand the branches that linux has, debian - ubuntu - mint and so on.

1 Like

A “PPA does not support…” message means that PPA repository does not offer any packages that support the distribution release you are using. The current release of Mint is based on Bionic.

Mint offers releases based on 3 desktop environments, Cinnamon, MATE, and XFCE. Each uses a different engine to paint screen content. I’ve never noticed screen tearing in Cinnamon but I have in MATE and XFCE. If you’re using one of the latter two, be sure the compositor is enabled. There’s a setting GUI for that.

If you run full screen in Cinnamon, there is a setting that toggles compositing on/off in full screen.

Firefox on Linux disables hardware acceleration by default. You can search for how to enable it. That might make a difference.

Be aware that if the Driver Manager tool offers an Nvidia driver for your card it is probably best to stay with that, not one from a PPA. You have more assurance Canonical will test that driver against a kernel update, and vice versa, than with a PPA’s driver. Also, the primary reason Nvidia releases new driver versions is to support new cards. The company posts information about what’s in each new version online.

1 Like

There is a semi official ubuntu ppa with newer nvidia drivers: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

These work as well as the ones from the driver manager and are more recent. It has a wide selection and you just install what you want. Best would be the current long lived release.

As for the PPA not supporting the distro it is as others said.

Linux Mint is based on Ubuntu Bionic (18.04.x LTS). So PPAs not targeting Bionic will not work.

EDIT: IMPORTANT. Either with Ubuntu or Mint use Timeshift to make snapshots (on a different linux partition than the Os btw). It will make your system basically immortal. So any mistake you make you can recover.

Ok so, what I did to mostly get rid of tearing is add nvidia-drm.modeset=1 to grub where you see quiet splash put it on the same line. You can do sudo nano /etc/default/grub, and find GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

It should now look like ~GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nvidia-drm.modeset=1”

Then do sudo update-grub to apply

This should enable Nvidia PRIME to mitigate most issues. That said I still had tearing after doing this in chrome. Chrome runs like dog poop for me no matter what I do. You can disable hardware Accel in the settings but that will greatly increase cpu usage. It’s a lose lose there.

if it’s using the intel gpu you need to enable tear free. this fix requires editing a file in /etc/xorg

if it’s using the nvidia gpu you need to open nvidia settings and go to the display options tab. click the advanced button and check the box for force composition pipeline.

if you still get tearing specifically in a web browser then you need to enable hardware acceleration in the browser. the process for this is different for chrome (about:flags) and firefox (about:config)

moving past fixing that issue I strongly suggest using Ubuntu instead of mint. I’ve had to deal with too many outdated and broken packages and dependencies on mint to ever suggest it. use Ubuntu it has all the exact same things but it’s better maintained and much more updated. which is saying something because most Linux people complain that Ubuntu doesn’t stay up to date enough.

Enough with the suggestions to use another OS. If OP wants to use another OS then let them make that decision. If your sole reason for suggesting another OS is to fix a problem OP doesnt have then you should reconsider why you are suggesting it.