I got 99 problems... and A2 is one

Apologies for the JayZ reference (Jay "zed", in England. But only if you're cool enough to pronounce it the correct way).

Anyway, I have some genuine problems with my build. It appears to be something to do with my storage. I know that the Q-code displayed on the motherboard, "A2", is not an uncommon problem. I have a red LED indicating that there is a problem with my boot device.

I built my PC some weeks ago, and had everything running fine. I had the appropriate motherboard drivers and GPU drivers installed. No high temperatures, good gaming performance. Please read further for all the possible information that I can give to you guys, in order to help meeeee.

I installed ASUS utilities last night, thought I would give Fan Xpert a twirl. I click a button, I don't know what it was, but it should have configured the fans to the optimal setting. It then restarted my system, and I thought it was best to just let do its thing. After an amount of time passed, the LEDs on the fans were still on, I just decided to shut down the PC, because whatever was supposed to happen did not happen! I thought I would try again in the morning.

So... I am trying to sleep at night. The Computer boots up by itself. It is full of LED lights, so I know the damn thing was being controlled by some sort of demon. It was just glaring at me. U kno dat feel? I think that is the point in time I just pulled the covers over my head. One arm lept out of the covers and frantically searching for a weapon, and it found my electric shaver. I was going to shave that bitch in half!

The PC quietened down, and totally turned itself off, to my relief. This is part of the weird experience I have had with my system, in the past day.

I tried booting it up again this morning, and it just wouldn't display anything. That is when I noticed the error code on my motherboard. I've also done some simple cable management, unplugging sata devices to get the cables tidy, make sure they were all fitted properly. So the sata devices appear fine. I changed all the cables, I ensured that the devices were getting power.

I've also tried clearing the CMOS to get around the problem, to try and get the PC to actually boot.

The damn thing turns on and just displays this A2 code and I cannot think what to do next. I do have some spare HDD, to maybe try and get around any of the bad mojo on the drives currently in the build.

What would you guys advise?

Here is my build: http://uk.pcpartpicker.com/b/Dgl

Can you get in bios at all?

Nope. I got no display. Just the error code on the motherboard. I've tried using the onboard graphics, to eliminate the GPU in the list of possible problems.

It's definitely something to do with my SSD that I use to boot. It could be something stupid, like a cable, or port. But, with the way Fan Xpert was acting weird, and the way the system would turn itself on and off during the night. I just don't know.

I think I'll take it to a tech guy I know, and just pay him to fix it.

It would be better to not go to one just to save money.

Heres what i would try.

-Using different sata cables and using different sata ports.

-Using different cable to monitor like a Display Port, Hdmi or Dvi

I read on another forum that it could be the pcie lane that making it not boot. so try using a different lane maybe.

If any of these don't work i will find more things for you to test. Just hold in there the answer to you problems will be solved. Eventually....


I tried those. I tried HDMI and display port. With card and without card.

Thing is, the computer was running fine, until I ran some of the ASUS utilities. Some sort of corruption has occurred. Either on the motherboard, or my SSD, where some of the stuff was installed.

Gotta think about all the weird actions my PC has been doing. Turning itself on after being quiet for hours, the powering down. That's not just a normal A2 complaint. Though, I am still hoping that I can just have a play around with the sata and get it to boot. Then clean up those programs.

I'm thinking I need to just format the SSD and HDD. Cut my losses. Then clear the CMOS again. Do a fresh install of Windows. Not sure how I am going to do it.

It might be the best idea to just wipe you hdd and ssd and try again with a fresh install. If that dosen't work im baffled. And not ot install Asus utilities.

Am i the only one that turns my pc of at the wall?

Must be. Though, there isn't anything wrong with that. I just delibrately bought the fastest consumer SSD and other parts so I didn't waste time on boot up. So, not turning off at the wall is my speedy preference.

It was strange. It was like 4am, then I heard it whirring and I look over to see the LEDs glimmering, and then getting louder and brighter. And I just about shit my pants. I physically turned the PC off, when I went to sleep. So having it boot up in a really slow, weird manner. Gradually getting louder and louder was just terrifying.

I know my PC is pretty monstrous, I didn't imagine it would try to strangle me in my sleep. I might have to lock it away in another room tonight.

How can I wipe my drives, without any kind of interface?

I do have a spare HDD, with nothing on it. I thought about using that to boot, then trying to format the different devices. Would that be advisable? I did have the intention of wiping my drives, anyway. I got some stuff on there that I wanted to try and keep, but no big deal. I wanted to wipe them so I could configure my drives appropriately. Wanted my HDD for be C:\ so all my crap would automatically get sent to mass storage.

You could reinstall windows on the spare hdd just untill you get the problem fixed. Then return to your original drive.

If you wanted to wipe the drives you could go to a friends house with a pc and hook one of you sata cables up and reformat it. If you don't have a pc lying around.

Yeah, I'll try the spare HDD. That might open up some fixes.

Good luck this seams to be a big problem. A reason i stay away from newly released products. The companies still have some hidden bugs lying around. Eventually someone will find a bug and is seams you did.

It was fine until I ran some of those extra utilities. Everything happens for a reason. I thought my drives were already bloated. So, this is an excuse to just erase everything.

Well good luck with it. 

I better get some sleep nearlly 3am here in Aus.

Yeah, I recall seeing you say you were from Aus. Thanks for the help, dude. I'll post results here

Plugged in my spare HDD, still got the A2 code. I'll be swapping cables and ports to try and get it to boot on this spare HDD. However, I fear I will get the same results.

I think this is possibly pointed to the motherboard. Fortunately, I have a USB pen drive on the way. I might be able to do a BIOS flashback with that USB drive. This motherboard supports USB BIOS flashback, thankfully. I might be able to restore the BIOS, that way. Since, clearing the CMOS hasn't had the desired affect.

Try resetting the bios

On the Hero, the A2 code means that the IDE is detected, but it can't get any further.


Tried the BIOS. Tried the jumper, tried the CMOS battery. Last thing I mentioned is BIOS flashback with the USB key. I've got it on order, the page with the BIOS file I can download is bookmarked.

I'll give the CMOS another bash later, just too tired after a day of playing with SATA cables.

Sounds like a Bios error. Reflashing the bios should fix it. I accidentally corrupted my M5A99FX Pro R2 bios when I was overclocking a month or two back but I was able to save it with Bios Flash back with a reflash. If reflashing doesn't fix it I would RMA.

Thanks, man. I ordered my USB flash drive some days before this corruption occurred. Everything happens for a reason, right?

I also got a disklink on the way. It's one of those USB devices that you can connect SSDs and HDDs to, just incase I need to reformat. You've really given me hope.

As I said, I got the BIOS file bookmarked, ready to download. I shall try your method. Thanks again.

I've used the BIOS Flashback on my Maximus V Formula to quickly update to recent BIOSes. Works lke a charm, as long as your power doesn't go out ;)