I bought an Optane SSD and I don't know how to use it

I bought an Intel Optane D4800X server SSD w/ 750GB capacity (u.2 and branded IBM). I bought a u.2 to PCIe conversion card, but I am unable to format the drive (the progress just slows/stalls).

I am on an AMD system but I was under the impression that you could just use the drive as a regular SSD. I tried to install Intel Rapid Storage Technology Drivers but it does not work on non-intel platforms. Any suggestions?

My goal is just to get a readout of TBW and drive health information because I bought the drive second hand. Is there any way to do this?

Update: I think it was the Conversion card. or
Maybe I was just too impatient (it took more than 30 minutes to format the drive) and I hope it is working just fine.

Update 2: Apperently there is a temperature problem (I see why they canceled optane if this density drive can heat NAND up by this much). Re: trying crystaldiskmark with more threads or smth.

Update 3: Using more threads was the solution, I am still not at the rated speeds, but at least my benchmark numbers is not an order of magnitude lower. (Update 4 Picture)

Hi and welcome!

I think that you generally did the correct steps. Stalls and slow progress are unexpected and you should look for indicators of trouble.

First I would consult system logs for connectivity errors.

Also, the D4800X is an enterprise drive and probably demands better cooling than the typical desktop environment provides. I would recommend looking for temperature readouts. Too high values can be the cause for thermal throttling.

I’ve run a few in less than ideal situations, unless he’s REALLY taxing it, it won’t be a problem. Chances are he isn’t, and will never

1 Like

I am just trying to format the thing to I could run crystaldiskmark or smth. I am really not trying to do anything too taxing here.

Eventually I would like the drive (and maybe a spare for raid 1) to be a part of a ZFS NAS as the L2 cache and metadata cache, but that is a long ways off since I don’t even have an enclosure yet and my sysadmin skills are literally zero. (I have played around w/ Pop_OS but trueNAS core is something I need to learn)

I put my money on that adapter being bad. You got it on Amazon, can you order a different one to test and then just return it?

If I am unable to install intel RST what next? Is the drive just dead? It shows up in diskmgmt in windows, but formatting it and trying to install stuff on it is not working.

Is there some linux/FOSS utility that allows me to utilize this drive/

That adapter also had a SATA port and included a SATA cable. I plugged it in thinking it was required. Maybe that is the issue?

You don’t need the SATA cable for sure, I’d unplug and test, but I don’t think it would be an issue as the SSD has no SATA interface

Don’t tell Amazon but I may have flexed the connector a bit when trying to screw the drive onto the add in board

If you can, try this

1 Like

Oh no, how will Jeff afford another rocket!

I return like 50% of the stuff I order

I literally saw that, and scoffed and thought it was too cheap and was a ripoff.
I will do no such thing this time.

The reason I linked it is that I’ve bought 3 of them and all 3 worked fine, reviews seem alright too

At least if you try another adapter, you can write that off being the issue

actually, is that connector actually U.2?
I had some confusion as to the SFF naming scheme and was afraid I was buying the wrong product.

Yep, that’s U.2

I actually never thought to look in HWinfo64. Here is the readout. See if you can see anything that looks wrong.

Looks alright to be, but I’ve also never looked at a drive in hwinfo

I’ve got one of those running on an AMD threadripper and can confirm it should work like a normal SSD.

I’m not sure if it’s the case here, but I’ve had similar issues in Windows with NVME drives that were previously formatted using unsupported filesystems or perhaps were configured as a boot drive for another OS.

In those instances, Windows can detect the drives, but there’s no way to access it.

In case you haven’t tried this already, you should run diskmgmt utility to delete any existing partitions, format the drive and then assign a Drive letter.

If you have done this already, it’s possible your conversion card is faulty.

2 Likes

Even better, open cmd as admin and enter diskpart

do “list disk” and find the SSD, then do “select disk X” on the ssd, and then do “clean”

1 Like

I got the second conversion card, but the format is still taking forever.
Is it possible it is a drive problem?