I bought an Optane SSD and I don't know how to use it

Actually nevermind, it just took like 15 minutes even on quick format. Will post crystaldiskmark screenshot soon TM.

image

image

Uhh, my benchmarks are not showing anywhere close to the specs… What does this mean? Is windows this bottlenecked or is the drive faulty?

I am becoming increasingly concerned

You need better cooling. I my case the SSD location behind the motherboard wasn’t good, because there wasn’t enough airflow. Now it’s mounted in the front directly behind some fan and now the temperature is ~30° C

1 Like

You are right, but the performance is still not necessarily as specified
Especially the IOPS.

Try to get the temperature below 50C.

While I don’t have hands-on experience with the Optane 4800X, I notice that my Micro 9300s are throttling once the temperature sensors raise beyond 50C.

1 Like

Try more threads

I don’t have extra case fans. I borrowed the only desk fan in the house and I was pointing right at it.
The operating temps on the specs sheet said up to 70C anyways.

Assuming the above conditions… would you say that this drive is in good health. Especially considering that the nonexistant TBW number and that it is a 2 year old drive

How? choeasycopy?

That’s more like it

Something still seems off as you are getting about half the performance.

Here is what I’m getting with my Optane 905P (Gen 3), but my transfer mode is PCIe 3.0 x 4, whereas yours is only PCIe 3.0 x 2.

1 Like

Didn’t notice earlier. That explains the current performance.

1 Like

This looks like only have 2 PCIe 3.0 lanes active, instead of 4 (Ah, late to the party)

Note sure what would cause that other than a bad connection or lanes boot being physically there on the motherboard. But I’ve never seen only two done. It’s always either 1x or 4x

Doesn’t the DC4800 series have a dual port PCIe 2x2-lane interface for redundancy/failover purposes? That’s about the extent of my knowledge on the subject, but if your particular drive does and it’s something configurable, maybe related to the drop in performance?

That said, I seem to remember that they should fail back to a single 4x link when a certain backplane pin wasn’t driven on the drive, but maybe that’s just for newer drives. Can’t really say for certain.

Convenient that I find this only after buying the exact same drive and running into the same problems.

Windows really does not like formatting this drive. If you look in the event viewer, you’ll probably see stornvme entries of “Reset to device: \Device<Some Path>” every few seconds while trying to format it, with or without drivers. However for some reason, Linux has no trouble. I ended up formatting it as NTFS (as well as the other 2 partitions Windows needs for a boot drive + all the correct flags) from Linux then installing Windows on it, which worked.

I’ve tried it both in my AMD EPYC-based server with U.2 hotswap bays (but only single-port connectors), and an X570-based desktop with coincidentally the same DiLiVing adapter cable mentioned above. Both platforms exhibited the same problems with formatting.

Performance has been underwhelming, and it’s probably because mine is also only linked up at PCIe 3.0 x2, as per both CrystalDiskMark and HWiNFO.

The D4800x is the dual-port (two PCIe 3.0 x2 connections) version of the P4800x (one PCIe 3.0 x4 connection), but from multiple sources online I was led to believe that if the drive is connected to a single controller, it should link up as a regular x4 device, yet clearly that’s not happening. I haven’t checked whether it links up as x4 in the server.

Intel offers a driver you can install for it, but it unsurprisingly made no difference in performance or link width.


CDM-Driver

1 Like

The other 2 images since I can’t post more than 2 at a time:

HWiNFO
IntelMAS

1 Like

Bad news. It only links up at x2 even through the U.2 backplane on the server. It appears this drive does not support falling back to single-port x4 mode. I’m returning mine to the seller and have purchased a P4800X instead.

HWI-Server

Other SSDs in the same backplane link up at x4 just fine, so it’s a problem with this Optane drive :frowning: (just to be clear, the other drives are also single-port ones, so I can’t confirm whether other dual-port drives’ fallback works or not)
HWI-Other-Server