Return to Level1Techs.com

Home WiFi visible but not connecting for no apparent reason, I need the ghostbusters or something

The hits just keep on coming tonight in my house.

TL;DR: WiFi is visible and can be saved as a network but will not connect to any devices at all. I have tried the usual suspect fixes and none of them work, see below for the details.

Long Form: We have a home router provided by out ISP (Vodafone Ireland) and it had been happily sitting for years not disturbed and doing its duties. About 2 months ago the WiFi started ocasionaly dropping for a moment and recovering, this had no impact on wired connections and our underlying internet connection is fine. The problems advanced to dropping for a few seconds to minutes and eventually full days where upon I would come home and be asked to “fix the internet”, the usually IT Crowd fix (Hello IT, Have you tried turning it off and on again? hangs up phone) worked most of the time and sometime a few tries would be needed but it worked.

About 2 weeks ago it reached unworkable points and the ISP was called. They sent out a new router after some back and forward and explaining what the problem was and that it was an untraceable intermittent fault with no clear reason why. The new router arrived and all was well for a while with not a problem.

TODAY! Come home and my brother casully says, the WiFi has been down the while day, he knows all the usual tricks and had tried them to no avail. I poke around I the configuration pages and try changing:

  1. the channels,
  2. the name,
  3. the number of devices that can connect,
  4. the security,
  5. all the reasonable options.

I am at a loss. I don’t even know what I would tell the ISP now as this is twice with different hardware.

Every device can see the connection, they input the password and then the WiFi will just say saved, secured on android devices, same for everything else with their own error messages.

The WiFi is there, but won’t let anything connect.

Please help, please.

Edit: just fixed the title… One word was out of place.

Just a shot in the dark, is the encryption the same? So I would assume WPA2-PSK, but an additional maybe there was a setting for AES or TKIP that wasn’t set properly.

Also, since it wasn’t mentioned. Have you tried turning it off and on again?
EDIT: Ignore the off/on again question since I just saw “IT Crowd” fix.

1 Like

I have tried that, it was set to WPA-PSK/WPA2-PSK with TKIP+AES. I tried setting it to just AES, to WEP, to just plain Open every time the same it would save the network but not connect.

I did not leave it open, that was just briefly to test.

It was not metioned in specific words but yes the IT Crowd fix was applied.

What does event viewer on any windows device say about connecting to the wireless?

You can find it under standard “System” logs.

P.S. I choose windows specifically because I’ve been dealing with wireless issues at work all this week and it has been driving me nuts.

We have no wireless windows… Wait a minute, I will set up my mini PC and find out.

these are generally not great, you might have to consider replacing it

Yes I know.

My only defence is it worked fine for years before this, but it is definitely on the list of things to do, I just want to try all the free options first.

things generally work until they break

Okay thanks for being helpful…

1 Like

no problem, anytime

Okay I have the event viewer open.

I have no idea what I am looking for, but the PC is the same general problem. Won’t connect to the WiFi but is aware of it and has the correct password.

I want to guess it is Router side…

Does WiFi work after factory resetting the combo modem?

Okay… the hard reset did not work, in that it did not factory reset the router. It still has the WiFi name I set after we got it and the login password we changed it to, but after one more on and off cycle it is working, for now.

I will keep an eye on it though. I hate these faults. I have done these steps before and no fix do them again and fixed, ugh!

I am still not sure if the reset button should be pressed while it is on or off. I did not try unplugged. But I pressed it when it was on, turned it off and pressed it again just for good measure.

Edit: I don’t class thus as solved yet.

Factory reset in my mind is the 30-30-30 reset.

Hold down the reset but/pin 30s w/ power on, continue to hold for 30s with power off, continue to hold for 30s plugging power on again.

2 Likes

I will keep that in mind for next time, thank you for the help.

The router from my ISP stores a copy of all these things on their servers, so on a hard reset it clears everything and then reapplies some of the previous settings.

I don’t think ours is that advanced at all.

Could be wrong but I really doubt it.

1 Like

Similar situations are observed in several EU locations with Compal ch7465ce and some TPLINK 5Ghz cards. The networks are broadcast but you will not connect. Apparently a problem with the software.

And how is it in your case it’s hard to say. Maybe time for your own router with good wifi?

That will be the next step if this continues. Though I don’t want to buy potentially multiple routers that all encounter the same problem because I still have zero idea why this is happening in the first place.

I have already floated the idea here and there is agreement but it is for nothing and waste of money if it achieves nothing.

Without a second router, it can be difficult to say clearly where the problem lies. Unless you make AP on some PC temporarily.

If different cards and machines are not able to connect. If the change of channels, encryption, network type, drivers, restarts, off / on wifi, it has no effect and you have eliminated virtually every other option except wifi in the isp router …

It will be a hide and seek game. Check literally everything using the elimination method to identify the source of the problem.

You can always buy some cheap Archer C1200 for 45 euros. :wink:

1 Like