HGST compatibility with not so old MOBO

Hi guys, hope everyone’s well.

I have an Asus Z370-A MOBO, and I’m trying to use HGST 14TB HD (HC620 HSH721414ALE620) with it… Can I make windows recognize the HD?


Is it SATA [connected direct to board]?

You have opened the “Disc Manager” in the control panel?

Is the drive listed there, but in a different colour?

A brand new drive needs to be formatted.
I think you fisrt have to choose GPT, then NTFS
(It shouldn’t allow you to choose MBR, as the drive is too large, I think)


yes, It’s SATA connected to the board. I tried different SATA ports, and different cables.

none of the two 14TB HD show in device manager. Nor in the MOBO BIOS. @Trooper_ish

Wow, if they aren’t showing as attached in the motherboard, that’s pretty tough. Are they spinning up with power when the system starts?
If the SATA sockets and cables have worked fine with other drives, you might have 2 dead disks, as unlikely as that is. Or more specifically, two dead controller boards in the disks.
None of the PBC or cables leading into the drives look damaged?

Look if the sata 3.3v reset pin is a problem.

1 Like

yeah, their spinning, and all showing connectors looks good. It’s a compatibility problem. I talked to Asus support (my mobo), they said I need Z-4** to make it work. I’m not convinced they’re right, because when I asked what’s the highest capacity HD my mobo support, the support person replied “1TB”…

The HD aren’t shucked. Here’s a photo of the HD

Could still need mod (Looks to me like its an OEM drive not COTS)


Isn’t it out of one of those external HDD enclosures?
Sometimes you need to mod the SATA power pins to make it work properly.
This is a guide for WD drives, not sure if Hitachi ones are different or not:

The drive still spins up even if the reset pin is an issue. The only symptom of the 3.3v pin issue is that the drive is not detected. The easiest way to see if it is a problem is to plug it into a Molex to sata adapter instead of straight sata from the PSU.


Hitachi = WD for hard drives these days.

1 Like

Oh, then it should be the same thing, in theory.

The 3.3v pin Cake suggested is a great thing to check- a little bit of thin tape can be put on to test

thank you all for your answers
@mutation666 @Automobili3XF @TheCakeIsNaOH @GoldenAngel1997 @Trooper_ish

so I used two sata power to molex adpaters, and connected the UPS cable power SATA --> into a molex --> and that MOLEX --> into a SATA power --> into the HD

… but the reasults are the same. Both drives are working, I can feel them spinning on startup, but BIOS nor Windows recognize them

1 Like

How weird, it must have some kind of protection.
Did you try it on another motherboard?

Did you try the pin taping trick?
Have you tried any other sata cables/MBports, for that connection?

Should you have access, to another computer system, throw it on there

Don’t have another mobo :blush:
decided to skip a generation, because next generation will require a new mobo again (AMD).

I have two 3TB HGST drives connected to this mobo, and they work well for 3 year now.
yes, switched ports and cables with each of the two HDs

I have an external 2TB HD, is there a point taking the 2TB out, put the 14TB instead, and connect via USB?

It’s sure worth trying the USB thing

well, with a USB conncetion through sata to usb adapter, windows does recognize the HD… :confused:

at least the disks are ok
but how can I make them work with SATA?

1 Like