Return to Level1Techs.com

Header/Title Bar on GNOME Shell 3.32.2 too Thick/Big

gui
#1

This is the Title/Header bar on Fedora 30 / GNOME Shell 3.32.2

I am trying to get it to the same size as I had it on Fedora 29 see below:

I’ve tried changing the font size but that only works for most programs. The Terminal still has this large bar and I do not like it :face_with_symbols_over_mouth:

the config file in this link ( Gnome 3 bar fix ) No longer works… I still have ~/.config/gtk-3.0/gtk.css and all, and some apps are respecting these rules, but not Gnome Terminal.
see KeepassXC below:

Has anyone found a workaround / fix?

0 Likes

#2

Does this stuff get it done?

decoration.ssd headerbar.titlebar {
    min-height: 0;
}

decoration.ssd headerbar.titlebar button.titlebutton {
    padding-top: 1px;
    padding-bottom: 1px;
    min-height: 0;
}
0 Likes

#3

Sorry but that is the same solution I have noted above

I believe after some tinkering today that The Gnome team has done something different with terminal since it now has menu, search, etc on that bar. Wondering if anyone has come up with a solution. At this point it’s just Terminal because all other apps respect the config file.

0 Likes

#4

Look at answer number 1

0 Likes

#5

I’m pretty sure that reddit post had a lot more ideas than that forum thread you linked to. Did you dig through that, the initial complaint seemed pretty similar to what you’re saying.

0 Likes

#6

I’ve updated the .css file but I’m in the middle of finishing up some jobs that I have running so when all that is done I will update with my findings.

Also to note: Most of the fixes are from Gnome 3.2x and things have changed subtly from the Gnome team, so I don’t expect it to work but I will refresh everything in about an hour and report back.

2 Likes

#7

The added code to my configs did not work so I will comment them out. (need to for other builds) I did some looking around and found this from the Gnome team

Client-Side Decorations Initiative

Apparently this is the default now for certain gnome apps. there is a list on the website :

Which apps are affected?

Below is a list of some popular applications using title bars. The information regarding toolkit, difficulty to port to CSD, and status may not be accurate or up to date. Feel free to fix potential errors or missing information. If any apps you use are missing from this list, please add them.

High Priority:

App Toolkit Difficulty Status
LibreOffice VCL+GTK3 difficult discussion, other related bugs: bug 1, bug 2
Blender No toolkit difficult discussion
Firefox GTK3 difficult implementation in progress
GNOME Terminal GTK3 medium done (on by default on GNOME, but overridable both ways by a gsetting)
Inkscape GTK2 difficult not started
GIMP GTK2 difficult not started
Skype Electron easy not started
Telegram Qt easy mockup

I will have to do some tinkering, but atthe moment it’s realy the only app that I use daily that still does not respect the .css config file so i might live with it for a while till i have time to play with settings. I will update this if i find a solution.

Thanks @Goalkeeper @ContourNut for taking the time to look into it

2 Likes

#8

So basically, they want to look like elementary os

1 Like

#9

2 Likes

#10

Yea this thing where you shove widgets into the titlebar is really popular now. And in the Gtk world it’s supported with a special widget (GtkHeaderBar) that makes it very very easy to implement without breaking things like user specified min|max|close button order and position. But since widgets are generally bigger than people like their min|max|close buttons it ends up increasing the height of the titlebar.

I think apps that use it well make great use of the space and I really don’t mind it (example: tilix - there are several useful actions on the titlebar). And then some apps just have it forced in to little gain (example: gnome-terminal - there’s maybe one useful action). All in all though, even if they did a poor job of it, if they dropped the traditional menu they’re still using less vertical space overall. And if they dropped the menu and toolbar, then you get back a massive amount of vertical space.

I’ve just kind of gotten used to it :man_shrugging:. What really took me a long time to get used to was clicking in the titlebar without activating something, but I’ve slowly learned to use super+click to move windows around.

1 Like

#11

on by default on GNOME, but overridable both ways by a gsetting

This sounds like all you have to do is tick a checkbox. Look through your dconf settings.


EDIT: Yep, it’s just that easy. Open DConf editor, then set org->gnome->terminal->legacy->headerbar to false. Restart the terminal. Done.

3 Likes

#12

Thank you. I’ve never had to do that on my system but I have another system i will try this on. I will keep the thread going for at least a couple days and come back with my results.

1 Like