Return to Level1Techs.com

GreenWithEnvy: A Linux NVIDIA GPU OC utility available on Flatpak

nvidia
linux

#1

Looks darn impressive. I might try it out if the community here likes it. It does have the “Coolbits” prerequisite, but that’s required anyways for GPU OCs on Linux.

The key function this has over nvidia-settings is a GUI method of setting the power limit, and FAN CURVES.

You can view the repo here:

Tagging @wendell cause it’s 100% related to the Gaming on Linux video series.


#2

Let’s Troubleshoot py3nvml. Reply to this post if you have problems with py3nvml failing.

Here are my problems:

It can’t find the shared library libnvidia-ml.so.1 even though it’s present in /usr/lib/x86_64-linux-gnu on Ubuntu and /usr/lib64 on Fedora. I’m running 415.22.05 on Ubuntu and 396.54.09 on Fedora.

Apparently it’s only affecting Flatpak. Ubuntu 18.04 and Fedora 28 fail to get the shared library from a flatpak install.

Arch though is fine on 418.30 beta drivers:

The problem is this app uses libdazzle, which only works on GNOME 3.30, and Flatpak can grab GNOME 3.30 as a runtime. But using a Flatpak might create path confusion in some scripts… GNOME 3.30 and libdazzle, plus shared library access are the biggest blockers for this project.

So, anyone else have py3nvml issues? Also, anyone get it working on 18.10 or Fedora 29?


#3

So something weird happened after I installed GWE.

It seems that LightDM ( my display manager ) would no longer start, because of a DBUS conflict or error.

I am not sure if there was a correlation to installing GWE and LightDM breaking, but it had been fine for a long time before I installed GWE and it was the only thing that had changed ( no updates or anything ).

So I thought I would put a warning out there for anyone running LightDM. I tried everything, deleted all config files, reinstalled LightDM, changed greeters, but it would just start to a blinking screen.

But that doesn’t matter to me, GWE offers fan profiles, which I really wanted.

So I just disabled LightDM, installed & enabled SDDM and called it a day.

Everything is working great for me, but I only have Coolbits “4” because I don’t care to OC the card (yet).
Also, this is Arch running nvidia 415.27 (non-beta).


#4

Hi everyone, I’m the developer of GWE.

Let’s Troubleshoot py3nvml .

@FurryJackman it is likely that to fix your issue you just have to run a flatpak update to get the latest org.freedesktop.Platform.GL.nvidia

It seems that LightDM ( my display manager ) would no longer start, because of a DBUS conflict or error.

@duncanyoyo1 I never heard about any issue with DMs or DBUS related to GWE, how have you installed the app? Via Flathub?


#5

I installed it via yay ( AUR package gwe )

And it’s likely that it wasn’t GWE’s fault, it has been my experience that LightDM is pretty bad.


#6

I see, the best way to get it for now is using Flatpak.

But please let me know if you find something more so that I can add a warning and/or get in touch with the AUR package maintainer.


#7

I tried the flatpak one, but it had way more issues.

  1. It uses the hideous CSD. Can’t stand them.

  2. It doesn’t use my GTK theme.

  3. It has to install like 700mb of useless stuff, where the AUR package is like 1.5mb.

For some reason KDE doesn’t play well with anything using CSD, it breaks the drop shadow a lot of the time. I actually use this https://github.com/PCMan/gtk3-nocsd to force CSD off and it works great, but not for flatpak apps. I think most of my issues are because I don’t use gnome.

But regardless GWE is awesome, and I thank you greatly for it. These features have been missing for some time now in Linux.


#8

org.freedesktop.Platform.GL.nvidia never got installed when I requested it. Might be a dependencies issue. It was also not made clear in the README.

Same problem occurs when I manually install the one for my drivers from Flathub. Looks like Flathub only lists stable drivers rather than beta ones or the Vulkan betas. There are no Vulkan or standard beta driver runtimes, period.

Here’s the stubborn unresolved issue on it. They will never do it because they change too much, meaning we’re all SOL on beta drivers:

This is supposedly the solution but it is incredibly confusing:

And even doing all that, it still can’t parse the file. Not on the (Vulkan) beta drivers via Flatpak. Arch is fine.


#9

Thanks for investigating the issue, I’ll update the readme making clear that Flatpak doesn’t work with beta (Vulkan) drivers.