Got FAHControl Running on Fedora

In a past version of this thread, I had issues getting FAHControl working
Linked below
Need help with gpu folding, [email protected], Fedora 31, Nvidia, Nvidia rtx 2070?
and explained in the following quote

After digging around the github page of the Folding at Home team, I found out there was a fix that solved the python compatibility issue

Funny enough I found out about the github and python compatibility when I was trying to find a method to disable cpu folding from the config.xml file. I found this guide that mentioned how the control client had issues with python3.


Without this guide, I would not have bothered to look into the repository that had fixed the compatibility issue. When I couldn’t get the setup script to work, It made me try filing a issue and try looking at the official Folding At Home github page.

If you don’t want to open the link I will quote it below as well
The OP on the github had the following issues, I also experienced these a while back, but I never documented it

FAHControl                
Traceback (most recent call last):
  File "/usr/bin/FAHControl", line 25, in <module>
    from fah import FAHControl, load_fahcontrol_db
ModuleNotFoundError: No module named 'fah'

the solution was actually to try 2 things using

python2 /usr/bin/FAHControl

in the terminal or modifying the bin file from /usr/bin/FAHControl

#!/usr/bin/python2

Funny enough it was a suggestion @draeh had suggested

I tried posting here, but the suggestions to use didn’t work.

When I took a look at the commit changes, it appears that they solved the python dependency error in March and committed a fix in April

Looking back, I think the reason I got the initial errors in the first place was from not knowing to install the pygtk2 prerequisite.

Debian / Ubuntu

sudo apt-get install -y python-stdeb python-gtk2 python-all debhelper

RedHat / CentOS

sudo yum install -y pygtk2

This prerequisite is no where on the rpm downloads. If I have learned anything from this experience, it’s that a wiki for the project is needed.

Here's a bright idea Here’s a bright idea, why don’t you link the github on the wiki so that when a new user can’t figure out why the application does not work, they don’t spend the next month wracking their brains trying to search the internet for solutions.

1 Like

This and not being able to find a fix to get my gpus working is why I got frustrated and uninstalled it. Thanks for the info, may give it another spin.

1 Like

Which is also pinned in the starting post of that thread.

1 Like

perhaps, but I feel the issue was I had not installed pygtk2 prerequisite for the control. When I tried changing the python to python2, I still couldn’t launch the program.

At no point in the linux configuration from the support page did they mention needing the pygtk2 package to get the application to open a window.
https://foldingathome.org/support/faq/installation-guides/configuration-guide/

The linux guide has no mentions of needing pygtk2, python-stdeb, python-gtk2 python-all or debhelper to get it running. This will inevitably frustrate new linux users since they can’t even get the program to load similar to the screenshots.

I’m a crazy persistent oddball to dedicate hours of time figuring out how to get FAHcontrol running. I didn’t look for solutions for fixing FAHcontrol until the config.xml file to prevent cpu folding stopped working.

1 Like