Return to Level1Techs.com

Glitchy audio with Fallout 4 and WINE

linux

#1

I’ve ‘fixed’ a problem with Fallout 4 under WINE and Proton that’s been driving me nuts for a couple of months. Audio in FO4 would start glitching out, or fail entirely, particularly with rapidly repeating audio (mostly automatic weapons fire would trigger it.)

The workaround seemed very odd to me. All I had to do was enable a fairly mild overclock for my Ryzen 7 1700 - 3.6GHz all-core turbo. I used this script:

Somehow I doubt such a mild overclock overcame this problem, and I suspect there’s something wrong with my default power management/governor settings that the script corrects. I’m on Fedora 28 if it matters.

Anyone have any insight? In any event it’s not that important; I just to have to remember to manually OC when I run Fallout.


#2

I know the literal name (Wine is not an emulator) suggests otherwise as they are pushing for the whole “compatibility layer for Windows” crap, BUT WINE (like any emulator) will react much differently given changes in frequencies and everything of that nature.

While it’s improbable, it’s something to keep in mind.

It is most likely a flaw in how audio is configured via winecfg. I wouldn’t know as I rely on Proton through Steam and I played Fallout 4 from start to finish that way.


#3

Now that you mention that about Proton I think you’re right; Proton seems reliable, or at least less glitchy than the standard WINE bundled with Fedora 28. I also have a custom build of WINE that used to run the audio fine, but an update a couple of months ago (not sure which package) broke audio for me. With the overclock, audio is perfect.

The reason I’m not using Steam/Proton is that I want to use mods with FO4, and I struggled to find a way to get a mod manager to work with Linux native Steam. Since WINE shares the same prefix between all apps/games, it’s much easier to use a third party launcher/manager.

I don’t remember why, but I made a couple of tweaks to the Zen scripts in the link above. One was to disable the C6 state. I wonder if that’s the reason the script fixes the audio. I may experiment later, but right now I’m tired of futzing with it.


#4

I fixed the audio in Fallout 4 by compiling FAudio with FFmpeg support.


#5

It’s an xaudio issue. winetricks xact and adding an override for xaudio2_7 works too.


#6

Already tried that, no dice. Even with the xact libraries and the override it still glitches - unless I overclock.


#7

Try to change your CPU Governor to Performance.


#8

Hmm, does that lock the clock speed to maximum turbo? With the Zen script, it just raises the maximum speed and doesn’t lock the CPU to a particular speed. I’ll try it to see what happens, but I think my best bet is to run the Zen script at boot. I’ve been using it for nearly a year now and it seems pretty stable.