Return to

Gigabyte X570 Master Mobo Update

So just an FYI on the latest F30 Build for this motherboard model.

I had the hardest time getting my Corsair DDR4/3200 Kit to work in XMP mode properly with the older BIOS versions.

After updating to this version I was finally able to enable the XMP profile and saving and this works now.

This also fixed my weird booting issue with my 2TB NVMe SSD too.


I just updated to version F30 also. AMD AGESA ComboV2 for AMD Ryzen 5000 processors support. I haven’t had any issues. I have 2 sticks of 16Gb gSkill 3600 Trident Z Neo DDR4. 1 Tb Pcie 4 NVME M.2 Sabrent drive for boot. A 500Gb crucial sata drive and a 500Gb old Seagate spinning rust drive from my dead Asus G7 laptop. I got the ryzen 5 3600 6 core in hopes of finding a cheaper 3950 or 5000 series cpu after they are released.

f30 crapped out my 3600mhz gskill kit too. had to manually jack up voltage and use profile 2. fine now.

Ah, I noticed my Corsair kit is stable at 1.365vdc and it too had issues running at a lower voltage at just the 3200 rated XMP speed.

Thx for the update, this is one of the boards I consider for my next build.

I’m looking into getting the 5950x to drop into this baord, so I will be checking out any later BIOS revisions to properly support it if I am lucky enough to get one on Launch Day :stuck_out_tongue_winking_eye:

I have this Corsair 3600 Kit working out the box on my x570 Aorus Master Rev 1.1

Memory Size 32GB Kit (2 x 16GB)
Tested Voltage 1.35V
Tested Speed 3600MHz

Intel 300 Series, Intel 400 Series, Intel X299, AMD 300 Series, AMD 400 Series, AMD X570

1 Like

Aha, well I have a Rev 1.0 motherboard so this may have something to do with my 3200 kit would not work at this speed until I updated to F30.

I’m really glad that Gigabyte installed a dual-bios setup, so I switched to the backup BIOS chip and then flashed previously versions and then tested.

Finally this version works when setting the XMP profile.

Bios Version F31b available. 2‎020/10/20

  1. Update AMD AGESA ComboV2 B for performance optimized on Ryzen 5000 series processors

Very nice, I kind of figured it would be soonish for the official Zen 3 CPU support.

Updated to Bios 31b X570 Aorus Master
1usmus Ryzen Power Plan

PC was fine last night with a few tests, however this morning I pressed the keyboard to wake the PC and the Bios has now reset itself.

Auto Overclock with Ryzen Master
XMP enabled
CPU Vitualisation enabled
1usmus power recommendations in Bios

Seems Ok, but going to watch it. If it happens again I’m going to flash it back to F30.

1 Like

Hi Guys.

Update on Bios 31b. I’m using the 3700X CPU.

As stated before in previous post the Bios reset itself when I installed F31 upon sleep, so I flashed back to F30.
As the board came with F21 I thought it prudent to retrace my steps right back to where I started off as I did not have sleep issues before F31b.
Flashed both bioses to F21, loaded optimised defaults, went into windows and tested. Board went to sleep OK with F21. Then updated to F30, this time not updating the second bios.

Primary bios now F30, backup F21.

Seems Ok but would need to test for a week or two to be sure.

My only thought was that perhaps its the 3900/50 CPUs that may have gained some benefit with Bios F31b, notwithstanding the update for Ryzen 5000 support.
From what I have read in similar threads, it was primarily the X570 Aorus Master boards with those 3900/50 CPUs that had sleep issues, or at least moreso when using them, plus I read setups with 850Watt or more PSUs too.
In my case I’m using a good quality 10Yr Warranty 650W PSU.

Also deleted 1usmus Power Plan. Its possible newer AMD Chipset drivers have made 1usmus’s Power Plan obsolete.

System Specs:
Auto Overclock Ryzen Master
XMP Enabled
CPU Vitualisation Enabled
Uninstalled 1usmus Ryzen Power Plan
Ryzen Balanced Power Plan
Ryzen 3700X CPU
Corsair 650W PSU
2 x 16GB Corsair Vengeance 3600

Please report any findings you made thanks :slight_smile:

Hi BigBodZod

I’m still on Bios F30 and staying there for the moment. PC goes to sleep correctly.

The F31b Bios has been updated to F31d.

  1. Update AMD AGESA ComboV2 C for performance optimized on Ryzen 5000 series processors

Very Good, you should stay at that BIOS revision then, unless you intend to update to a series 5000 CPU in which case the sleep mode maybe resolved with this series of CPU’s ?

Could also be some kind of Motherboard issue but I don’t use suspend nor sleep modes so I can’t really test this.

1 Like

Bios F31e now.

The suspend or sleep modes as you describe I found was attributed to the Realtek Wake On Lan bug.

There are several ways of resolving the problem.
Which of the following did the trick, I’m not entirely sure:

  1. Updated the driver from the Realtek website.
  2. Device Manager, Network Adaptors, Realtek, Properties, Power Management … uncheck “allow this device to wake the computer” (did this for the Intel LAN too).
  3. Bios. Disable Wake On Lan.

After these steps, bios resets stopped and sleep mode works fine on any Power Plan you choose.

Lastly, to be sure, I disabled the Realtek Lan in the Bios completely. I’m using the Intel Lan option or Wifi.

PC seems fine on F31e

1 Like

Nice to know, I have both the Intel and the Realtek LAN enabled in the BIOS, I am using he Realtek LAN.

I have to check the Wake on LAN, I usually disable this function and turn off all power saving and sleep functions as I don’t use these at all.


I’m also on F31e–no problems. I also turn off all power-saving and sleep/hibernate features as I don’t use them, either. For as long as I can remember, sleep has been problematic so years ago I began turning it all off…Now that I can cold boot in 10-12 secs I see no use for these features. I’m also using the RealTek Lan with the Intel controller turned off–I enabled the RT many months ago just to see it operate and had no problems and so I actually forgot I was using it for a while. I do find that the RealTek Lan drivers on the Realtek site are superior to the ones on the GB support page–which are fairly old by comparison.

1 Like

How bad are the RAM voltage issues on the Master? on my X570 I Aorus Pro WiFI it overvoltages the RAM by 0.05V.

I have not really paid attention to that nor have I checked, sorry.