Gigabyte Aorus Pro AX and E10M20-T1 - PCI card not recognized by motherboard

I recently put together a small system that will be a new NAS server. I built with the Gigabyte Aorus Pro AX mITX rev 1.2 board with a Ryzen 5700G and everything has gone fine until I added the Synology E10M20-T1. The card is not recognized by the BIOS (it shows no card in that slot when it is installed and Linux and FreeBSD both fail to see the drives or the NIC).

I’ve tried installing the E10M20-T1 with and without NVME drives connected (2 x 32gb optane) and still not recognized either.

I’ve tried disconnecting all other removable PCI devices from the board so that only the E10M20-T1 (Gen 3x8) was installed, no luck.

I put the E10M20-T1 into another system running windows 10 (old intel asus atx motherboard) and the network device and both optane drives were recognized so I’m pretty sure the card is ok.

I then put an old bluetooth/wifi combo (Gen 2x1) and a 10G NIC (Gen 3x4) card into the Aorus and those cards were recognized by the BIOS so I have reason to believe the PCI slot is functional.

I’ve tried a variety of PCI settings in the BIOS for the x16 slot (bifurcation at 8x8 and 8x4x4, force to Gen 3 instead of auto) and no luck.

BIOS is flashed to the latest available for the board.

Any help or ideas would be appreciated.

Have you tried with just the E10M20-T1 in the slot connected to the CPU? It’s the only slot with 16 lanes on the board.
The other slots are only PCIe 3.0 x2 mode and PCIe 3.0 x1 mode.

My theory is that the card requires more than 2 PCIe lanes to function, while the other cards you tried work with the lanes provided by the other slots.

Yeah, there is only one x16 pcie slot on this mitx board and I t’s connected to the CPU. It should have 16 lanes available, right? I only need 8 lanes and if I remove all other PCIe devices (m.2) it still doesn’t read.

Looks like I might be out of luck with this configuration.

Too bad. I was looking forward to that Synology card for 10G and optanes for ZIL SLOG. I guess I didn’t do enough homework for this build. :slightly_frowning_face:

It will probably work fine using a non-“G” CPU. I have a few builds using Ryzen 5xxxX + 1x PCIe GPU (instead of the built-in).
I know, there is something that revolts against the extra card (cost and effort), but at least it works.