AMD Ryzen 7 5700G PCIe issues


I am currently working on building my home NAS as well and i found an issue that i need help with. My current specs are (mostly leftovers from older builds):

Motherboard - MSI B450I GAMING PLUS AC - BIOS version 7A40vAG with AGESA ComboAm4v2PI
CPU - AMD Ryzen 7 5700G
RAM - 16GB DDR4 3200
Storage - 4 SATA SSDs & 1 NVMe SSD

Today i purchased Synology E10M20-T1 in order to have 10 Gbps and additional storage with 2 NVMe SSDs. The card is brand new, factory sealed, purchased from the retailer, not Ebay or other places. I can’t seem to be able to make it work at all. BIOS does not see the drives, the ethernet NIC does not send any packages. Also Windows nor Ubuntu sees any of the hardware.

I found this topic on this forum, but it’s locked and i can’t reply there. I am wondering if anyone else met this issue.

I tried the following:

  • PCIe slot on AUTO - x16
  • PCIe slot bifurcation - x8/x8 & x8/x4/x4
  • Graphics detection disabled & forced only IGP
  • Both CSM & UEFI modes
  • No other drive connected, other than the 2 on the Synology card
  • Disabled other devices like WiFi and LAN
  • Checked initially with Kingston drive and then with Samsung 970 drives

Nothing helped. Does anyone have any insight or solutions?

Thanks in advance!

What you want/need is a x4/x4/whatever mode. Sometimes this is hidden behind a special PCIe RAID mode option (to enable e.g. a 4xM.2 carrier card). Do you see anything like that?

This mini ITX board has only x8/x8 or x8/x4/x4. Just tried enabling RAID as well but i see no option, nor anything changed in PCIe options. The Synology card is x8 though. I saw Wendell used it recently in a video, but with an AM5 board though.

NOTE: just found this page from AMD forums and it seems for APUs you get x8/x4/x4 while for CPUs you get x4/x4/x4/x4.