Gigabit internet not working on Raspberry Pi 4B

I have symmetrical gigabit fiber (FTTH) and a raspberry pi 4 Model B (8GB) and when I run a speed test on it, All I can get is 4-5Mbps:

On my windows desktop, I get the full bandwidth:

I am on the latest firmware and the ethernet port is configured for 1000Mbps / Full Duplex:

I have ran iPerf and the local network is working at full gigabit speeds

I am running my raspberry pi Linux OS from a USB 3.0 flash drive at the moment and planning on upgrading to an SSD shortly. I am using this Raspberry Pi for a seed box for all my Linux Distros I’m wanting to familiarize myself with :wink:. Unfortunately I have been unable to figure out why it is not wanting to use all my available bandwidth.

Any help is welcome, thank you!

Firmware:
photo_2022-06-20_13-43-34

Raspberry Pi Speed test:

iPerf Network Test:
photo_2022-06-20_13-43-24

Are both your desktop machine and the Raspberry Pi using the same speed test server? (ping seems different?)

Are they both using IPv4 or IPv6?

Tried any other speed tests? e.g. : curl -o /dev/null --ipv4 'https://speed.cloudflare.com/__down?bytes=1000000000'

With your iperf running full speed it makes me wonder if it’s just a problem with the speedtest-cli app. Did you install it from the raspbian repos or download the latest version from github?

Also have you tested speeds with a few different servers?

speedtest --list
speedtest --server xxxxx

P.S. - My Pi4 on Raspbian 10 is able to saturate my 400/20Mbit connection

1 Like

Given my pi is on a vpn connection, I have another pi 4 that is not on a vpn connection getting the same results, Im not looking to saturate my gigabit connection on a vpn, but I know I get close to 200-300mbps on vpn so it still doesnt make sense to me.

image

Same result, No matter what speed test I use, I get the same result

Is there any other hardware between the pi and modem? An old switch or something like that? Maybe try swapping the cables between the computer and the pi to rule out a bad cable or something. I can see it links at 1gbs, but there seems like there is something else going on.

It is a direct connection to the router and I have replaced the cable twice to make sure it wasnt a bad cable issue

Hi. Long time Patron, 1st-time caller. :wink: I want to help, but I’m afraid I don’t have an exact system to replicate. I have a gig up/down and I have a model 4, 4GB model. It’s not a 4B with 8GB, but I’m going to post anyway. I’m all up to date and I’m posting my output in case it helps you see something that might make a difference. Happy to test / change something if you’d like since it’s just here at the moment. Hope all goes well. Thank you

[email protected]:~ $ ethtool eth0
Settings for eth0:
Supported ports: [ TP MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supported pause frame use: Symmetric Receive-only
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Link partner advertised pause frame use: Symmetric
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Cannot get wake-on-lan settings: Operation not permitted
Current message level: 0x00000007 (7)
drv probe link
Link detected: yes

[email protected]:~ $ speedtest
Retrieving speedtest.net configuration…
Testing from
Retrieving speedtest.net server list…
Selecting best server based on ping…
Hosted by
Testing download speed…
Download: 808.52 Mbit/s
Testing upload speed…
Upload: 552.26 Mbit/s
[email protected]:~ $

Thank you for attempting to help, at a quick glance it seems we have the same settings/configs. Unfortunately I don’t get the same speeds. Even when my VPN is turned off, the best I get is 3~5Mbps. I have now upgraded my OS Storage to an SSD and this has not resolved my issue.

1 Like

Yeah, I didn’t want to rub salt in the wound, but I’m running a MicroSD card (Samsung EVO 32), so I don’t believe your disk speed is the issue. Sorry. Beyond cable change and the other items already mentioned above, can you change the physical port it is connected to on your router/switch? Change up the topology.?. Move the desktop to the RPi port and RPi to the desktop if you follow me? Power off / unplug the whole network for 65+ seconds to kill all old tables, etc… It’s time to get crazy…:wink:

No worries, Im willing to try as much as I can to get this fixed.

I have replaced the cat5e cable with a (known good) cat6 cable
I have swapped ports between my desktop and pi
I have shutdown my network by pulling the plug for 120 seconds

The issue still persists. I would think at this point that I just have a bad pi, but I have another pi 4 with the same issue and it would be extremely unlikely that I have 2 bad pis. I have no idea what to do next so any suggestions I will attempt.

Thank you!

1 Like

Good job L1L. I agree, having two bad pis is a possibility, but very unlikely as you stated. Have you looked at regular file transfers from desktop to pi and back to see if they suffer the same way as the internet? Does a 300MB file move at just 3-4 Mbps as well? Just curious. It could help isolate where in the stack the issue may lie.
I haven’t researched how, but maybe rolling back your eeprom version is an option. I mean if it’s broken, it’s worth testing one of them. Very sorry mate. That’s frustrating for sure, especially on the newest model. …and they aren’t easy to find or affordable as they once were.

Im new to linux but I assume the iPerf test above show the results you are looking for?

1 Like

Great point. I dismissed that. Thank you

I’m just going at it the way I would. I have large files, so let’s try and move one around & see what happens. :wink:

My OS is on a USB for this test:

At the beginning, it was running great:
13Percent

But towards the end it dropped speed:
75Percent

Good. That validates the iPerf which wasn’t needed but thank you for the trouble. The slow down is normal in my experience. Disk cache fills and so forth.

I’d have a read here. https://forums.raspberrypi.com/viewtopic.php?t=319865
It isn’t a fix, but it gets me thinking now that you’ve done a lot of work on the tests, format all your pi media, download a fresh OS copy, new flash exercise, etc… and going through the whole install from scratch could be worth it. Pain in the neck, but you lose nothing but time at this point.
“All I can get is 4-5Mbps” is what bothers me the most, yet based on rpi forum you aren’t alone. Could be worth your time and I hope it helps.

I wish I could say I havent tried that before, I have been switching between my sd card, USB stick, and SSD with different OS’s and the issue persists across the board.