Gaming, on my Tesla, more likely than you think

Thanks for the response and sorry I didn’t reply sooner, I got extremely busy and only just saw your message. I was really looking for an Nvidia card anyway so I ended up taking a K40c for ~150€, which was a fairly good price at the time for roughly GTX 970 performance + 12GB of VRAM.


BTW, I guess it’s not of much use now that GPUs have almost gotten back to somewhat normal prices, but here is some stuff I found out or confirmed these past months about the K40c and M40:

  • The K40c works fine on the P8Z68-V/GEN3 without any need for BIOS mod or anything, so no “Above 4G decoding” and “disable CSM” options required. It’s probably compatible with any mainstream mobo.

  • The K40c doesn’t seem to like DX12 at all (maybe it was already mentioned, idk).

  • As someone already mentioned is the thread (I forget who, sorry), using an Intel HD Graphics 3000 iGPU for video output with a Tesla is not possible: Windows 10 won’t allow using the Tesla for graphics rendering if the Intel drivers are installed, no matter what, while it will allow it if they’re not but in that case the performance is garbage.

  • The M40 can’t work on a P8Z68-V/GEN3, even with options to enable 4G decoding and disable CSM unlocked in BIOS through AMIBCP (I don’t know if they actually did anything, but no combination worked).

  • They’re not easy to come by for cheap, but the ACX 2.0+ cooler used by EVGA on their 980 Ti is a great cooling solution for the M40. There’s ~15-20€ of modding to make it fit but it’s a pretty efficient cooler, even with an additional aluminium plate between it and the die. Also, the midplate and backplate are both compatible with the M40 (just a cutout to make in the midplate for the power connector) and there’s thermal pads on both for the VRAM chips. The Titan X version should be the same.

1 Like

guys did someone tried to undervolt a tesla k20x?
if yes, how you did? you had to flash a modified bios or there are some command for do it like the overclock?

one day i remember someone underpower the tesla k20 to 135w tdp but i dont remember who doing that sorry

Whatboard did you swap it to

If it is still x79 as stated it wont work without above 4g decoding

Its not so much the k40c that has directx12 issues the 780ti and allkepler have the same issues as in theory a ocd k40c to say the 1250 mark should get pretty close to a 1060 980 area but due to kepler being a weird architecture drivers and games havent been coded with kepler in mind for years vulkan doesnt evwn see much uplift for kepler either so with youre k40c id just sell it or keep it for a spare and buy a 980 seen them sell for less than 970 most of the time and when ocd a 980 is faster than a ocd furyx

@GigaBusterEXE do you have any experience about undervolting a tesla?

Nope, generally no need since they never hit thier power limit before they hit their volt limit

Is it too hot?

i think max voltage is 1 volt, but i can push at 980mhz with no stability problems, so i was thinking to lower 0,050 volt because i only use it at 901/928 mhz. So in this way i could gain 5 o 6 degrees at least. It’s not running hot, i do 60-65 at 140-155w and 70 with intensive games when reach 165-175w. But summer is coming and 5-6 degrees lower would be nice to have.

my mb is an x79, but it does have 4g decoding. 4g decoding is enabled. so this isnt the problem


this is tesla p40

I’m trying to get this to work in a vm with looking glass and gpu passthrough, looking glass is working fine, and I’ve passed an m40 and, an HD 4850 to a Windows 11 guest (I also tried Windows 10, same result) and a FirePro W4100 is giving me video for the host machine, if it matters. Anyways, the M40 appears in the list for selecting a gpu in the windows graphics options and as the “Power Saving” option with EnableMsHybrid=2, it won’t show up with a value of 1. The issue is that despite the M40 being selected, in either the Power saving mode or the manual selection, nothing actually uses it, I’m reading no gpu usage and the Nvidia setting tray activity icon is claiming the gpu is inactive

Anyone here run into anything similar?

yeah happens often with the radeon drivers, its something to do with the device order and the driver installed order, potentially the order you passed it through

if you’re going through the trough of passing through to a virtual machine theres a better method to use than the hacky windows method

craft computing has videos on it

Thanks, I’ll try with a non Radeon gpu if I can’t get things working by altering the passthrough order. I looked at the Craft Computing stuff, but I was hoping to avoid the latency and compression that VNC/Parsec apparently has. Though, if all else fails, I’ll give it a go.

2 Likes

Ah okay, didn’t know Kepler itself was the problem with DX12, thanks for the info. Of course a 980 would be much better performance-wise, especially now that the prices have dropped, but I need high VRAM more than high performance, and I don’t really care about DX12 support :wink:

I’d love to get another M40 though, but the prices aren’t low enough yet here (still around 220-240€ in total with the cooler, bracket and adapters).