Gaming, on my Tesla, more likely than you think

Try changing in bios the dedicated amount of VRAM to 1GB or 4GB for the Vega GPU

What speed is your ram running at? If it’s 2133 that could be the bottle neck

1 Like

Its not the wattage max. the only thing there that stick out is the AMD GPU clock.
Shouldn’t that be more than 400? Its also dipping a lot looks like.

My ram does in fact cap at 2133. Could be that really be that much of a bottleneck?
I’ve got a bunch of other ram. I’ll swap to something higher, swap the dedicated vram in the bios and report back.

After thinking a bit if you could manuly set the AMD GPU clock to 1500 Mhz I think that may help you some.

Edit: You can manuly set the P40 threw CMD ran as admin with nvidia- smi to check then use nvidia-smi -ac 3615,1531 to set the clocks.

On a closer inspection, my GPU clock keeps rapidly jumping between 400MHz and 1900MHz.

Also applied the command without change.

See if you can lock the AMD to 1900.
As for the P40 that looks normal and shoud stay there, might change after a reboot not sure if it gets cleared then.
At any rate its lock there for now.
Edit: nvidia-smi -q -d SUPPORTED_CLOCKS will show all supported clocks for the P40 and all Nvidia cards back to a certain year.

I’ve got the CPU locked at 1900 finally. Swapped to two sticks of 8gb 3000 ram. Set the vram of the vega graphics to 4gb in the bios. Still the exact same results with the benchmark though. Or well it’s 3247 now with the same settings. A touch better but still nowhere near what I should be getting I’m afraid.

I’ve heard tails of problems with AMD cards here in this thread.
Not saying that is the problem because its strange it also ran the same with the K1200.
I’ve heard tails of the order the AMD and Nvidia drivers being installed causing some problems.
But not sure if that would be related here in this case.
I have loooked at the K1200 in the past but I’d have to look it up again to refresh my memory on that card.
Keep banging at it we’ll find the problem lets hope.

1 Like

I appreciate the help a bunch. I was using an M40 prior to this a few months ago and I knew something was wrong because they were getting nearly identical performance. I’ve also tried an Athlon 3000g, Ryzen 3 3200g, ryzen pro 4300g, and ryzen 4100 with the k1200 as video out on the new P40 and I’ve gotten nearly identical performance with all of those configurations. I’ve also swapped motherboards twice across 3 windows installs.

Edit: So I swapped to my 2666 ram and it’s getting in the mid 4000s now in Heaven. I don’t know why it’s outperforming the 3000. But I think this might actually be the issue. I couldn’t have imagined it would have changed my score this much already.

Wow that’s a lot of work and not found the problem.
Only other thing I see in your GPUZ SS is Physx not showing as being installed.
I wouldn’t think that would be the cause but worth a shot.
DL Physx form the net install if the install says its already installed go to control panel/programs and uninstall it then reinstall.
If I’m reading GPUZ right the AMD card has only 512mb video memory.
I think you’d be better off with the K1200 as it shows to have 4gb.
You may have to use a older driver like 463.15 since its a Maxwell to get support in a driver.

EDit I just saw your edit that could be dew to memory timing. These newer memorys chips can sometimes have hight memory timming. The lower the better.
You can see the memory timings they are set at in CPU_Z.

Unfortunately even though my CPU can support up to 3200MHz ram and my bios have been reset + updated, it’s failing to so much as recognize any of my newer mixed brands of 3200MHz sticks with better memory timings so I’m trying to get to the bottom of it.

Going from 2944 to 4239 on my benchmark by swapping ram from my 2133 pair to my 2666 pair has made me certain that’s what the issue was though so thank you for helping me get to the bottom of it!

Look at the ram support list for your motherboard may give a clue as to why some are not working or working correctly. Some motherboards have advance setting and timing changes kind of like overclocking with tighter timming.
Edit: you may also be able to place the 3000 back and under clock those in bios inbetween 2666 or at 2666 and get better timings that may or may not help.

1 Like

I’m going to need to invest in some specific ram, but with Physx installed as well I’m sitting at 4571 in Heaven with the same settings as before which makes me certain it had to have been the RAM. Thank you both very very much for your help.


Welcome to tht forum.

-dm ?

run command as admin
nvidia-smi -dm 1
enable wddm
or nvidia-smi -dm 0

Aw okay. I was a little lost with the really old post you quoted.

nvidia-smi --gom=0

nvidia-smi -dm 0

nvidia-smi –q –d SUPPORTED_CLOCKS

nvidia-smi -ac ram,mhz

nvidia-smi dmon

switch to graphics and compute needs

then run physicx to auto

trun integrated in direct 3d settings to basic or general profile

then open gl to auto

and the cu to your main server accellerators

for the specific application on the add program tab at top right

for example you can run explorer on the server accellerators

delete unnessesary

then right click on desktop and select graphic settings on the bottom of the settings of display settings

add program and select preformance accellerator

unlock on firewall and gpedit.msc

run program

mostly all on



error correction code …on or off on application

Most of us old guys at this already know those, but thanks for posting it again for some new to this.

hello again, so I am having a rather bizarre problem when trying to update my NVIDIA driver. So the 517.71 driver I originally installed when I first got my p40 has worked great since then. I havent had any issues gaming on it until now.
After I try to install any driver other than the 517 on I get 1 of 2 outcomes, mostly I go to restart and my pc crashes right after posting and I have to either go into safe mode and uninstall the tesla or do a system restore. the other thing that happens is everything loads great but when I go to open ANY 3d application involving the tesla it either crashes ( Starfield just sits there frozen black screen ) or I get a tdr failure.
I am completely stumped I have tried everything I can possibly think of I have used ddu I’ve tried clean install with and without using the add hardware option using both the quadro p6000 template and 1080 ti. also when I tried those I used the quadro driver and geforce respectively. I have even tried taking the IGU out of the equation and installing a quadro k5000, and gtx 690. when I try that route i only get a hard crash upon reboot. i also am installing the matching 474.44 that is compatible with all 3.
I am completely stumped. Any help would be much appreciated.