Return to Level1Techs.com

Did I get a defect router?

routers
#1

As mentioned in another thread I bought an ASUS RT-87U router. From the start I experienced problems related to ssh. Furthermore, on some clients I am unable to connect to some sites. For example amazon.de does not work properly, while amazon.com does; I am also able to log into binance.com, but checking my portfolio doesn’t work properly.
I also noticed that sometimes I am unable to perform nslookups.

All of these problems are related to the 5GHz WiFi, my 2.4GHz WiFi works fine (but isn’t quite as fast).

Things I have tried to solve this issue:

  1. factory reset of the router

  2. different firmware (well I wanted to try it regardless XD), Merlin in my case

  3. Toying around with settings…

Now, as a little additional info: The apartment I’m living in is rather small and the problems occur even right next to the router. So, I don’t have hundreds of walls between my devices and the router.

Any ideas? Is my router indeed defect am I doing something wrong?

0 Likes

#2

Some devices don’t play well with channel bonding or whatever it’s called, where you use wider channels for more bandwidth. Try setting the router’s channel width to 40 or even 20 and see if you still have problems.

You could also try other channels in case it’s just interference

1 Like

#3

Thanks, I immediately went ahead and tried a different channel width (it was set to 80). I tried 20 and 40, but didn’t notice any difference, beside 20 being noticeably slower :frowning:
In case someone’s interested, these are my network settings:
wifi5

0 Likes

#4

Sounds like a dns resolution issue. Try changing your local machines dns to something like 9.9.9.9

For good measure do ipconfig /flushdns to clear existing dns cache.

If that works, try applying it to the routers dns setting, changing your computer back to automatic.

Let me know what happens and we’ll go from there.

1 Like

#5

I edited resolv.conf to 8.8.8.8 (it was at 1.1.1.1, which I have set on the router) and after hitting performing a DNS flush, Amazon worked, but Binance required a second dns flush (??). I haven’t tested this yet on other devices with different operating systems, nor do I know how to change the DNS on my wife’s phone :frowning:

Concerning my router: After performing a factory reset, I tried setting the DNS server to 1.1.1.1, because I noticed this problem and thought using a different one might change this issue.

0 Likes

#6

try doing a 30-30-30 reset and if that still doesnt seem to make a difference, flash stock.

0 Likes

#7

I have noticed sometimes, I have to flush DNS settings four or five times in a row to completely flush DNS. I would try flushing DNS again this time do it four or five times right in a row.

0 Likes

#8

Channel bonding has nothing to do with a DNS resolver issue that he seems to be having

That does not traditionally work on these routers. What he needs to do is perform the steps of the recovery factory reset. Place the router in recovery mode:

On your Router The 66u and 87u are very very similar save the internals

Press the power button to turn off the router.

Press and hold the button [RESTORE] for about 5 seconds.

While still pressing the [RESTORE] button, press the power button to turn on the Wireless Router

If the power light is flashing-slow, this means the wireless router is in Rescue Mode.

Now that you are in restore mode. Upload the firmware of your choice. Merlin or stock… set your computer wired directly to a default gateway of 192.168.1.1 and load the firmware

https://asuswrt.lostrealm.ca/

You will likely never get third party firmware support… The broadcom driver you have will not ever have support in Tomato and OpenWRT according to authors. There are developers trying to but its a horrible router for tweaking.

Okay so after you restore login via ssh after you set that up and run mtd-erase -d nvram

Or if you cant ssh turning off our router, and holding the WPS button for 30s(maybe) while you power on it. the router will reset it self.

Some of the reasons you might be having problems is asus ditched support REAL quick for this router which means they short changed their engineering process. I dont like giving @Azulath news like that but its probably true. Ill take a look at its internals I probably have on laying around and see what kind of workarounds their software is doing…

In the meantime see if that fixes your DNS resolver issues… try to use google dns for it

0 Likes

#9

it works just fine for the kind of reset I wanted him to do. I hate threads like these because people always jump in with another step without letting anyone else finish what they were trying in the first place.

Always too many cooks in the kitchen.

0 Likes

#10

Yeah I want him to perform the reset first and a nvram clear thats always my first step to diagnosing the issues but the OP is not far off. It really could be bad software. Asus ditched support very early and merlin has admitted its his least favorite on his forums.

root # uname -a
Linux soc1 2.6.35.12 
root # cat /proc/cpuinfo

Processor Family: ARC 700 [0x33]
CPU speed :     500.00 Mhz
Timers:         TIMER1 TIMER0 
Interrupt Vect Base:    0x88026800 
Peripheral Base: NOT present; assuming 0xCOFC0000 
Data UNCACHED Base (I/O): start 0xc0 Sz, 1024 MB 
Bogo MIPS :     248.21
ARC700 MMU Ver [2]
   PAGE SIZE 8k
   JTLB 128 x 2 = 256 entries
   uDTLB 8 entr, uITLB 4 entr
TLB Refill "will NOT" Flush uTLBs
Detected I-cache : 
  Type=2 way set-assoc, Line length=32, Size=16K (enabled)
Detected D-cache : 
  Type=4 way set-assoc, Line length=32, Size=16K (enabled)
Extensions:
   MPY: 32x32 with ANY Result Reg   MAC MPY: Dual 16 x 16 and 32 x 16
   DCCM: N/A  ICCM: N/A
   CRC: N/A,   SWAP: Present   NORM: Present
   Min-Max: Present,   Barrel Shifter: Present
   Ext Arith Insn: Present
Floating Point Extension: N/A

Ewww… Okay I know a bit about the hardware. Its a broadcom qantenna hybrid… I guess they probably chose this for the reason it was the first AC wave 2 chip at the time

None of this should interfere with the OPs DNS resolver though

0 Likes

#11

Its all yours bud, I wont try to help any more.

0 Likes

#12

nah man you did good… recommending a reset :slight_smile: I cant help alone hah

@Azulath scratch what I said about favorite firmware GO TO STOCK first

1 Like

#13

I did the 30-30-30 method and flashed stock firmware, but it was to no use. I’m still not able to connect to Amazon properly.

I also have to correct my statement above: I do have these problems even when I’m directly connected via an Ethernet cable. Furthermore, when I unplug the cable and put it into the modem everything seems to work. I’ve also used my piHole as DNS server again (I stopped using it because I thought it might be the culprit…DNS filtering and such :wink: ). I can clearly see my devices requesting the name of the server, but they don’t seem to get an answer. (Weirdly enough, nslookup s and dig s work often).

Which is why I’m not so sure if this issue is entirely DNS related. It seems rather that the router “withhold” the information or doesn’t pass it to the right client.

Also, I can still send the router back, no questions asked till Thursday…

@Heimdallr: The 30-30-30 method did reset the router. Should I perform your steps as well and clear nvram, or do I just need to clean nvram now?

0 Likes

#14

Yes the reason I say 30-30-30 does work on this routers is because it wont clear the nvram. It only resets settings… a quirk ASUS did with their ROM.

If after restoring to stock… and NVRAM clear and setting your DNS resolvers to 8.8.8.8 you still have strange software issues on the router… return it and get an RT-AC68U you will be much happier.

@Adubs has the correct mentality

1 Like

#15

I would just send it back tbh. It shouldnt be like this out of the box, and I personally dont think its worth this much hassle.

1 Like

#16

Thanks, I’ll try this later and I’ll give you a heads-up.

1 Like

#17

Are you on dsl or cable? I’m wondering if it’s maybe related to firewall/ICMP/MTU issues.

1 Like

#18

The router is connected via an Ethernet cable to my modem.
So, cable :wink:

@Heimdallr: What I also sort of fear is having to clear the nvram every couple of days or things like that. But I’ll give it a try and see what happens.

0 Likes

#19

Hmm Okay interesting question when you configure DNS are your forwarding to upstream you defined (option in the GUI) or are you computers finding the DNS server at 192.168.1.1?

and whos your provider. I really want you to be able to enjoy your purchase before we consider others…

Also my personal choice would be a ASUS RT-AC68 U but if you wanted no broadcom cuz say you wanted to tweak with third party firmware id roll a https://wikidevi.com/wiki/TP-LINK_Archer_C7_v1.x

1 Like

#20

if you ever have to clear it again it suggests a memory fault. That being said it should NOT affect DNS resolve… this is a strange issue lets rule out your cable provider first

1 Like