Return to Level1Techs.com

Unable to connecy by SSH with certain clients

linux
helpdesk
networking
#1

I have a couple of devices running in my home and usually connect to them via ssh if I need them to do something. But since I’ve added my new ASUS router, ssh started to behave weirdly. (All of my devices are connected to the router and the router is connected to my modem/gateway by an Ethernet cable).

Anyway, as mentioned in the title I am unable to connect to all of them. I’ll detail the sequence of errors/problems to the best of my knowledge in order to help you guys help me solve the problem.

First: I have two WiFi dongles, one supporting 2.4GHz, the other supporting both. Initially, I’ve been using the 2.4 dongle on my RPi3 running LibreELEC, but I figured 5GHz would be better since it is rather close to the router and also, why not XD.
But when using the 5GHz dongle I wasn’t able to ssh into the RPi3 on certain devices. I didn’t investigate the problem further, since I had other issues and currently my RPi3 is connected through PowerLAN and I haven’t had any ssh issues thus far.
Today, I started using the 5GHz dongle on a notebook (which I also connected to my 5GHz WiFi) and I had the same problem.
The following devices were able to connect to it:

  • PiHole - Ethernet

  • Notebook - Ubuntu 19.04 WiFi 5GHz native

  • Android tablet - 5GHz WiFi (App: Terminus)

The following devices were not able to connect:

  • Notebook - Manjaro, WiFi 5GHz native

  • Android smartphone - 5GHz WiFi (App: Terminus)

At first I tried deleting my .ssh folder just to be sure, but this didn’t solve my problem. I then decided to switch from 5GHz to 2.4GHz and now everything works fine on my Fedora notebook, but…

Suddenly, I am unable to connect to my Ubuntu notebook, without any reboot on the notebook one but one on my routers side. Again, my tablet, PiHole and Fedora are able to connect but my Manjaro notebook for instance isn’t.

The hang on all three machines started after the password input, here is the output when executing ssh -vvv:

[email protected]'s password: 
debug3: send packet: type 50
debug2: we sent a password packet, wait for reply
debug3: receive packet: type 52
debug1: Authentication succeeded (password).
Authenticated to ubuntu ([192.168.2.117]:22).
debug1: channel 0: new [client-session]
debug3: ssh_session2_open: channel_new: 0
debug2: channel 0: send open
debug3: send packet: type 90
debug1: Requesting [email protected]
debug3: send packet: type 80
debug1: Entering interactive session.
debug1: pledge: network
debug3: receive packet: type 80
debug1: client_input_global_request: rtype [email protected] want_reply 0
debug3: receive packet: type 91
debug2: channel_input_open_confirmation: channel 0: callback start
debug2: fd 3 setting TCP_NODELAY
debug3: ssh_packet_set_tos: set IP_TOS 0x48
debug2: client_session2_setup: id 0
debug2: channel 0: request pty-req confirm 1
debug3: send packet: type 98
debug2: channel 0: request shell confirm 1
debug3: send packet: type 98
debug2: channel_input_open_confirmation: channel 0: callback done
debug2: channel 0: open confirm rwindow 0 rmax 32768
debug3: send packet: type 1
client_loop: send disconnect: Broken pipe

I have also VNC servers running on both notebooks and I am able to connect without any issues…

0 Likes

Did I get a defect router?
#2

To make matters even more interesting:

My Ubuntu notebook’s DNS service doesn’t appear to run properly on 2.4GHz. In order to get it to run, I have to restart it manually. If I’m connected to the 5GHz WiFi everything works fine…

0 Likes