Return to Level1Techs.com

Decided to try Intel z590, and facing Driver issues in Win 10 x64. (╯°□°)╯︵ ┻━┻

Hey all,

CPU: 11700K
UEFI: Stock (didn’t get a chance to update it), noticed some others are having bigger issues by updating their BIOS or installing ME drivers.

I’ve responded to the thread on ROG forums, where one of the devs has provided the correct driver to use. [DRIVERS] Intel Ethernet/WiFi/Bluetooth - Page 8

It’s meant to be as simple as installing a .inf file, but I did that, rebooted, and nothing.

I also tried some drivers off the Intel site and it bricked the Win10 install from booting. Thankfully, it’s a new build and I’m just smoke testing it.

If any brave souls have been down this path, care to share some advice?

Thanks!
Cheers M.

cc: @wendell

1 Like

P.S. thankfully the bloody Wifi driver installs fine, the only damn driver that works. Bluetooth as well.

Fudge nuts, I’m fuming. (╯°□°)╯

You probably need chipset drivers.
http://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=fileinfo&id=4908&lang=en

Also, note that subsequent BIOS updates add some noticeable performance improvements.
Here are the newest MEI drivers too: http://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=fileinfo&id=4877&lang=en

You can find all the latest driver updates at Station-Drivers - News

1 Like

Thanks tour advice was spot on. Here’s the thing though I did try installing the MEI pack but it errors out just like the version you linked.

I traced the error to a need of .NET v4.6.2. Ok installed. Chipset driver installs fine. Yay!

Intel I225-V no luck. Boo.

Also Asus board is playing up. If I attach a second SSD I can never get my working install to boot. Even if I remove that additional drive. What’s going on? I’ve seen this behavior with my 1950X Threadripper boxes (both with Zenith Extreme mobos. I could never get Win10 to install on them)

You need to change the boot order so the OS loads from the drive you want it to. Go fiddle with the BIOS settings. Also, you should certainly do a clean installation to be on the safe side.

All are fresh installs and I’ve corrected the boot order. I even hold F8 and pick the boot drive. It plays dead.

Progress so far. Now I’be done a fresh install with 2x SSDs attached I’m going to remove the second, and see what this does.

I can confirm this odd behavior -

UEFI changes:
XMPII enabled (vendor settings only)
Virtualization enabled
Secure boot enabled (defaults)

  1. Fresh install onto 1x SSD (primary)
    Install -
    .NET 4.6.2
    Chipset drivers
    Bluetooth driver
    WiFi driver.

Power off, attach second SSD
Boot off primary via F8
After main Asus F2/Del display second smaller Asus logo and Win10 spinner missing - black display.

Same procedure above but started with both drives attached
Power off, removed the second SSD
Primary no longer bootable.

I’ve done over 6 fresh installs to troubleshoot this.

Thanks.

Is CSM enabled? Though with secure boot on, it shouldn’t be.
What kind of GPU do you have? Integrated graphics? Exact motherboard model?

Im asking because it wasnt asked. What mb do you have?

Cannot mange CSM as all the options are greyed out.

I’ve tried with secure boot - set to windows or Other OS

Using integrated graphics for now. I plan to add a gpu once I get it into a case.

Asus z590 Strix gaming-E wifi

Thanks. Please see my previous post.

I’ve now loaded optimized defaults but cannot get the previously working SSD to boot. There’s no way I can rely on such a system as a workstation.

Hmm.

Do you have a RAID setup? What’s the GPU?

Drivers can be found here if you don’t know:

You’ll also need the latest windows build since Z590 is a very recent platform.
https://www.microsoft.com/software-download/windows10

1 Like

No RAID just a single SSS attached. No GPU installed. Used integrated graphics.

I’m doing a barebones test with the system fitted on a cardboard box. Think of this as a smoke test.

Now that could be a factor!! But how come I’m able to install from an older build? I even ran the windows updater and it says nothing more to update.

It only stops booting if I either add another drive or remove a drive present since boot

Well, the drive you are attaching must be faulty. Try testing it on different computer with Crystal Disk Info.

In can confirm the drives are fine. It’s just that the Asus UEFI looses track of its MBR partition etc. I’ve experienced this same issue before on the Zenith extreme boards.

The trick I used back then when I ran XenServer was to rerun the installer to repair the boot partitions.

I’ll try the Win10 ISO to try and upgrade. Will report soon. Thanks mate.

Well, you shouldn’t use MBR anyway. Go with GPT. How are you shutting the computer down? Doing a reset could trigger such a behavior (holding the power key, switching off the PSU).
What are drive models you have?