Brandnew 10G server with RAID 10, SMB files transfers @ 11MBs [SOLVED!]

my old garbo external raid box still managed 111MBs i even killed my camera NVR software and rested. the raid10 it’s self is still pulling some speeds on crystal diskmark. if i copy from or to the raid, from or to the host’s C drive i still get very good speeds and of course as i said from a 1gbs client on the network i get 11MBs read or write, which before was like 100+MBs over said gig network with my garbo raid box beforel

here is my new server build: X570D4I-2T U-NAS build


Windows Server 2019
Ryzen 3400G quad core
2x 16gb Kingston ECC DDR4 SODIMM
Dell PERC H700 1gb RAM RAID card
4x SeaGate Iron Wolf NAS 12Tb 7200rpm
AsRock X570D4I-2T motherboard w/ Intel X550 10g Nics and BMC
U-NAS case w/ Delta PSU 2xx watts
Some laptop blower fans

all decent stuff, enterprise gear for the home network, too.

is the fact i opened up the SMB share to public permissions for the LAN? is it something else? are there options i need to enable in windows server 2019? is SMB single threaded?

any TS i can try?


EDIT: FYI i also have NFS enabled on the file share as well. i wanted to try that out with linux. also public. (i want any lan connected device to be able to just grab files or auto find the shares)

and in case anyone asks, i know the difference between megabit and megaBYTE. i knows that’s step one of TS.

Have you checked if you network connection actually works at 1Gbps, since 11MB/s sound like the network card only doing 100Mbps.


it previously pulled 111MBs with my old storage solution on the same server. 11Mbs comes to around 800megabits per second.

EDIT: disabling NFS made no difference

EDIT: I MADE A TYPO, it should say 111MBs is around 800mbps

1 Megabyte = 8 Megabits
11 Megabytes = 88 Megabits
100 Megabytes = 800 Megabits

How are these machines connected. Is the link negotiating to 100Mbps instead of Gigabit?

1 Like

…wait a minute… the power went out the other night. the main switch takes minutes to boot. NO WAY my desk switch could negotiate 1G to switch that isn’t booted yet.

WINNER WINNER CHICKEN DINNER! …bonus points… i when the wall to unplug and re-plug said desk switch and the cable is right proper kinked/bent at the boot. …a jacked cable AND a power outage! …i’d say it was 100meg alright!

…to verify speedtest confirmed 80meg prior and 180meg after! file transfers now 104MBs!


Glad it worked out!


This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.