Return to Level1Techs.com

Beware windows 10 file compression

Since the death of 7 was upon us, i put 10 on all my machines and nothing big other than new bloatware really happened, then windows decides my very full ssd needed to have every fucking non OS file on it compressed. 10GB free is cutting it close but this is a default and i have to check and see if this is killing my 100000000 game saves because i was too lazy to reroute default locations a long time ago (kinda my fault but still)

also RIP my FLAC

Regedit →

\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Policies

NtfsDisableCompression

set to 1

done


This fucked up a friends computer (Win 7) a while ago. Because what is worse than a slow computer with a full harddrive?
Correct! A slow computer with a full harddrive doing compression!

4 Likes

thanks for the reply, but i dont have anything other than (default) in there, i used some command that should have disabled this. do you think a dword would keep this away or should it stay dead?

Windows 10 in general:

3 Likes

Presumably it’s compressed some files due to the lack of space? As it doesn’t compress by default as far as I’m aware.

Your flac files are fine

3 Likes

Um, there are two types of compression: lossless and lossy.

Windows built in compression is lossless, so you are not losing anything. Your files if you open them are unchanged, the compression only changes how the files are stored on disk.

3 Likes

Windows has many way to achieve things.

I was going to comment on that, i checked my registry just to see if it was enabled by default, but the key straight up doesn’t exist on mine.

ignore Tixati, its an ilusion, fumes, fugazi!

Literally just ran into this issue. Copied a VHD from my computer, to an external HDD, then to my coworker’s PC. When creating the VM, it wouldn’t start because the VHD was compressed. The error actually said the VHD was either compressed or a couple other things, but I knew it wasn’t compressed on my machine, and she knew she didn’t turn compression on, so we troubleshooted the other issues. Some time later we realized Windows was messing with our files and interrupting our worflow. Nice.

Our workaround was to just decompress that one file, but I’ll hold onto this information if more problems crop up.

Did she also have little room left?

1 Like

yes. It was fine before adding the VHD, but the VHD put her into the red

So unless you set the registy or group policy, windows does as it pleases without informing the user.

2 Likes

What version of windows 10 if you dont mind me asking? (home, pro?)

I believe this may have been introduced in part to ensure that Windows can continue to run and keep up to date. The user gets informed on the low disk space, or should on a normal system so they can free up space. Not sure if it reverts after or not though. It’s definitely better than the alternative of people having zero disk space and having to wipe their system if they even know how to.

Power users who know what they’re doing can simply run

fsutil behavor set disablecompression 1
3 Likes

Pro

Windows10 has that annoying pop-up notification thing anyway, so WHY NOT TELL THE USER?

You can disable that if its annoying you… though not sure why.

How? Because all I managed is to cut it down to the point where it informs me every hour that notifications are disabled (yay “focus assist”

User Configuration > Administrative Templates > Start Menu and Taskbar > Notifications

Though you’re better just changing the permissions of the apps you don’t want notifications from, they’re all configurable in the settings menu.

Focus assist is specifically for controlling times where you want to minimise or allow only important notifications though.

Turning off notifications is the kind of thing that would lead to issues like this topic.

thanks

I don’t want to be notified about stuff. The only programm that is allowed to disturb me is HWinfo with temperature or SMART warnings.


It is not and you know that.