Best remote desktop for LAN?

I’m looking for a way to connect to a Windows machine over LAN and use a remote desktop. The workstation I’m connecting from runs Linux (OpenSUSE). Do you recommend any options - I’m looking for as fast and responsive option as possible :slight_smile: .
With the right settings RDP is near perfect - but I’m getting a strange issue. On the Windows workstation I can’t start one of the apps when rdp connection is used - it complains that there’s “not sufficient graphical hardware”. Weird (non-remotely the app starts as it should). The problem is this app is crucial to my workflow.
I’m not getting this problem with VNC, but the responsiveness is so bad there’s really no point in using it for any gui apps.

So I’m still looking for a solution - I don’t mind proprietary ones. Especially if those offer regular licenses (I’m not into this subscription nonsense).

Is running a Windows VM on your OpenSUSE machine an option?

I use this daily at work - remmina with freerdp

Works just as good as remote desktop on windows

My usecase: company runs windows server with quickbooks (non enterprise - hence having to run it on windows) hosted on it. I enter clients into quickbooks via remote desktop. Has printer redirect, microphone share, and clipboard sync built in.


Ive had a lot of issues with remmina and screen flickering. I have found that nomachine is very good. You get global copy paste and file transfer. Def my go to at home and work

thats an odd issue, ive been using it with no problem for about 2 years with regular updates

1 Like

Believe me its not an old issue I tried using the nightly recently and on kubuntu both remmina and rdesktop give me flickering.

probably because of rdesktop protocol, try freerdp. remmina is just a gui for various remote desktop protocols.

rdesktop protocol:


imo freerdp works much better. both can be used with remmina

Thanks for letting me know will give it a try

thx for the suggestions.

@oO.o : the situation is a bit more tricky. I’m already using VM on my OpenSUSE desktop and I have a pcie passthrough set up. Now I’m looking for a best way to access it - not only from my host machine, but also from other workstations.

@GloriousEggroll : Remmina uses RDP / VNC connections mostly. And as mentioned neither of those do the trick.
RDP almost does - for 99% of apps it’s awesome. But I have one crucial app that does not - as soon as I share my windows workstation / VM with rdp it starts complaining about graphics and crashes.
So the problem seems to be on the “server” side , not on a client side.
Apart from that I can set up much better rdp connections from my linux client but avoiding Remmina and using xfreerdp straight away. It’s a bit tricky at first, but once you figure out the right mix of command line options you get way smoother graphics (even playing videos etc on such remote connections works without a hitch).
So yeah, I’d love to use RDP (even thorugh Remmina) but as I have no clue why this annoying app complains it is a no go :frowning: .

@blackfire: will test nomachine. At first glance looks promising :slight_smile: .

I’m also thinking about going round the issue , by streaming the windows desktop and using Synergy on client machines. Wonder whether it will work. Will need to find ways to stream desktop locally - but that’s a subject for another topic.

Its odd you’re having issues with VNC over LAN like that. RDP in windows these days has something called remote FX which will use the host GPU to draw. I’m not sure if open source alternatives can take advantage of that though. I’m not sure which versions of windows are capable of this either. Teamviewer has always been a decent compromise for me, allowing unattended connections when the program is logged in to.

Perhaps playing with the encoding options in VNC might do the trick for you? I’ve always used tightVNC and found it to be very responsive out of the box.

thx @Adubs , will give a VNC a 2nd shot. I have never been able to set it up to connect to Windows in a way that would give me smooth results. Each time I’ev tried I got unworkable (at least in gui), laggy , stuttery result.
XfreeRDP can use rfx - it is one of those command line options that improve the experience I’ve mentioned. But as I’ve said if I set remote sharing on the Windows machine (through windows remote desktop and thus use rdp protocol) I have issues with this single , extremely annoying app that I simply have to use and there’s no alternative to it (a build job prep app for a specific 3d printer).

Personally I’m a huge fan of NoMachine. It performs extremely well, is incredibly easy to setup, and is multiplatform. Even has an android client so sometimes I use it to stream my desktop to a phone or tablet. (Technically only tablets are officially supported right now because they feel that their UI needs to be adapted to fit smaller phone screens but you can still side load it)

It is proprietary, but free for personal use.

When using RDP make sure you’ve set the correct GPU to be primary. If there’s a dedicated GPU as well as an integrated one and no display attached Windows may select the wrong one. I’ve had issues like this in the past.

Other than that I’d also give VNC another shot as it works best in my experience.

1 Like

Thx for encouraging me to retry VNC. Previously I’ve been setting it up on a Windows side using TigerVNC - and as mentioned results were terrible.
But I’ve just installed TightVNC and it’s night and a day kind of difference. Very promising! I have my fingers crossed - hopefully with some tweaks I’ll be able to boost performance. Any suggestions which settings I can try on a server and on a client?
Getting back to vnc manuals :slight_smile: .


RDP is a common protocol. freerdp and rdesktop are two different “brands” that both handle the RDP protocol. It’s worth trying to see which one handles it better. Remmina can use both, i believe you have to choose the one you use from the protocol drop down for the connection’s preferences in remmina xrdp

choose RDP not Rdesktop after installing freerdp

@GloriousEggroll : as mentioned the problem is not a client side, but on a server side when rdp protocol is used along with windows remote desktop.

I’m trying to fiugre out vnc - how do you change encoding? I’ve tried:
vncviewer −CompressLevel 0 −PreferredEncoding raw

but it still defaults to Tight.

oh! try adding /admin to the address, i’ve had a problem in the past where only one user at a time could log in and that resolved it.

ex: /admin

To be honest I have no idea because I usually use VNC the opposite way around from what your setup is. My linux server is headless and I run the windows TightVNC client.

You can also use Parsec. They advertise it more for gaming with friends over the internet though. I’ve used it for some time on my local network and find it easy to setup and use.
iirc you can set it to autostart and start streaming too.