Return to Level1Techs.com

Bad WiFi performance (on RPi3) when watching a livestream

wifi
performance
#1

As mentioned in another thread I’ve upgraded my Internet to a 60MBit connection and also purchased a router since my own was not able to handle to stream everything fluidly. When speedtesting my connections everything checks out and I reach 60MBit without any problems.

However, the situation is quite different with on my Raspberry Pi 3 I use for streaming. It basically stutters every few minutes, especially when wachting a livestream. I had this problem when my RPi3 was new, but I figured it was due to a bad internal WiFi, which is why I switched to a WiFi USB dongle which solved the problem. Sadly, this stuttering has returned even with my WiFi dongle and I’m not sure what’s causing this issue and/or how to solve. I’m not entirely sure that this is caused on my end, but I don’t really know how to test for this.
Any help would be appreciated :slight_smile:

0 Likes

#2

The onboard wifi is a cheap, shoddy little chip. Need a usb adapter to get any throughput out of them

Also IIRC all IO shares bandwith on the usb root hub so good luck pushing much anyways.

1 Like

#3

Thanks, but as mentioned in my post I’m already using a WiFi dongle. As for the USB controller, there is only the WiFi dongle and an external 3.5" drive connected to it. (The drive is turned off for most of the time).
Thus, I doubt I’m straining the controller to much, or am I missing something?

0 Likes

#4

As above, so below. Your choke point is the USB root hub whether you use the onboard networking or a dongle.

You may be able to fix the reset issues by forcing power management off in your networking config, and using a high amperage supply for the pi (that mechanical drive is probably stressing it a bit) but you’ll never get better raw throughput out of it, even with the ethernet port.

1 Like

#5

I thought you missed my dongle-statement.

Anyway, I think I have purchased a good high amperage supply for my Pi3 and the mechanical drive is deactivated most of the time (and it also has a power supply of its own, so it doesn’t draw power from the USB port).
So, basically the RPi3 working before was just some luck? :frowning:

0 Likes

#6

if you didn’t make any configuration changes, then yes.

SBCs are somewhat more vulnerable to electronic interference as well, maybe try throwing a cage on it (doubt itll help but it might)

1 Like

#7

Dammit, but thanks for your help.

0 Likes

#8

I’ve had zero luck using wifi with my RPi2. Trying to transfer something through wifi with a USB stick was really painful and never worked properly.
Maybe you could try to enable at your own risk and higher amperage through the USB ports and see if that fixes the issue (normally the USBs are limited to 500mA).

1 Like

#9

If you have a USB3 device plugged in, it can interfere with 2.4Ghz wifi and bluetooth connections plugged in close-by. Very common problem. Try unplugging any other USB devices, or switching to 5Ghz wifi if possible.

1 Like

#10

guess we should also mention that rpis have no networking acceleration, so if most of the cpu time is taken by something like video decoding, your network performance will suffer as a result.

1 Like

#11

I’m pretty sure the USB 3.0 2.4GHZ interference issue is caused by the USB 3.0 ports, which a Pi doesn’t have. I might be wrong, but I don’t think it is created by the peripheral but rather the host controller.

The real question is if you were having an issue with the onboard wifi, did you test it with an ethernet cable? Lots of variables that affect wifi could be ruled out with an ethernet cable. If you were once able to make it work to your satisfaction then I would break it down to bare bones to recreate the good performance, and reintroduce things one at a time until performance tanks - starting with ethernet, no external devices beyond a mouse, and good power.

That means more than just an appropriately rated PSU. Voltage drop across undersized conductors, along with the terrible MicroUSB connectors (they’re all terrible for this task) means you really need either an externally powered hub or a clean 5.2VDC coming from your PSU, or better yet both. Just unplugging and plugging back in can change the resistance of the connection. I try to leave one cable plugged in and unplug the other side for consistency.

I think they have wifi analyzer apps you can use for cheap/free, perhaps changing to another channel will help if the ethernet cable yields positive results.

1 Like

#12

you’re right about the pi not having usb3

also all of the IO on the pi is off one usb2 hub, meaning if you have raw bandwidth issues on any device its gonna be the same hard limit no matter what you do

1 Like

#13

Ahh, I thought the newest one had USB3, but you’re right, it doesn’t.

1 Like

#14

I mean it’s still a possible source of interference if it is right next to a laptop or jammed behind a PC on a desk, but my understanding is the interference greatly diminishes after a handful of inches or so.

1 Like

#15

god forbid they add a useful feature in less than 4 iterations

1 Like

#16

Thanks for all those replies :slight_smile:
Yesterday, I was rather busy amd thus unable to really check in…

@MetalizeYourBrain I could/will try that later if noething else helps.

@Ruffalo I have no USB3 device connected and I’m already using 5GHz on the Pi

@tkoham Considering mmal, which I’m using for most streams, supports hardware video decoding and Netflix decoding runs in software without any issues, it doubt it really is CPU related.

@KleerKut Afaik my power supply isn’t too bad, but the Ethernet idea is a good one. Which is why, I unplugged my WiFi dongle and connected my Ethernet cable. At the moment there aren’t any issues. That being said, I’ll keep it running for a couple of days to be sure.

0 Likes

#17

it’ll stop it from hogging all the cpu time, but it’s not going to magically eliminate the memory demand or take it all off the cpu either.

not using mmal means barely functional standard definition vs decent playback in the first place, there’s a very small resource pool on those devices.

0 Likes

#18

Wait wait wait everyone stop

Is there not a shield to decode video? Or to do a similar thing? I’m feelin for ya buddy otherwise if adding hardware isn’t an option.

0 Likes

#19

I’ve switched from LAN to PowerLAN and everything still seems to work. In a few days, I’ll probably try one of my WiFi dongles again.

0 Likes